Linux NFS development
 help / color / mirror / Atom feed
* [PATCH] nfsd: Simplify the allocation of slab caches in nfsd_drc_slab_create
@ 2024-02-01  8:19 Kunwu Chan
  2024-02-02 14:13 ` Benjamin Coddington
  0 siblings, 1 reply; 5+ messages in thread
From: Kunwu Chan @ 2024-02-01  8:19 UTC (permalink / raw)
  To: chuck.lever, jlayton, neilb, kolga, Dai.Ngo, tom
  Cc: linux-nfs, linux-kernel, Kunwu Chan

Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Make the code cleaner and more readable.

Signed-off-by: Kunwu Chan <chentao@kylinos.cn>
---
 fs/nfsd/nfscache.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/fs/nfsd/nfscache.c b/fs/nfsd/nfscache.c
index 5c1a4a0aa605..64ce0cc22197 100644
--- a/fs/nfsd/nfscache.c
+++ b/fs/nfsd/nfscache.c
@@ -166,8 +166,7 @@ nfsd_reply_cache_free(struct nfsd_drc_bucket *b, struct nfsd_cacherep *rp,
 
 int nfsd_drc_slab_create(void)
 {
-	drc_slab = kmem_cache_create("nfsd_drc",
-				sizeof(struct nfsd_cacherep), 0, 0, NULL);
+	drc_slab = KMEM_CACHE(nfsd_cacherep, 0);
 	return drc_slab ? 0: -ENOMEM;
 }
 
-- 
2.39.2


^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2024-02-04  3:19 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2024-02-01  8:19 [PATCH] nfsd: Simplify the allocation of slab caches in nfsd_drc_slab_create Kunwu Chan
2024-02-02 14:13 ` Benjamin Coddington
2024-02-02 14:24   ` Jeff Layton
2024-02-04  3:19     ` Kunwu Chan
2024-02-03  0:35   ` NeilBrown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox