From: Bart.VanAssche@wdc.com (Bart Van Assche)
Subject: [GIT PULL] nvme update for Linux 4.14, take 2
Date: Wed, 30 Aug 2017 15:46:33 +0000 [thread overview]
Message-ID: <1504107991.2526.16.camel@wdc.com> (raw)
In-Reply-To: <a798247e-cc89-f189-4ad9-92095a86106e@grimberg.me>
On Wed, 2017-08-30@18:33 +0300, Sagi Grimberg wrote:
> > > I just realized that patch:
> > > --
> > > commit d352ae205d8b05f3f7558d10f474d8436581b3e2
> > > Author: Bart Van Assche <bart.vanassche at wdc.com>
> > > Date: Thu Aug 17 16:23:03 2017 -0700
> > >
> > > blk-mq: Make blk_mq_reinit_tagset() calls easier to read
> > >
> > > Since blk_mq_ops.reinit_request is only called from inside
> > > blk_mq_reinit_tagset(), make this function pointer an argument of
> > > blk_mq_reinit_tagset() instead of a member of struct blk_mq_ops.
> > > This patch does not change any functionality but makes
> > > blk_mq_reinit_tagset() calls easier to read and to analyze.
> > > --
> > >
> > > Makes it impossible for me to move controller reset flow to
> > > nvme-core without adding a trampoline (as the reinit_request
> > > is transport specific)...
> >
> > Hello Sagi,
> >
> > Sorry but I doubt that that patch makes it "impossible" to move controller
> > reset flow to the NVMe core. There are already several function pointers in
> > the nvme_ctrl_ops data structure and there is one such data structure per
> > transport. Had you already considered to add a function pointer to that
> > structure?
>
> I have, that's the trampoline function that I was referring to, it feels
> a bit funny to have aa nvme core function that would look like:
>
> int nvme_reinit_request()
> {
> return ctrl->ops->reinit_request()
> }
>
> I can easily do that, but doesn't it defeat the purpose of blk_mq_ops?
I don't think so. Request reinitialization is an NVMe concept that is not used
by any other block driver, so why should the pointer to the reinitialization
function exist in blk_mq_ops?
Bart.
next prev parent reply other threads:[~2017-08-30 15:46 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-08-29 15:05 [GIT PULL] nvme update for Linux 4.14, take 2 Christoph Hellwig
2017-08-29 15:10 ` Jens Axboe
2017-08-30 15:10 ` Sagi Grimberg
2017-08-30 15:28 ` Bart Van Assche
2017-08-30 15:33 ` Sagi Grimberg
2017-08-30 15:46 ` Bart Van Assche [this message]
2017-08-30 15:53 ` Jens Axboe
2017-08-30 16:05 ` Sagi Grimberg
2017-08-30 16:11 ` Bart Van Assche
2017-08-30 16:47 ` Sagi Grimberg
2017-08-30 16:56 ` Bart Van Assche
2017-08-30 20:59 ` Sagi Grimberg
2017-08-31 13:10 ` hch
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1504107991.2526.16.camel@wdc.com \
--to=bart.vanassche@wdc.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox