From: Bart.VanAssche@wdc.com (Bart Van Assche)
Subject: [GIT PULL] nvme update for Linux 4.14, take 2
Date: Wed, 30 Aug 2017 16:56:28 +0000 [thread overview]
Message-ID: <1504112187.2526.47.camel@wdc.com> (raw)
In-Reply-To: <a2945cf7-93e5-11da-0780-3472b29f18bc@grimberg.me>
On Wed, 2017-08-30@19:47 +0300, Sagi Grimberg wrote:
> > > If we get to choose, my preference would be to restore the old behavior
> > > because currently existing nvme transports keep their internal ctrl
> > > representation in the tagset->driver_data as they implement
> > > init/exit_request. Bouncing in nvme core would require to change that
> > > and always keep struct nvme_ctrl as the tagset->driver_data and convert
> > > it on every handler...
> > >
> > > Everything is doable but it seems like an unneeded hassle to me...
> >
> > Sorry but I'm not convinced that it would be necessary to change what
> > tagset->driver_data points at. How about moving blk_mq_reinit_tagset() from
> > the block layer core to the NVMe core, to rename it and to pass a pointer
> > to the nvme_ctrl data structure to that function instead of only block layer
> > information?
>
> That would mean that I need to open-code the tagset iteration in nvme
> which does not feel like something a driver should do.
How about renaming blk_mq_reinit_tagset() into blk_mq_tagset_iter() and
to make the argument list of blk_mq_tagset_iter() more similar to that of
blk_mq_queue_tag_busy_iter() such that callers of blk_mq_tagset_iter()
can pass a pointer to any structure through the @priv argument? That would
make this function more general and maybe also more useful to other block
drivers.
Bart.
next prev parent reply other threads:[~2017-08-30 16:56 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-08-29 15:05 [GIT PULL] nvme update for Linux 4.14, take 2 Christoph Hellwig
2017-08-29 15:10 ` Jens Axboe
2017-08-30 15:10 ` Sagi Grimberg
2017-08-30 15:28 ` Bart Van Assche
2017-08-30 15:33 ` Sagi Grimberg
2017-08-30 15:46 ` Bart Van Assche
2017-08-30 15:53 ` Jens Axboe
2017-08-30 16:05 ` Sagi Grimberg
2017-08-30 16:11 ` Bart Van Assche
2017-08-30 16:47 ` Sagi Grimberg
2017-08-30 16:56 ` Bart Van Assche [this message]
2017-08-30 20:59 ` Sagi Grimberg
2017-08-31 13:10 ` hch
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1504112187.2526.47.camel@wdc.com \
--to=bart.vanassche@wdc.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox