* Re: [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation [not found] ` <20190115162837.5399-3-thomas.petazzoni@bootlin.com> @ 2019-01-16 13:27 ` Thierry Reding 2019-01-16 15:47 ` Tony Lindgren 0 siblings, 1 reply; 5+ messages in thread From: Thierry Reding @ 2019-01-16 13:27 UTC (permalink / raw) To: Thomas Petazzoni Cc: Adrian Hunter, Kishon Vijay Abraham I, Ulf Hansson, Jonathan Hunter, linux-mmc, linux-kernel, linux-tegra, Gregory Clement, Tony Lindgren, linux-omap [-- Attachment #1: Type: text/plain, Size: 1529 bytes --] On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote: > The SDHCI core is know properly checking for the state of a WP GPIO, "know" -> "now" > so there is no longer any need for the sdhci-omap code to implement > ->get_ro() using mmc_gpio_get_ro(). > > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> > --- > Note: this patch has only been compiled tested, as I don't have the > hardware to test it. > --- > drivers/mmc/host/sdhci-omap.c | 1 - > 1 file changed, 1 deletion(-) I can't runtime test this myself, but it certainly looks like this would do the right thing because it calls the core now call the very same function as this used to, so: Reviewed-by: Thierry Reding <treding@nvidia.com> Adding Tony and linux-omap for a slightly wider audience and hopefully find someone to test this on. For reference, the whole series is here: https://patchwork.kernel.org/project/linux-mmc/list/?series=66905 Thierry > > diff --git a/drivers/mmc/host/sdhci-omap.c b/drivers/mmc/host/sdhci-omap.c > index d264391616f9..c2a28930086f 100644 > --- a/drivers/mmc/host/sdhci-omap.c > +++ b/drivers/mmc/host/sdhci-omap.c > @@ -987,7 +987,6 @@ static int sdhci_omap_probe(struct platform_device *pdev) > goto err_put_sync; > } > > - host->mmc_host_ops.get_ro = mmc_gpio_get_ro; > host->mmc_host_ops.start_signal_voltage_switch = > sdhci_omap_start_signal_voltage_switch; > host->mmc_host_ops.set_ios = sdhci_omap_set_ios; > -- > 2.20.1 > [-- Attachment #2: signature.asc --] [-- Type: application/pgp-signature, Size: 833 bytes --] ^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation 2019-01-16 13:27 ` [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation Thierry Reding @ 2019-01-16 15:47 ` Tony Lindgren 2019-01-16 15:58 ` Thomas Petazzoni 2019-01-18 10:57 ` Faiz Abbas 0 siblings, 2 replies; 5+ messages in thread From: Tony Lindgren @ 2019-01-16 15:47 UTC (permalink / raw) To: Thierry Reding Cc: Thomas Petazzoni, Adrian Hunter, Kishon Vijay Abraham I, Ulf Hansson, Jonathan Hunter, linux-mmc, linux-kernel, linux-tegra, Gregory Clement, linux-omap * Thierry Reding <thierry.reding@gmail.com> [190116 13:28]: > On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote: > > The SDHCI core is know properly checking for the state of a WP GPIO, > > "know" -> "now" > > > so there is no longer any need for the sdhci-omap code to implement > > ->get_ro() using mmc_gpio_get_ro(). > > > > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> > > --- > > Note: this patch has only been compiled tested, as I don't have the > > hardware to test it. > > --- > > drivers/mmc/host/sdhci-omap.c | 1 - > > 1 file changed, 1 deletion(-) > > I can't runtime test this myself, but it certainly looks like this would > do the right thing because it calls the core now call the very same > function as this used to, so: > > Reviewed-by: Thierry Reding <treding@nvidia.com> > > Adding Tony and linux-omap for a slightly wider audience and hopefully > find someone to test this on. For reference, the whole series is here: > > https://patchwork.kernel.org/project/linux-mmc/list/?series=66905 Thanks Kishon can you please review and test? Regards, Tony > > diff --git a/drivers/mmc/host/sdhci-omap.c b/drivers/mmc/host/sdhci-omap.c > > index d264391616f9..c2a28930086f 100644 > > --- a/drivers/mmc/host/sdhci-omap.c > > +++ b/drivers/mmc/host/sdhci-omap.c > > @@ -987,7 +987,6 @@ static int sdhci_omap_probe(struct platform_device *pdev) > > goto err_put_sync; > > } > > > > - host->mmc_host_ops.get_ro = mmc_gpio_get_ro; > > host->mmc_host_ops.start_signal_voltage_switch = > > sdhci_omap_start_signal_voltage_switch; > > host->mmc_host_ops.set_ios = sdhci_omap_set_ios; > > -- > > 2.20.1 > > ^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation 2019-01-16 15:47 ` Tony Lindgren @ 2019-01-16 15:58 ` Thomas Petazzoni 2019-01-18 10:57 ` Faiz Abbas 1 sibling, 0 replies; 5+ messages in thread From: Thomas Petazzoni @ 2019-01-16 15:58 UTC (permalink / raw) To: Tony Lindgren Cc: Thierry Reding, Adrian Hunter, Kishon Vijay Abraham I, Ulf Hansson, Jonathan Hunter, linux-mmc, linux-kernel, linux-tegra, Gregory Clement, linux-omap Hello, On Wed, 16 Jan 2019 07:47:18 -0800, Tony Lindgren wrote: > > Reviewed-by: Thierry Reding <treding@nvidia.com> > > > > Adding Tony and linux-omap for a slightly wider audience and hopefully > > find someone to test this on. For reference, the whole series is here: > > > > https://patchwork.kernel.org/project/linux-mmc/list/?series=66905 > > Thanks Kishon can you please review and test? I think Adrian's comment that ->get_ro() should be called first in the core code makes sense, so I'll send a v2 with this change. Perhaps testing should be done on the v2 instead, even though I believe it should be functionally equivalent. Best regards, Thomas -- Thomas Petazzoni, CTO, Bootlin Embedded Linux and Kernel engineering https://bootlin.com ^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation 2019-01-16 15:47 ` Tony Lindgren 2019-01-16 15:58 ` Thomas Petazzoni @ 2019-01-18 10:57 ` Faiz Abbas 2019-01-18 15:32 ` Tony Lindgren 1 sibling, 1 reply; 5+ messages in thread From: Faiz Abbas @ 2019-01-18 10:57 UTC (permalink / raw) To: Tony Lindgren, Thierry Reding Cc: Thomas Petazzoni, Adrian Hunter, Kishon Vijay Abraham I, Ulf Hansson, Jonathan Hunter, linux-mmc, linux-kernel, linux-tegra, Gregory Clement, linux-omap Tony, On 16/01/19 9:17 PM, Tony Lindgren wrote: > * Thierry Reding <thierry.reding@gmail.com> [190116 13:28]: >> On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote: >>> The SDHCI core is know properly checking for the state of a WP GPIO, >> >> "know" -> "now" >> >>> so there is no longer any need for the sdhci-omap code to implement >>> ->get_ro() using mmc_gpio_get_ro(). >>> >>> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> >>> --- >>> Note: this patch has only been compiled tested, as I don't have the >>> hardware to test it. >>> --- >>> drivers/mmc/host/sdhci-omap.c | 1 - >>> 1 file changed, 1 deletion(-) >> >> I can't runtime test this myself, but it certainly looks like this would >> do the right thing because it calls the core now call the very same >> function as this used to, so: >> >> Reviewed-by: Thierry Reding <treding@nvidia.com> >> >> Adding Tony and linux-omap for a slightly wider audience and hopefully >> find someone to test this on. For reference, the whole series is here: >> >> https://patchwork.kernel.org/project/linux-mmc/list/?series=66905 > > Thanks Kishon can you please review and test? > I can help with testing once Thomas posts a v2. Thanks, Faiz ^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation 2019-01-18 10:57 ` Faiz Abbas @ 2019-01-18 15:32 ` Tony Lindgren 0 siblings, 0 replies; 5+ messages in thread From: Tony Lindgren @ 2019-01-18 15:32 UTC (permalink / raw) To: Faiz Abbas Cc: Thierry Reding, Thomas Petazzoni, Adrian Hunter, Kishon Vijay Abraham I, Ulf Hansson, Jonathan Hunter, linux-mmc, linux-kernel, linux-tegra, Gregory Clement, linux-omap * Faiz Abbas <faiz_abbas@ti.com> [190118 10:54]: > Tony, > > On 16/01/19 9:17 PM, Tony Lindgren wrote: > > * Thierry Reding <thierry.reding@gmail.com> [190116 13:28]: > >> On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote: > >>> The SDHCI core is know properly checking for the state of a WP GPIO, > >> > >> "know" -> "now" > >> > >>> so there is no longer any need for the sdhci-omap code to implement > >>> ->get_ro() using mmc_gpio_get_ro(). > >>> > >>> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> > >>> --- > >>> Note: this patch has only been compiled tested, as I don't have the > >>> hardware to test it. > >>> --- > >>> drivers/mmc/host/sdhci-omap.c | 1 - > >>> 1 file changed, 1 deletion(-) > >> > >> I can't runtime test this myself, but it certainly looks like this would > >> do the right thing because it calls the core now call the very same > >> function as this used to, so: > >> > >> Reviewed-by: Thierry Reding <treding@nvidia.com> > >> > >> Adding Tony and linux-omap for a slightly wider audience and hopefully > >> find someone to test this on. For reference, the whole series is here: > >> > >> https://patchwork.kernel.org/project/linux-mmc/list/?series=66905 > > > > Thanks Kishon can you please review and test? > > > > I can help with testing once Thomas posts a v2. OK great thanks! Tony ^ permalink raw reply [flat|nested] 5+ messages in thread
end of thread, other threads:[~2019-01-18 15:32 UTC | newest]
Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <20190115162837.5399-1-thomas.petazzoni@bootlin.com>
[not found] ` <20190115162837.5399-3-thomas.petazzoni@bootlin.com>
2019-01-16 13:27 ` [PATCH 2/3] mmc: sdhci-omap: drop ->get_ro() implementation Thierry Reding
2019-01-16 15:47 ` Tony Lindgren
2019-01-16 15:58 ` Thomas Petazzoni
2019-01-18 10:57 ` Faiz Abbas
2019-01-18 15:32 ` Tony Lindgren
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox