Linux PCI subsystem development
 help / color / mirror / Atom feed
* [PATCH v11 0/6] Refactor capability search into common macros
@ 2025-05-05 16:34 Hans Zhang
  2025-05-05 16:34 ` [PATCH v11 1/6] PCI: Introduce generic bus config read helper function Hans Zhang
                   ` (5 more replies)
  0 siblings, 6 replies; 10+ messages in thread
From: Hans Zhang @ 2025-05-05 16:34 UTC (permalink / raw)
  To: lpieralisi, bhelgaas, manivannan.sadhasivam, ilpo.jarvinen, kw
  Cc: cassel, robh, jingoohan1, linux-pci, linux-kernel, Hans Zhang

1. PCI: Introduce generic bus config read helper function.
2. PCI: Clean up __pci_find_next_cap_ttl() readability.
3. PCI: Refactor capability search into common macros.
4. PCI: dwc: Use common PCI host bridge APIs for finding the capabilities.
5. PCI: cadence: Use common PCI host bridge APIs for finding the
   capabilities.
6. PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode.

---
Changes since v10:
- The patch [v10 2/6] remove #include <uapi/linux/pci_regs.h> and add macro definition comments.
- The patch [v10 3/6] remove #include <uapi/linux/pci_regs.h> and commit message were modified.
- The other patches have not been modified.

Changes since v9:
- Resolved [v9 4/6] compilation error.
  The latest 6.15 rc1 merge __dw_pcie_find_vsec_capability, which uses 
  dw_pcie_find_next_ext_capability.
- The other patches have not been modified.

Changes since v8:
- Split patch.
- The patch commit message were modified.
- Other patches(4/6, 5/6, 6/6) are unchanged.

Changes since v7:
- Patch 2/5 and 3/5 compilation error resolved.
- Other patches are unchanged.

Changes since v6:
- Refactor capability search into common macros.
- Delete pci-host-helpers.c and MAINTAINERS.

Changes since v5:
- If you put the helpers in drivers/pci/pci.c, they unnecessarily enlarge
  the kernel's .text section even if it's known already at compile time
  that they're never going to be used (e.g. on x86).
- Move the API for find capabilitys to a new file called
  pci-host-helpers.c.
- Add new patch for MAINTAINERS.

Changes since v4:
- Resolved [v4 1/4] compilation warning.
- The patch subject and commit message were modified.

Changes since v3:
- Resolved [v3 1/4] compilation error.
- Other patches are not modified.

Changes since v2:
- Add and split into a series of patches.
---

Hans Zhang (6):
  PCI: Introduce generic bus config read helper function
  PCI: Clean up __pci_find_next_cap_ttl() readability
  PCI: Refactor capability search into common macros
  PCI: dwc: Use common PCI host bridge APIs for finding the capabilities
  PCI: cadence: Use common PCI host bridge APIs for finding the
    capabilities
  PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode.

 drivers/pci/access.c                          | 17 ++++
 .../pci/controller/cadence/pcie-cadence-ep.c  | 40 +++++----
 drivers/pci/controller/cadence/pcie-cadence.c | 28 ++++++
 drivers/pci/controller/cadence/pcie-cadence.h | 18 ++--
 drivers/pci/controller/dwc/pcie-designware.c  | 76 ++--------------
 drivers/pci/pci.c                             | 68 ++-------------
 drivers/pci/pci.h                             | 87 +++++++++++++++++++
 include/uapi/linux/pci_regs.h                 |  2 +
 8 files changed, 188 insertions(+), 148 deletions(-)


base-commit: ca91b9500108d4cf083a635c2e11c884d5dd20ea
-- 
2.25.1


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2025-05-13  8:06 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-05-05 16:34 [PATCH v11 0/6] Refactor capability search into common macros Hans Zhang
2025-05-05 16:34 ` [PATCH v11 1/6] PCI: Introduce generic bus config read helper function Hans Zhang
2025-05-05 16:34 ` [PATCH v11 2/6] PCI: Clean up __pci_find_next_cap_ttl() readability Hans Zhang
2025-05-05 16:34 ` [PATCH v11 3/6] PCI: Refactor capability search into common macros Hans Zhang
2025-05-05 16:34 ` [PATCH v11 4/6] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities Hans Zhang
2025-05-09 12:49   ` kernel test robot
2025-05-09 16:57     ` Hans Zhang
2025-05-05 16:34 ` [PATCH v11 5/6] PCI: cadence: " Hans Zhang
2025-05-13  8:06   ` kernel test robot
2025-05-05 16:34 ` [PATCH v11 6/6] PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode Hans Zhang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox