Linux PCI subsystem development
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Braden Zhang" <braden_zhang@lecomputing.com>
Cc: linux-pci@vger.kernel.org
Subject: Re: [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu
Date: Fri, 10 Jul 2026 09:51:08 +0000	[thread overview]
Message-ID: <20260710095109.1185F1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260710-pcie-pmu-v1-1-1519e580313f@lecomputing.com>

Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
- [Low] Inconsistent whitespace formatting in include/linux/pci_ids.h.
- [Low] The commit message is incomplete and contains typos that obscure its meaning.
--

--- Patch [1]: [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu ---
commit c0d34696455e22a889eb602a30aeaa12283c0cfb
Author: Brett Zhou <brett_zhou@lecomputing.com>

arm64/pcie/pmu: Add pci id for LECARC pcie pmu

This commit adds a new PCI vendor ID for LECARC and registers it in the
DWC PCIe VSEC IDs table to support the LECARC PCIe Performance Monitoring
Unit.

> This patch adds  for LECARC SoCs that pcie Controller
> IP PCI Express DM Controller pum function

[Severity: Low]
This isn't a bug, but there appear to be a few typos and missing words in
the commit message. The phrase "adds  for" seems to be missing a word like
"support", and "pum" is likely a typo for "pmu". Could the message be
updated for clarity?

> diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
> index 1c9d40e09107d..1c4fd16315054 100644
> --- a/include/linux/pci_ids.h
> +++ b/include/linux/pci_ids.h
> @@ -173,6 +173,7 @@
>  #define PCI_VENDOR_ID_DYNALINK		0x0675
>  #define PCI_DEVICE_ID_DYNALINK_IS64PH	0x1702
>  
> +#define PCI_VENDOR_ID_LECARC            0x0720

[Severity: Low]
This isn't a bug, but does this newly added macro use spaces instead of tabs
for alignment? The rest of include/linux/pci_ids.h appears to consistently
use tabs to separate the macro name and the value.

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260710-pcie-pmu-v1-1-1519e580313f@lecomputing.com?part=1

      reply	other threads:[~2026-07-10  9:51 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-10  9:10 [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu Braden Zhang
2026-07-10  9:51 ` sashiko-bot [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260710095109.1185F1F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=braden_zhang@lecomputing.com \
    --cc=linux-pci@vger.kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox