* [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu
@ 2026-07-10 9:10 Braden Zhang
2026-07-10 9:51 ` sashiko-bot
0 siblings, 1 reply; 2+ messages in thread
From: Braden Zhang @ 2026-07-10 9:10 UTC (permalink / raw)
To: Bjorn Helgaas, Jingoo Han, Manivannan Sadhasivam
Cc: linux-pci, linux-kernel, Brett Zhou, Braden Zhang
From: Brett Zhou <brett_zhou@lecomputing.com>
This patch adds for LECARC SoCs that pcie Controller
IP PCI Express DM Controller pum function
Signed-off-by: Brett Zhou <brett_zhou@lecomputing.com>
---
Signed-off-by: Braden Zhang <braden_zhang@lecomputing.com>
---
include/linux/pci_ids.h | 1 +
include/linux/pcie-dwc.h | 2 ++
2 files changed, 3 insertions(+)
diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
index 1c9d40e09107..1c4fd1631505 100644
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -173,6 +173,7 @@
#define PCI_VENDOR_ID_DYNALINK 0x0675
#define PCI_DEVICE_ID_DYNALINK_IS64PH 0x1702
+#define PCI_VENDOR_ID_LECARC 0x0720
#define PCI_VENDOR_ID_UBIQUITI 0x0777
#define PCI_VENDOR_ID_BERKOM 0x0871
diff --git a/include/linux/pcie-dwc.h b/include/linux/pcie-dwc.h
index 8ff778e7aec0..1a31fe4db228 100644
--- a/include/linux/pcie-dwc.h
+++ b/include/linux/pcie-dwc.h
@@ -32,6 +32,8 @@ static const struct dwc_pcie_vsec_id dwc_pcie_rasdes_vsec_ids[] = {
.vsec_id = 0x02, .vsec_rev = 0x4 },
{ .vendor_id = PCI_VENDOR_ID_SAMSUNG,
.vsec_id = 0x02, .vsec_rev = 0x4 },
+ { .vendor_id = PCI_VENDOR_ID_LECARC,
+ .vsec_id = 0x02, .vsec_rev = 0x4 },
{}
};
---
base-commit: a635d6748234582ea287c5ffeae28b9b23f91c7e
change-id: 20260710-pcie-pmu-5ef78c56c3b6
Best regards,
--
Braden Zhang <braden_zhang@lecomputing.com>
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu
2026-07-10 9:10 [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu Braden Zhang
@ 2026-07-10 9:51 ` sashiko-bot
0 siblings, 0 replies; 2+ messages in thread
From: sashiko-bot @ 2026-07-10 9:51 UTC (permalink / raw)
To: Braden Zhang; +Cc: linux-pci
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
- [Low] Inconsistent whitespace formatting in include/linux/pci_ids.h.
- [Low] The commit message is incomplete and contains typos that obscure its meaning.
--
--- Patch [1]: [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu ---
commit c0d34696455e22a889eb602a30aeaa12283c0cfb
Author: Brett Zhou <brett_zhou@lecomputing.com>
arm64/pcie/pmu: Add pci id for LECARC pcie pmu
This commit adds a new PCI vendor ID for LECARC and registers it in the
DWC PCIe VSEC IDs table to support the LECARC PCIe Performance Monitoring
Unit.
> This patch adds for LECARC SoCs that pcie Controller
> IP PCI Express DM Controller pum function
[Severity: Low]
This isn't a bug, but there appear to be a few typos and missing words in
the commit message. The phrase "adds for" seems to be missing a word like
"support", and "pum" is likely a typo for "pmu". Could the message be
updated for clarity?
> diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
> index 1c9d40e09107d..1c4fd16315054 100644
> --- a/include/linux/pci_ids.h
> +++ b/include/linux/pci_ids.h
> @@ -173,6 +173,7 @@
> #define PCI_VENDOR_ID_DYNALINK 0x0675
> #define PCI_DEVICE_ID_DYNALINK_IS64PH 0x1702
>
> +#define PCI_VENDOR_ID_LECARC 0x0720
[Severity: Low]
This isn't a bug, but does this newly added macro use spaces instead of tabs
for alignment? The rest of include/linux/pci_ids.h appears to consistently
use tabs to separate the macro name and the value.
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260710-pcie-pmu-v1-1-1519e580313f@lecomputing.com?part=1
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-07-10 9:51 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-10 9:10 [PATCH] arm64/pcie/pmu: Add pci id for LECARC pcie pmu Braden Zhang
2026-07-10 9:51 ` sashiko-bot
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox