Linux-RISC-V Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/6] riscv: Make IPI_MAX visible and use it consistently
@ 2026-09-11  3:27 Guo Ren
  2026-09-11  3:27 ` [PATCH v2 1/6] riscv: smp: Move enum ipi_message_type to asm/smp.h Guo Ren
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: Guo Ren @ 2026-09-11  3:27 UTC (permalink / raw)
  To: Paul Walmsley, Palmer Dabbelt, Albert Ou, Alexandre Ghiti,
	Daniel Lezcano, Thomas Gleixner, Radu Rendec, Anup Patel,
	Tiffany Lin, Andrew-CT Chen, Yunfei Dong, Minghsiu Tsai,
	Houlong Wei, Mauro Carvalho Chehab, Matthias Brugger,
	AngeloGioacchino Del Regno
  Cc: linux-riscv, linux-kernel, linux-media, linux-arm-kernel,
	linux-mediatek, tip-bot2 for GUO Ren (XuanTie), GUO Ren (XuanTie),
	Nathan Chancellor

This series removes the implicit assumption that RISC-V supports exactly
eight IPI message types.

Currently, the SBI, CLINT and ACLINT SSWI IPI providers use
BITS_PER_BYTE when sizing the generic IPI mux, while IMSIC carries a
separate IMSIC_NR_IPI definition set to 8. These values happen to match
IPI_MAX today, but neither is the proper source of truth for the number
of RISC-V IPI message types.

Move enum ipi_message_type to asm/smp.h so IPI providers can use IPI_MAX
directly, then replace the BITS_PER_BYTE and IMSIC_NR_IPI uses with
IPI_MAX.

This also makes adding future RISC-V IPI message types independent of
the current eight-entry assumption.

A follow-up patch renames the MediaTek VPU mailbox terminator from
IPI_MAX to IPI_VPU_MAX. That token belongs to the VPU firmware IPI id
enum and should follow the same prefixed convention as IPI_VPU_INIT
(and SCP_IPI_MAX on the SCP side), instead of reusing the generic
IPI_MAX name.

---
GUO Ren (XuanTie) (4):
      clocksource: clint: Use IPI_MAX for IPI muxing
      irqchip/aclint-sswi: Use IPI_MAX for IPI muxing
      irqchip/imsic: Use IPI_MAX instead of IMSIC_NR_IPI
      media: mtk-vpu: rename IPI_MAX to IPI_VPU_MAX

tip-bot2 for GUO Ren (XuanTie) (2):
      riscv: smp: Move enum ipi_message_type to asm/smp.h
      riscv: sbi: Use IPI_MAX for SBI IPI muxing

 arch/riscv/include/asm/smp.h                  | 12 ++++++++++++
 arch/riscv/kernel/sbi-ipi.c                   |  4 ++--
 arch/riscv/kernel/smp.c                       | 12 ------------
 drivers/clocksource/timer-clint.c             |  4 ++--
 drivers/irqchip/irq-aclint-sswi.c             |  4 ++--
 drivers/irqchip/irq-riscv-imsic-early.c       |  4 ++--
 drivers/irqchip/irq-riscv-imsic-state.h       |  1 -
 drivers/media/platform/mediatek/vpu/mtk_vpu.c | 12 ++++++------
 drivers/media/platform/mediatek/vpu/mtk_vpu.h |  4 ++--
 9 files changed, 28 insertions(+), 29 deletions(-)
---
base-commit: 08df884136f1c1197bab2a27814404fd329d9aac
change-id: 20260911-ipi_max-ff71eeadf6fd

Best regards,
--  
GUO Ren (XuanTie) <guoren@kernel.org>


_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2026-09-13 19:53 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-09-11  3:27 [PATCH v2 0/6] riscv: Make IPI_MAX visible and use it consistently Guo Ren
2026-09-11  3:27 ` [PATCH v2 1/6] riscv: smp: Move enum ipi_message_type to asm/smp.h Guo Ren
2026-09-11  3:27 ` [PATCH v2 2/6] riscv: sbi: Use IPI_MAX for SBI IPI muxing Guo Ren
2026-09-11  3:27 ` [PATCH v2 3/6] clocksource: clint: Use IPI_MAX for " GUO Ren (XuanTie)
2026-09-11  3:27 ` [PATCH v2 4/6] irqchip/aclint-sswi: " GUO Ren (XuanTie)
2026-09-11  3:27 ` [PATCH v2 5/6] irqchip/imsic: Use IPI_MAX instead of IMSIC_NR_IPI GUO Ren (XuanTie)
2026-09-11  3:27 ` [PATCH v2 6/6] media: mtk-vpu: rename IPI_MAX to IPI_VPU_MAX GUO Ren (XuanTie)
2026-09-13 19:53 ` [PATCH v2 0/6] riscv: Make IPI_MAX visible and use it consistently Radu Rendec

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox