Linux-RISC-V Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2018-01-24 22:19:09 to 2018-03-06 13:00:59 UTC [more...]

[RFC PATCH] riscv/locking: Strengthen spin_lock() and spin_unlock()
 2018-03-06 13:00 UTC  (23+ messages)

[RFC PATCH 2/2] riscv/atomic: Strengthen implementations with fences
 2018-03-05 19:05 UTC  (2+ messages)

[RFC PATCH 1/2] riscv/spinlock: Strengthen implementations with fences
 2018-03-05 18:24 UTC 

[RFC PATCH 0/2] riscv/spinlock,atomic: Miscellaneous fixes
 2018-03-05 18:23 UTC 

[PATCH v7 00/13] Support PPTT for ARM64
 2018-03-05 12:24 UTC  (21+ messages)
` [PATCH v7 01/13] drivers: base: cacheinfo: move cache_setup_of_node()
` [PATCH v7 02/13] drivers: base: cacheinfo: setup DT cache properties early
` [PATCH v7 03/13] cacheinfo: rename of_node to fw_token
` [PATCH v7 04/13] arm64/acpi: Create arch specific cpu to acpi id helper
` [PATCH v7 05/13] ACPI/PPTT: Add Processor Properties Topology Table parsing
` [PATCH v7 06/13] ACPI: Enable PPTT support on ARM64
` [PATCH v7 07/13] drivers: base cacheinfo: Add support for ACPI based firmware tables
` [PATCH v7 08/13] arm64: "
` [PATCH v7 09/13] ACPI/PPTT: Add topology parsing code
` [PATCH v7 10/13] arm64: topology: rename cluster_id
` [PATCH v7 11/13] arm64: topology: enable ACPI/PPTT based CPU topology
` [PATCH v7 12/13] ACPI: Add PPTT to injectable table list
` [PATCH v7 13/13] arm64: topology: divorce MC scheduling domain from core_siblings

upstream status?
 2018-03-02 15:58 UTC 

[PATCH 0/9] RISC-V: Make modules loadable
 2018-03-02  9:12 UTC  (23+ messages)
` [PATCH 1/9] RISC-V: Build non position-independent modules
` [PATCH 2/9] RISC-V: Load modules within relative jump range of the kernel text
` [PATCH 3/9] RISC-V: Support RISCV_CALL relocations for non-PIC modules
` [PATCH 4/9] RISC-V: Support RISCV_RVC_BRANCH relocations in modules
` [PATCH 5/9] RISC-V: Support RISCV_RVC_JUMP "
` [PATCH 6/9] RISC-V: Support RISCV_ADD32 "
` [PATCH 7/9] RISC-V: Support RISCV_SUB32 "
` [PATCH 8/9] RISC-V: Support RISCV_ALIGN "
` [PATCH 9/9] RISC-V: Build a module-enabled kernel by default

RISC-V Seccomp Support?
 2018-03-01 11:44 UTC  (3+ messages)

[GIT PULL] RISC-V: smb_mb() fix for 4.16-rc4
 2018-02-28 22:50 UTC 

[PATCH] riscv/barrier: Define __smp_{store_release,load_acquire}
 2018-02-28  0:15 UTC  (4+ messages)

Building Risc-V Linux kernel images for qemu without rebuilding bbl
 2018-02-27 23:38 UTC  (3+ messages)

[PATCH RFC] riscv/barrier: Define __smp_{mb,rmb,wmb}
 2018-02-27  2:27 UTC  (5+ messages)

[PATCH] riscv: enable STRICT_DEVMEM by default
 2018-02-26 18:04 UTC  (5+ messages)

[PATCH] riscv: Add install target to Makefile
 2018-02-24  0:40 UTC  (3+ messages)
` [PATCH v2] "

[PATCH] riscv: Respect the initrd found in the dt, if any
 2018-02-23  3:38 UTC  (3+ messages)

[PATCH] riscv: Implement free_initrd_mem
 2018-02-23  0:41 UTC  (3+ messages)
` [PATCH v2] "

[PATCH v2] riscv: enable STRICT_DEVMEM by default
 2018-02-22 15:57 UTC 

[palmer:riscv-all 16/19] u54-prci.c:undefined reference to `__udivdi3'
 2018-02-21 21:25 UTC 

[palmer:riscv-all 12/17] ./arch/riscv/include/generated/asm/handle_irq.h:1:10: fatal error: asm-generic/handle_irq.h: No such file or directory
 2018-02-21 17:11 UTC 

[GIT PULL] RISC-V: Cleanups for 4.16-rc3
 2018-02-21 16:37 UTC 

[PATCH] set_handle_irq: Return EBUSY if the handler has already been registered
 2018-02-20  0:05 UTC 

[patches] [PATCH] Rename sbi_save to parse_dtb to improve code readability
 2018-02-15 23:02 UTC 

[PATCH 00/20] Remove references to undefined symbols and fix two potential bugs
 2018-02-13  2:07 UTC  (26+ messages)
` [PATCH 06/20] riscv: Remove ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE select
` [PATCH 07/20] riscv: Remove ARCH_WANT_OPTIONAL_GPIOLIB select
      ` [PATCH] riscv: kconfig: Remove RISCV_IRQ_INTC select
    ` [PATCH] ALSA: ac97: kconfig: Remove select of undefined symbol AC97

[GIT PULL] RISC-V changes for 4.16
 2018-02-07 20:24 UTC  (2+ messages)

Make set_handle_irq and handle_arch_irq generic
 2018-01-27  3:13 UTC  (13+ messages)
` [PATCH v2 1/4] arm: "
` [PATCH v2 2/4] arm64: Use the new MULTI_IRQ_HANDLER
` [PATCH v2 3/4] openrisc: "
` [PATCH v2 4/4] RISC-V: Move to the new generic IRQ handler
    ` [patches] "

[GIT PULL] RISC-V: We have a new mailing list and git repo!
 2018-01-26 23:13 UTC  (3+ messages)
  ` [patches] "

[PATCH] Update the RISC-V MAINTAINERS file
 2018-01-26  7:10 UTC  (2+ messages)

[PATCH] riscv: don't use the symbolic satp name in assembler code
 2018-01-25  7:20 UTC  (6+ messages)
  ` [PATCH 1/4] riscv: remove the unused current_pgdir function
  ` [PATCH 2/4] riscv: don't read back satp in paging_init
  ` [PATCH 3/4] riscv: rename sptbr to satp
  ` [PATCH 4/4] riscv: inline set_pgdir into its only caller


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox