* [PATCH 0/5] thermal: simplify getting .driver_data
@ 2018-10-21 20:00 Wolfram Sang
2018-10-21 20:00 ` [PATCH 2/5] thermal: rockchip_thermal: " Wolfram Sang
0 siblings, 1 reply; 4+ messages in thread
From: Wolfram Sang @ 2018-10-21 20:00 UTC (permalink / raw)
To: linux-kernel
Cc: linux-renesas-soc, Wolfram Sang, linux-arm-kernel, linux-pm,
linux-rockchip
I got tired of fixing this in Renesas drivers manually, so I took the big
hammer. Remove this cumbersome code pattern which got copy-pasted too much
already:
- struct platform_device *pdev = to_platform_device(dev);
- struct ep93xx_keypad *keypad = platform_get_drvdata(pdev);
+ struct ep93xx_keypad *keypad = dev_get_drvdata(dev);
A branch, tested by buildbot, can be found here:
git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git coccinelle/get_drvdata
I have been asked if it couldn't be done for dev_set_drvdata as well. I checked
it and did not find one occasion where it could be simplified like this. Not
much of a surprise because driver_data is usually set in probe() functions
which access struct platform_device in many other ways.
I am open for other comments, suggestions, too, of course.
Here is the cocci-script I created:
@@
struct device* d;
identifier pdev;
expression *ptr;
@@
(
- struct platform_device *pdev = to_platform_device(d);
|
- struct platform_device *pdev;
...
- pdev = to_platform_device(d);
)
<... when != pdev
- &pdev->dev
+ d
...>
ptr =
- platform_get_drvdata(pdev)
+ dev_get_drvdata(d)
<... when != pdev
- &pdev->dev
+ d
...>
Kind regards,
Wolfram
Wolfram Sang (5):
thermal: int340x_thermal: int3400_thermal: simplify getting
.driver_data
thermal: rockchip_thermal: simplify getting .driver_data
thermal: spear_thermal: simplify getting .driver_data
thermal: st: st_thermal: simplify getting .driver_data
thermal: zx2967_thermal: simplify getting .driver_data
drivers/thermal/int340x_thermal/int3400_thermal.c | 9 +++------
drivers/thermal/rockchip_thermal.c | 8 +++-----
drivers/thermal/spear_thermal.c | 8 +++-----
drivers/thermal/st/st_thermal.c | 6 ++----
drivers/thermal/zx2967_thermal.c | 6 ++----
5 files changed, 13 insertions(+), 24 deletions(-)
--
2.19.0
^ permalink raw reply [flat|nested] 4+ messages in thread
* [PATCH 2/5] thermal: rockchip_thermal: simplify getting .driver_data
2018-10-21 20:00 [PATCH 0/5] thermal: simplify getting .driver_data Wolfram Sang
@ 2018-10-21 20:00 ` Wolfram Sang
2018-11-02 12:25 ` Heiko Stuebner
2018-11-05 15:05 ` Daniel Lezcano
0 siblings, 2 replies; 4+ messages in thread
From: Wolfram Sang @ 2018-10-21 20:00 UTC (permalink / raw)
To: linux-kernel
Cc: linux-renesas-soc, Wolfram Sang, Zhang Rui, Eduardo Valentin,
Daniel Lezcano, Heiko Stuebner, linux-pm, linux-arm-kernel,
linux-rockchip
We should get 'driver_data' from 'struct device' directly. Going via
platform_device is an unneeded step back and forth.
Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
---
Build tested only. buildbot is happy.
drivers/thermal/rockchip_thermal.c | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/thermal/rockchip_thermal.c b/drivers/thermal/rockchip_thermal.c
index f36375d5a16c..9c7643d62ed7 100644
--- a/drivers/thermal/rockchip_thermal.c
+++ b/drivers/thermal/rockchip_thermal.c
@@ -1327,8 +1327,7 @@ static int rockchip_thermal_remove(struct platform_device *pdev)
static int __maybe_unused rockchip_thermal_suspend(struct device *dev)
{
- struct platform_device *pdev = to_platform_device(dev);
- struct rockchip_thermal_data *thermal = platform_get_drvdata(pdev);
+ struct rockchip_thermal_data *thermal = dev_get_drvdata(dev);
int i;
for (i = 0; i < thermal->chip->chn_num; i++)
@@ -1346,8 +1345,7 @@ static int __maybe_unused rockchip_thermal_suspend(struct device *dev)
static int __maybe_unused rockchip_thermal_resume(struct device *dev)
{
- struct platform_device *pdev = to_platform_device(dev);
- struct rockchip_thermal_data *thermal = platform_get_drvdata(pdev);
+ struct rockchip_thermal_data *thermal = dev_get_drvdata(dev);
int i;
int error;
@@ -1376,7 +1374,7 @@ static int __maybe_unused rockchip_thermal_resume(struct device *dev)
id, thermal->regs,
thermal->tshut_temp);
if (error)
- dev_err(&pdev->dev, "%s: invalid tshut=%d, error=%d\n",
+ dev_err(dev, "%s: invalid tshut=%d, error=%d\n",
__func__, thermal->tshut_temp, error);
}
--
2.19.0
^ permalink raw reply related [flat|nested] 4+ messages in thread
* Re: [PATCH 2/5] thermal: rockchip_thermal: simplify getting .driver_data
2018-10-21 20:00 ` [PATCH 2/5] thermal: rockchip_thermal: " Wolfram Sang
@ 2018-11-02 12:25 ` Heiko Stuebner
2018-11-05 15:05 ` Daniel Lezcano
1 sibling, 0 replies; 4+ messages in thread
From: Heiko Stuebner @ 2018-11-02 12:25 UTC (permalink / raw)
To: Wolfram Sang
Cc: linux-kernel, linux-renesas-soc, Zhang Rui, Eduardo Valentin,
Daniel Lezcano, linux-pm, linux-arm-kernel, linux-rockchip
Am Sonntag, 21. Oktober 2018, 22:00:49 CET schrieb Wolfram Sang:
> We should get 'driver_data' from 'struct device' directly. Going via
> platform_device is an unneeded step back and forth.
>
> Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
Reviewed-by: Heiko Stuebner <heiko@sntech.de>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 2/5] thermal: rockchip_thermal: simplify getting .driver_data
2018-10-21 20:00 ` [PATCH 2/5] thermal: rockchip_thermal: " Wolfram Sang
2018-11-02 12:25 ` Heiko Stuebner
@ 2018-11-05 15:05 ` Daniel Lezcano
1 sibling, 0 replies; 4+ messages in thread
From: Daniel Lezcano @ 2018-11-05 15:05 UTC (permalink / raw)
To: Wolfram Sang, linux-kernel
Cc: linux-renesas-soc, Zhang Rui, Eduardo Valentin, Heiko Stuebner,
linux-pm, linux-arm-kernel, linux-rockchip
On 21/10/2018 22:00, Wolfram Sang wrote:
> We should get 'driver_data' from 'struct device' directly. Going via
> platform_device is an unneeded step back and forth.
>
> Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
Reviewed-by: Daniel Lezcano <daniel.lezcano@linaro.org>
> ---
>
> Build tested only. buildbot is happy.
>
> drivers/thermal/rockchip_thermal.c | 8 +++-----
> 1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/thermal/rockchip_thermal.c b/drivers/thermal/rockchip_thermal.c
> index f36375d5a16c..9c7643d62ed7 100644
> --- a/drivers/thermal/rockchip_thermal.c
> +++ b/drivers/thermal/rockchip_thermal.c
> @@ -1327,8 +1327,7 @@ static int rockchip_thermal_remove(struct platform_device *pdev)
>
> static int __maybe_unused rockchip_thermal_suspend(struct device *dev)
> {
> - struct platform_device *pdev = to_platform_device(dev);
> - struct rockchip_thermal_data *thermal = platform_get_drvdata(pdev);
> + struct rockchip_thermal_data *thermal = dev_get_drvdata(dev);
> int i;
>
> for (i = 0; i < thermal->chip->chn_num; i++)
> @@ -1346,8 +1345,7 @@ static int __maybe_unused rockchip_thermal_suspend(struct device *dev)
>
> static int __maybe_unused rockchip_thermal_resume(struct device *dev)
> {
> - struct platform_device *pdev = to_platform_device(dev);
> - struct rockchip_thermal_data *thermal = platform_get_drvdata(pdev);
> + struct rockchip_thermal_data *thermal = dev_get_drvdata(dev);
> int i;
> int error;
>
> @@ -1376,7 +1374,7 @@ static int __maybe_unused rockchip_thermal_resume(struct device *dev)
> id, thermal->regs,
> thermal->tshut_temp);
> if (error)
> - dev_err(&pdev->dev, "%s: invalid tshut=%d, error=%d\n",
> + dev_err(dev, "%s: invalid tshut=%d, error=%d\n",
> __func__, thermal->tshut_temp, error);
> }
>
>
--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs
Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2018-11-05 15:05 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2018-10-21 20:00 [PATCH 0/5] thermal: simplify getting .driver_data Wolfram Sang
2018-10-21 20:00 ` [PATCH 2/5] thermal: rockchip_thermal: " Wolfram Sang
2018-11-02 12:25 ` Heiko Stuebner
2018-11-05 15:05 ` Daniel Lezcano
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox