Linux s390 Architecture development
 help / color / mirror / Atom feed
From: Heiko Carstens <hca@linux.ibm.com>
To: Mete Durlu <meted@linux.ibm.com>
Cc: Vasily Gorbik <gor@linux.ibm.com>,
	Alexander Gordeev <agordeev@linux.ibm.com>,
	Christian Borntraeger <borntraeger@linux.ibm.com>,
	Sven Schnelle <svens@linux.ibm.com>,
	linux-s390@vger.kernel.org
Subject: Re: [PATCH 0/2] s390/ipl: Improve readability
Date: Wed, 22 Jul 2026 10:28:47 +0200	[thread overview]
Message-ID: <20260722082847.16302A2b-hca@linux.ibm.com> (raw)
In-Reply-To: <20260721-ipl_refactor-v1-0-4d5938de9a70@linux.ibm.com>

On Tue, Jul 21, 2026 at 08:47:26PM +0200, Mete Durlu wrote:
> Improve readability of s390 ipl code by openly writing static struct
> definitions, reformatting list definitions and using ARRAY_SIZE() macro
> in suitable places.
> 
> No functional changes, only coding style changes.
> 
> Signed-off-by: Mete Durlu <meted@linux.ibm.com>
> ---
> Mete Durlu (2):
>       s390/ipl: Use ARRAY_SIZE macro
>       s390/ipl: Improve readability
> 
>  arch/s390/kernel/ipl.c | 58 +++++++++++++++++++++++++++++++++-----------------
>  1 file changed, 38 insertions(+), 20 deletions(-)

Acked-by: Heiko Carstens <hca@linux.ibm.com>

      parent reply	other threads:[~2026-07-22  8:28 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-21 18:47 [PATCH 0/2] s390/ipl: Improve readability Mete Durlu
2026-07-21 18:47 ` [PATCH 1/2] s390/ipl: Use ARRAY_SIZE macro Mete Durlu
2026-07-21 19:00   ` sashiko-bot
2026-07-21 18:47 ` [PATCH 2/2] s390/ipl: Improve readability Mete Durlu
2026-07-21 19:04   ` sashiko-bot
2026-07-22  8:28 ` Heiko Carstens [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260722082847.16302A2b-hca@linux.ibm.com \
    --to=hca@linux.ibm.com \
    --cc=agordeev@linux.ibm.com \
    --cc=borntraeger@linux.ibm.com \
    --cc=gor@linux.ibm.com \
    --cc=linux-s390@vger.kernel.org \
    --cc=meted@linux.ibm.com \
    --cc=svens@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox