* [PATCH v2 00/23] Rid W=1 warnings in MTD
@ 2020-11-06 21:36 Lee Jones
2020-11-06 21:36 ` [PATCH v2 17/23] mtd: nand: raw: s3c2410: Add documentation for 2 missing struct members Lee Jones
2020-11-09 8:28 ` [PATCH v2 00/23] Rid W=1 warnings in MTD Miquel Raynal
0 siblings, 2 replies; 3+ messages in thread
From: Lee Jones @ 2020-11-06 21:36 UTC (permalink / raw)
To: lee.jones
Cc: linux-kernel, Adrian Hunter, bcm-kernel-feedback-list, Ben Dooks,
Benjamin Herrenschmidt, Boris BREZILLON, Boris Brezillon,
Brian Norris, Chen-Yu Tsai, Choudary Kalluri,
Christian König, Dan Brown, David Woodhouse, Dmitriy B,
dri-devel, Frieder Schrempf, Jian Zhang, Jochen Schäuble,
Kamal Dasu, Krzysztof Kozlowski, Kukjin Kim, Kyungmin Park,
linaro-mm-sig, linux-media, linux-mtd, linuxppc-dev,
linux-samsung-soc, Maxime Ripard, Michael Ellerman, Miquel Raynal,
Naga Sureshkumar Relli, Nicolas Pitre, Paul Mackerras,
Philipp Zabel, Qiang Yu, Richard Weinberger, Robert Jarzmik,
Sergey Lapin, Sumit Semwal, Thomas Gleixner, Thomas Gleixner,
Tudor Ambarus, Vignesh Raghavendra, Yoshio Furuyama
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
v1 => v2:
- Added tags
- Satisfied Miquel's review comments
Lee Jones (23):
mtd: mtdpart: Fix misdocumented function parameter 'mtd'
mtd: devices: phram: File headers are not good candidates for
kernel-doc
mtd: nand: onenand: onenand_base: Fix expected kernel-doc formatting
mtd: devices: docg3: Fix kernel-doc 'bad line' and 'excessive doc'
issues
mtd: mtdcore: Fix misspelled function parameter 'section'
mtd: nand: onenand: onenand_bbt: Fix expected kernel-doc formatting
mtd: spi-nor: controllers: hisi-sfc: Demote non-conformant kernel-doc
mtd: ubi: build: Document 'ubi_num' in struct mtd_dev_param
mtd: nand: spi: toshiba: Demote non-conformant kernel-doc header
mtd: ubi: kapi: Correct documentation for 'ubi_leb_read_sg's 'sgl'
parameter
mtd: ubi: eba: Fix a couple of misdocumentation issues
mtd: ubi: wl: Fix a couple of kernel-doc issues
mtd: nand: raw: brcmnand: brcmnand: Demote non-conformant kernel-doc
headers
mtd: ubi: gluebi: Fix misnamed function parameter documentation
mtd: nand: raw: diskonchip: Marking unused variables as
__always_unused
mtd: nand: raw: cafe_nand: Remove superfluous param doc and add
another
mtd: nand: raw: s3c2410: Add documentation for 2 missing struct
members
mtd: nand: raw: omap_elm: Finish half populated function header,
demote empty ones
mtd: nand: raw: omap2: Fix a bunch of kernel-doc misdemeanours
mtd: nand: raw: sunxi_nand: Document 'sunxi_nfc's 'caps' member
mtd: nand: raw: arasan-nand-controller: Document 'anfc_op's 'buf'
member
mtd: nand: onenand: onenand_base: Fix some kernel-doc misdemeanours
mtd: devices: powernv_flash: Add function names to headers and fix
'dev'
drivers/mtd/devices/docg3.c | 5 +-
drivers/mtd/devices/phram.c | 2 +-
drivers/mtd/devices/powernv_flash.c | 5 +-
drivers/mtd/mtdcore.c | 2 +-
drivers/mtd/mtdpart.c | 2 +-
drivers/mtd/nand/onenand/onenand_base.c | 444 +++++++++---------
drivers/mtd/nand/onenand/onenand_bbt.c | 32 +-
drivers/mtd/nand/raw/arasan-nand-controller.c | 1 +
drivers/mtd/nand/raw/brcmnand/brcmnand.c | 6 +-
drivers/mtd/nand/raw/cafe_nand.c | 2 +-
drivers/mtd/nand/raw/diskonchip.c | 4 +-
drivers/mtd/nand/raw/omap2.c | 18 +-
drivers/mtd/nand/raw/omap_elm.c | 7 +-
drivers/mtd/nand/raw/s3c2410.c | 4 +-
drivers/mtd/nand/raw/sunxi_nand.c | 1 +
drivers/mtd/nand/spi/toshiba.c | 2 +-
drivers/mtd/spi-nor/controllers/hisi-sfc.c | 2 +-
drivers/mtd/ubi/build.c | 1 +
drivers/mtd/ubi/eba.c | 3 +-
drivers/mtd/ubi/gluebi.c | 2 +-
drivers/mtd/ubi/kapi.c | 2 +-
drivers/mtd/ubi/wl.c | 3 +-
22 files changed, 278 insertions(+), 272 deletions(-)
Cc: Adrian Hunter <ext-adrian.hunter@nokia.com>
Cc: bcm-kernel-feedback-list@broadcom.com
Cc: Ben Dooks <ben@simtec.co.uk>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Boris BREZILLON <b.brezillon.dev@gmail.com>
Cc: Boris Brezillon <boris.brezillon@collabora.com>
Cc: Brian Norris <computersforpeace@gmail.com>
Cc: Chen-Yu Tsai <wens@csie.org>
Cc: Choudary Kalluri <punnaia@xilinx.com>
Cc: "Christian König" <christian.koenig@amd.com>
Cc: Dan Brown <dan_brown@ieee.org>
Cc: David Woodhouse <dwmw2@infradead.org>
Cc: Dmitriy B <rzk333@gmail.com>
Cc: dri-devel@lists.freedesktop.org
Cc: Frieder Schrempf <frieder.schrempf@kontron.de>
Cc: Jian Zhang <jzhang@ti.com>
Cc: "Jochen Schäuble" <psionic@psionic.de>
Cc: Kamal Dasu <kdasu.kdev@gmail.com>
Cc: Krzysztof Kozlowski <krzk@kernel.org>
Cc: Kukjin Kim <kgene@kernel.org>
Cc: Kyungmin Park <kyungmin.park@samsung.com>
Cc: linaro-mm-sig@lists.linaro.org
Cc: linux-media@vger.kernel.org
Cc: linux-mtd@lists.infradead.org
Cc: linuxppc-dev@lists.ozlabs.org
Cc: linux-samsung-soc@vger.kernel.org
Cc: Maxime Ripard <mripard@kernel.org>
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Miquel Raynal <miquel.raynal@bootlin.com>
Cc: Naga Sureshkumar Relli <nagasure@xilinx.com>
Cc: Nicolas Pitre <nico@fluxnic.net>
Cc: Paul Mackerras <paulus@samba.org>
Cc: Philipp Zabel <p.zabel@pengutronix.de>
Cc: Qiang Yu <yuq825@gmail.com>
Cc: Richard Weinberger <richard@nod.at>
Cc: Robert Jarzmik <robert.jarzmik@free.fr>
Cc: Sergey Lapin <slapin@ossfans.org>
Cc: Sumit Semwal <sumit.semwal@linaro.org>
Cc: Thomas Gleixner <gleixner@linutronix.de>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Tudor Ambarus <tudor.ambarus@microchip.com>
Cc: Vignesh Raghavendra <vigneshr@ti.com>
Cc: Yoshio Furuyama <ytc-mb-yfuruyama7@kioxia.com>
--
2.25.1
^ permalink raw reply [flat|nested] 3+ messages in thread* [PATCH v2 17/23] mtd: nand: raw: s3c2410: Add documentation for 2 missing struct members
2020-11-06 21:36 [PATCH v2 00/23] Rid W=1 warnings in MTD Lee Jones
@ 2020-11-06 21:36 ` Lee Jones
2020-11-09 8:28 ` [PATCH v2 00/23] Rid W=1 warnings in MTD Miquel Raynal
1 sibling, 0 replies; 3+ messages in thread
From: Lee Jones @ 2020-11-06 21:36 UTC (permalink / raw)
To: lee.jones
Cc: linux-kernel, Miquel Raynal, Richard Weinberger,
Vignesh Raghavendra, Kukjin Kim, Krzysztof Kozlowski, Ben Dooks,
linux-mtd, linux-samsung-soc
Correct 'controller' typo while we're at it.
Fixes the following W=1 kernel build warning(s):
drivers/mtd/nand/raw/s3c2410.c:172: warning: Function parameter or member 'controller' not described in 's3c2410_nand_info'
drivers/mtd/nand/raw/s3c2410.c:172: warning: Function parameter or member 'freq_transition' not described in 's3c2410_nand_info'
Cc: Miquel Raynal <miquel.raynal@bootlin.com>
Cc: Richard Weinberger <richard@nod.at>
Cc: Vignesh Raghavendra <vigneshr@ti.com>
Cc: Kukjin Kim <kgene@kernel.org>
Cc: Krzysztof Kozlowski <krzk@kernel.org>
Cc: Ben Dooks <ben@simtec.co.uk>
Cc: linux-mtd@lists.infradead.org
Cc: linux-samsung-soc@vger.kernel.org
Signed-off-by: Lee Jones <lee.jones@linaro.org>
Reviewed-by: Krzysztof Kozlowski <krzk@kernel.org>
---
drivers/mtd/nand/raw/s3c2410.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/mtd/nand/raw/s3c2410.c b/drivers/mtd/nand/raw/s3c2410.c
index cb2d1b4e278cb..f0a4535c812aa 100644
--- a/drivers/mtd/nand/raw/s3c2410.c
+++ b/drivers/mtd/nand/raw/s3c2410.c
@@ -133,7 +133,8 @@ enum s3c_nand_clk_state {
/**
* struct s3c2410_nand_info - NAND controller state.
- * @mtds: An array of MTD instances on this controoler.
+ * @controller: Base controller structure.
+ * @mtds: An array of MTD instances on this controller.
* @platform: The platform data for this board.
* @device: The platform device we bound to.
* @clk: The clock resource for this controller.
@@ -145,6 +146,7 @@ enum s3c_nand_clk_state {
* @clk_rate: The clock rate from @clk.
* @clk_state: The current clock state.
* @cpu_type: The exact type of this controller.
+ * @freq_transition: CPUFreq notifier block
*/
struct s3c2410_nand_info {
/* mtd info */
--
2.25.1
^ permalink raw reply related [flat|nested] 3+ messages in thread* Re: [PATCH v2 00/23] Rid W=1 warnings in MTD
2020-11-06 21:36 [PATCH v2 00/23] Rid W=1 warnings in MTD Lee Jones
2020-11-06 21:36 ` [PATCH v2 17/23] mtd: nand: raw: s3c2410: Add documentation for 2 missing struct members Lee Jones
@ 2020-11-09 8:28 ` Miquel Raynal
1 sibling, 0 replies; 3+ messages in thread
From: Miquel Raynal @ 2020-11-09 8:28 UTC (permalink / raw)
To: Lee Jones
Cc: linux-kernel, Adrian Hunter, bcm-kernel-feedback-list, Ben Dooks,
Benjamin Herrenschmidt, Boris BREZILLON, Boris Brezillon,
Brian Norris, Chen-Yu Tsai, Choudary Kalluri,
Christian König, Dan Brown, David Woodhouse, Dmitriy B,
dri-devel, Frieder Schrempf, Jian Zhang, Jochen Schäuble,
Kamal Dasu, Krzysztof Kozlowski, Kukjin Kim, Kyungmin Park,
linaro-mm-sig, linux-media, linux-mtd, linuxppc-dev,
linux-samsung-soc, Maxime Ripard, Michael Ellerman,
Naga Sureshkumar Relli, Nicolas Pitre, Paul Mackerras,
Philipp Zabel, Qiang Yu, Richard Weinberger, Robert Jarzmik,
Sergey Lapin, Sumit Semwal, Thomas Gleixner, Thomas Gleixner,
Tudor Ambarus, Vignesh Raghavendra, Yoshio Furuyama
Hi Lee,
Lee Jones <lee.jones@linaro.org> wrote on Fri, 6 Nov 2020 21:36:32
+0000:
> This set is part of a larger effort attempting to clean-up W=1
> kernel builds, which are currently overwhelmingly riddled with
> niggly little warnings.
>
> v1 => v2:
> - Added tags
> - Satisfied Miquel's review comments
>
You probably missed my request to update the titles. That's why I
wanted the entire series to be resent. Anyway, as I forgot a few,
please find below the prefixes that should be used:
> Lee Jones (23):
> mtd: mtdpart: Fix misdocumented function parameter 'mtd'
> mtd: devices: phram: File headers are not good candidates for
> kernel-doc
> mtd: nand: onenand: onenand_base: Fix expected kernel-doc formatting
mtd: onenand: Fix...
> mtd: devices: docg3: Fix kernel-doc 'bad line' and 'excessive doc'
> issues
> mtd: mtdcore: Fix misspelled function parameter 'section'
mtd: Fix...
> mtd: nand: onenand: onenand_bbt: Fix expected kernel-doc formatting
mtd: onenand: Fix...
> mtd: spi-nor: controllers: hisi-sfc: Demote non-conformant kernel-doc
mtd: spi-nor: hisi-sfc: Demote...
> mtd: ubi: build: Document 'ubi_num' in struct mtd_dev_param
> mtd: nand: spi: toshiba: Demote non-conformant kernel-doc header
mtd: spinand: toshiba: Demote...
> mtd: ubi: kapi: Correct documentation for 'ubi_leb_read_sg's 'sgl'
> parameter
> mtd: ubi: eba: Fix a couple of misdocumentation issues
> mtd: ubi: wl: Fix a couple of kernel-doc issues
> mtd: nand: raw: brcmnand: brcmnand: Demote non-conformant kernel-doc
> headers
mtd: rawnand: brcmnand: Demote...
> mtd: ubi: gluebi: Fix misnamed function parameter documentation
> mtd: nand: raw: diskonchip: Marking unused variables as
> __always_unused
mtd: rawnand: diskonchip: Marking...
> mtd: nand: raw: cafe_nand: Remove superfluous param doc and add
> another
mtd: rawnand: cafe: Remove
> mtd: nand: raw: s3c2410: Add documentation for 2 missing struct
> members
mtd: rawnand: s3c2410: Add...
> mtd: nand: raw: omap_elm: Finish half populated function header,
> demote empty ones
mtd: rawnand: omap_elm: Finish
> mtd: nand: raw: omap2: Fix a bunch of kernel-doc misdemeanours
mtd:r rawnand: omap2: Fix
> mtd: nand: raw: sunxi_nand: Document 'sunxi_nfc's 'caps' member
mtd: rawnand: sunxi: Document
> mtd: nand: raw: arasan-nand-controller: Document 'anfc_op's 'buf'
> member
mtd: rawnand: arasan: Document
> mtd: nand: onenand: onenand_base: Fix some kernel-doc misdemeanours
mtd: onenand: Fix
> mtd: devices: powernv_flash: Add function names to headers and fix
> 'dev'
Otherwise the content of the series looks good to me.
Thanks,
Miquèl
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2020-11-09 8:29 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2020-11-06 21:36 [PATCH v2 00/23] Rid W=1 warnings in MTD Lee Jones
2020-11-06 21:36 ` [PATCH v2 17/23] mtd: nand: raw: s3c2410: Add documentation for 2 missing struct members Lee Jones
2020-11-09 8:28 ` [PATCH v2 00/23] Rid W=1 warnings in MTD Miquel Raynal
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox