* [PATCH] ARM: EXYNOS: use BUG_ON where possible [not found] <1352406191-14303-1-git-send-email-sasha.levin@oracle.com> @ 2012-11-08 20:23 ` Sasha Levin 2012-11-12 15:12 ` Maarten Lankhorst 2012-11-08 20:23 ` [PATCH] ARM: dma: " Sasha Levin 1 sibling, 1 reply; 6+ messages in thread From: Sasha Levin @ 2012-11-08 20:23 UTC (permalink / raw) To: linux-kernel Cc: Sasha Levin, Kukjin Kim, Russell King, linux-arm-kernel, linux-samsung-soc Just use BUG_ON() instead of constructions such as: if (...) BUG() A simplified version of the semantic patch that makes this transformation is as follows: (http://coccinelle.lip6.fr/) // <smpl> @@ expression e; @@ - if (e) BUG(); + BUG_ON(e); // </smpl> Signed-off-by: Sasha Levin <sasha.levin@oracle.com> --- arch/arm/mach-exynos/common.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c index 4e577f6..6a55a5a 100644 --- a/arch/arm/mach-exynos/common.c +++ b/arch/arm/mach-exynos/common.c @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int combiner_nr, unsigned int i else max_nr = EXYNOS4_MAX_COMBINER_NR; - if (combiner_nr >= max_nr) - BUG(); - if (irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0) - BUG(); + BUG_ON(combiner_nr >= max_nr); + BUG_ON(irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0); irq_set_chained_handler(irq, combiner_handle_cascade_irq); } -- 1.7.10.4 ^ permalink raw reply related [flat|nested] 6+ messages in thread
* Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible 2012-11-08 20:23 ` [PATCH] ARM: EXYNOS: use BUG_ON where possible Sasha Levin @ 2012-11-12 15:12 ` Maarten Lankhorst 2012-11-12 15:23 ` Russell King - ARM Linux 2012-11-12 15:25 ` Sasha Levin 0 siblings, 2 replies; 6+ messages in thread From: Maarten Lankhorst @ 2012-11-12 15:12 UTC (permalink / raw) To: Sasha Levin Cc: linux-kernel, Kukjin Kim, Russell King, linux-arm-kernel, linux-samsung-soc Op 08-11-12 21:23, Sasha Levin schreef: > Just use BUG_ON() instead of constructions such as: > > if (...) > BUG() > > A simplified version of the semantic patch that makes this transformation > is as follows: (http://coccinelle.lip6.fr/) > > // <smpl> > @@ > expression e; > @@ > - if (e) BUG(); > + BUG_ON(e); > // </smpl> > > Signed-off-by: Sasha Levin <sasha.levin@oracle.com> > --- > arch/arm/mach-exynos/common.c | 6 ++---- > 1 file changed, 2 insertions(+), 4 deletions(-) > > diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c > index 4e577f6..6a55a5a 100644 > --- a/arch/arm/mach-exynos/common.c > +++ b/arch/arm/mach-exynos/common.c > @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int combiner_nr, unsigned int i > else > max_nr = EXYNOS4_MAX_COMBINER_NR; > > - if (combiner_nr >= max_nr) > - BUG(); > - if (irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0) > - BUG(); > + BUG_ON(combiner_nr >= max_nr); > + BUG_ON(irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0); Is it really a good idea to put functions that perform work in a BUG_ON? I don't know, but for some reason it just feels wrong. I'd expect code to compile fine if BUG_ON was a noop, so doing verification calls only, not actual work.. ~Maarten ^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible 2012-11-12 15:12 ` Maarten Lankhorst @ 2012-11-12 15:23 ` Russell King - ARM Linux 2012-11-12 15:52 ` Sasha Levin 2012-11-12 15:25 ` Sasha Levin 1 sibling, 1 reply; 6+ messages in thread From: Russell King - ARM Linux @ 2012-11-12 15:23 UTC (permalink / raw) To: Maarten Lankhorst Cc: Sasha Levin, linux-kernel, Kukjin Kim, linux-arm-kernel, linux-samsung-soc On Mon, Nov 12, 2012 at 04:12:29PM +0100, Maarten Lankhorst wrote: > Op 08-11-12 21:23, Sasha Levin schreef: > > @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int combiner_nr, unsigned int i > > else > > max_nr = EXYNOS4_MAX_COMBINER_NR; > > > > - if (combiner_nr >= max_nr) > > - BUG(); > > - if (irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0) > > - BUG(); > > + BUG_ON(combiner_nr >= max_nr); > > + BUG_ON(irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0); > > Is it really a good idea to put functions that perform work in a BUG_ON? > I don't know, but for some reason it just feels wrong. I'd expect code to > compile fine if BUG_ON was a noop, so doing verification calls only, not > actual work.. Well, it is currently defined as: include/asm-generic/bug.h:#define BUG_ON(condition) do { if (unlikely(condition)) BUG(); } while(0) include/asm-generic/bug.h:#define BUG_ON(condition) do { if (condition) ; } while(0) but as these can be overridden, I don't think relying on those implementations is a good idea; to do so would be fragile. Eg, what if the BUG_ON() implementation becomes just: #define BUG_ON(x) then the function call itself vanishes. So, only put the actual bug test inside a BUG_ON(), not the functional part which must always be executed. ^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible 2012-11-12 15:23 ` Russell King - ARM Linux @ 2012-11-12 15:52 ` Sasha Levin 0 siblings, 0 replies; 6+ messages in thread From: Sasha Levin @ 2012-11-12 15:52 UTC (permalink / raw) To: Russell King - ARM Linux Cc: Maarten Lankhorst, linux-kernel, Kukjin Kim, linux-arm-kernel, linux-samsung-soc On 11/12/2012 10:23 AM, Russell King - ARM Linux wrote: > On Mon, Nov 12, 2012 at 04:12:29PM +0100, Maarten Lankhorst wrote: >> Op 08-11-12 21:23, Sasha Levin schreef: >>> @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int combiner_nr, unsigned int i >>> else >>> max_nr = EXYNOS4_MAX_COMBINER_NR; >>> >>> - if (combiner_nr >= max_nr) >>> - BUG(); >>> - if (irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0) >>> - BUG(); >>> + BUG_ON(combiner_nr >= max_nr); >>> + BUG_ON(irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0); >> >> Is it really a good idea to put functions that perform work in a BUG_ON? >> I don't know, but for some reason it just feels wrong. I'd expect code to >> compile fine if BUG_ON was a noop, so doing verification calls only, not >> actual work.. > > Well, it is currently defined as: > > include/asm-generic/bug.h:#define BUG_ON(condition) do { if (unlikely(condition)) BUG(); } while(0) > include/asm-generic/bug.h:#define BUG_ON(condition) do { if (condition) ; } while(0) > > but as these can be overridden, I don't think relying on those > implementations is a good idea; to do so would be fragile. Eg, what if > the BUG_ON() implementation becomes just: > > #define BUG_ON(x) > > then the function call itself vanishes. So, only put the actual bug test > inside a BUG_ON(), not the functional part which must always be executed. Even if we ignore that modifying the side-effects is wrong, there's already more than enough code in the kernel (both in kernel/ / mm/, and in arch/) to cause breakage if for some reason the expression is not evaluated. If some arch decides to not evaluate the expression there it's going to be inherently broken. Thanks, Sasha ^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible 2012-11-12 15:12 ` Maarten Lankhorst 2012-11-12 15:23 ` Russell King - ARM Linux @ 2012-11-12 15:25 ` Sasha Levin 1 sibling, 0 replies; 6+ messages in thread From: Sasha Levin @ 2012-11-12 15:25 UTC (permalink / raw) To: Maarten Lankhorst Cc: linux-kernel, Kukjin Kim, Russell King, linux-arm-kernel, linux-samsung-soc On 11/12/2012 10:12 AM, Maarten Lankhorst wrote: > Op 08-11-12 21:23, Sasha Levin schreef: >> Just use BUG_ON() instead of constructions such as: >> >> if (...) >> BUG() >> >> A simplified version of the semantic patch that makes this transformation >> is as follows: (http://coccinelle.lip6.fr/) >> >> // <smpl> >> @@ >> expression e; >> @@ >> - if (e) BUG(); >> + BUG_ON(e); >> // </smpl> >> >> Signed-off-by: Sasha Levin <sasha.levin@oracle.com> >> --- >> arch/arm/mach-exynos/common.c | 6 ++---- >> 1 file changed, 2 insertions(+), 4 deletions(-) >> >> diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c >> index 4e577f6..6a55a5a 100644 >> --- a/arch/arm/mach-exynos/common.c >> +++ b/arch/arm/mach-exynos/common.c >> @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int combiner_nr, unsigned int i >> else >> max_nr = EXYNOS4_MAX_COMBINER_NR; >> >> - if (combiner_nr >= max_nr) >> - BUG(); >> - if (irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0) >> - BUG(); >> + BUG_ON(combiner_nr >= max_nr); >> + BUG_ON(irq_set_handler_data(irq, &combiner_data[combiner_nr]) != 0); > Is it really a good idea to put functions that perform work in a BUG_ON? > I don't know, but for some reason it just feels wrong. I'd expect code to > compile fine if BUG_ON was a noop, so doing verification calls only, not > actual work.. You can't modify the side-effects of a macro based on kernel configuration. If we're evaluating the expression when BUG_ON() is enabled, you must also evaluate the expression when BUG_ON() is not enabled (HAVE_ARCH_BUG_ON is not set). The only reason I'd not include function calls in a BUG_ON() call is due to readability considerations. In this case it looked okay to me, but if someone thinks that getting the function call into the BUG_ON() complicated things I'm fine with skipping that. Thanks, Sasha ^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH] ARM: dma: use BUG_ON where possible [not found] <1352406191-14303-1-git-send-email-sasha.levin@oracle.com> 2012-11-08 20:23 ` [PATCH] ARM: EXYNOS: use BUG_ON where possible Sasha Levin @ 2012-11-08 20:23 ` Sasha Levin 1 sibling, 0 replies; 6+ messages in thread From: Sasha Levin @ 2012-11-08 20:23 UTC (permalink / raw) To: linux-kernel Cc: Sasha Levin, Russell King, Ben Dooks, Kukjin Kim, linux-arm-kernel, linux-samsung-soc Just use BUG_ON() instead of constructions such as: if (...) BUG() A simplified version of the semantic patch that makes this transformation is as follows: (http://coccinelle.lip6.fr/) // <smpl> @@ expression e; @@ - if (e) BUG(); + BUG_ON(e); // </smpl> Signed-off-by: Sasha Levin <sasha.levin@oracle.com> --- arch/arm/mach-rpc/dma.c | 3 +-- arch/arm/mach-s3c64xx/dma.c | 3 +-- 2 files changed, 2 insertions(+), 4 deletions(-) diff --git a/arch/arm/mach-rpc/dma.c b/arch/arm/mach-rpc/dma.c index 85883b2..92e22ba 100644 --- a/arch/arm/mach-rpc/dma.c +++ b/arch/arm/mach-rpc/dma.c @@ -265,8 +265,7 @@ static void floppy_enable_dma(unsigned int chan, dma_t *dma) unsigned int fiqhandler_length; struct pt_regs regs; - if (fdma->dma.sg) - BUG(); + BUG_ON(fdma->dma.sg); if (fdma->dma.dma_mode == DMA_MODE_READ) { extern unsigned char floppy_fiqin_start, floppy_fiqin_end; diff --git a/arch/arm/mach-s3c64xx/dma.c b/arch/arm/mach-s3c64xx/dma.c index f2a7a17..585c2ae 100644 --- a/arch/arm/mach-s3c64xx/dma.c +++ b/arch/arm/mach-s3c64xx/dma.c @@ -603,8 +603,7 @@ static irqreturn_t s3c64xx_dma_irq(int irq, void *pw) && buff->next != chan->next) buff = buff->next; - if (!buff) - BUG(); + BUG_ON(!buff); if (buff == chan->next) buff = chan->end; -- 1.7.10.4 ^ permalink raw reply related [flat|nested] 6+ messages in thread
end of thread, other threads:[~2012-11-12 15:53 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <1352406191-14303-1-git-send-email-sasha.levin@oracle.com>
2012-11-08 20:23 ` [PATCH] ARM: EXYNOS: use BUG_ON where possible Sasha Levin
2012-11-12 15:12 ` Maarten Lankhorst
2012-11-12 15:23 ` Russell King - ARM Linux
2012-11-12 15:52 ` Sasha Levin
2012-11-12 15:25 ` Sasha Levin
2012-11-08 20:23 ` [PATCH] ARM: dma: " Sasha Levin
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox