From: Jason Yan <yanaijie@huawei.com>
To: Jinpu Wang <jinpu.wang@ionos.com>
Cc: <martin.petersen@oracle.com>, <jejb@linux.ibm.com>,
<linux-scsi@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<hare@suse.com>, <hch@lst.de>, <bvanassche@acm.org>,
<john.garry@huawei.com>
Subject: Re: [PATCH v2 0/8] scsi: libsas: sas address comparation refactor
Date: Mon, 26 Sep 2022 14:37:28 +0800 [thread overview]
Message-ID: <b1cd66fa-411c-2d68-45d7-89aa6219c3cf@huawei.com> (raw)
In-Reply-To: <CAMGffE=6BGVLqTbO3SGFZhCYDjo0U=Ay+JO4h+pNi10Hcb0w9g@mail.gmail.com>
On 2022/9/26 14:09, Jinpu Wang wrote:
> On Sat, Sep 24, 2022 at 9:24 AM Jason Yan <yanaijie@huawei.com> wrote:
>>
>> Sas address conversion and comparation is widely used in libsas and
>> drivers. However they are all opencoded and to avoid the line spill over
>> 80 columns, are mostly split into multi-lines.
>>
>> To make the code easier to read, introduce some helpers with clearer
>> semantics and replace the opencoded segments with them.
>>
>> v1->v2:
>> First factor out sas_find_attached_phy() and replace LLDDs's code
>> with it.
>> Remove three too simple helpers.
>> Rename the helpers with 'sas_' prefix.
>>
> Hi Jason,
>
> Thx for doing this.
>> Jason Yan (8):
>> scsi: libsas: introduce sas_find_attached_phy() helper
>> scsi: pm8001: use sas_find_attached_phy() instead of open coded
>> scsi: mvsas: use sas_find_attached_phy() instead of open coded
>> scsi: hisi_sas: use sas_find_attathed_phy() instead of open coded
> These 4 look good to me.
> Reviewed-by: Jack Wang <jinpu.wang@ionos.com>
Hi Jack,
Thank you very much for the review.
>> scsi: libsas: introduce sas address comparation helpers
>> scsi: libsas: use sas_phy_match_dev_addr() instead of open coded
>> scsi: libsas: use sas_phy_addr_same() instead of open coded
>> scsi: libsas: use sas_phy_match_port_addr() instead of open coded
> These helpers are too simple to replace, we add more loc in the end.
The initial purpose to introduce these helpers is to stop cutting
compare expressions into two lines and to make the code looks clean. We
add more loc in the end because of function declaration and more blank
lines between them.
Thanks,
Jason
>>
>> drivers/scsi/hisi_sas/hisi_sas_main.c | 12 ++------
>> drivers/scsi/libsas/sas_expander.c | 40 ++++++++++++++++-----------
>> drivers/scsi/libsas/sas_internal.h | 17 ++++++++++++
>> drivers/scsi/mvsas/mv_sas.c | 15 +++-------
>> drivers/scsi/pm8001/pm8001_sas.c | 16 ++++-------
>> include/scsi/libsas.h | 2 ++
>> 6 files changed, 54 insertions(+), 48 deletions(-)
>>
>> --
>> 2.31.1
>>
> .
>
prev parent reply other threads:[~2022-09-26 6:37 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-24 7:34 [PATCH v2 0/8] scsi: libsas: sas address comparation refactor Jason Yan
2022-09-24 7:34 ` [PATCH v2 1/8] scsi: libsas: introduce sas_find_attached_phy() helper Jason Yan
2022-09-24 7:34 ` [PATCH v2 2/8] scsi: pm8001: use sas_find_attached_phy() instead of open coded Jason Yan
2022-09-24 7:34 ` [PATCH v2 3/8] scsi: mvsas: " Jason Yan
2022-09-24 7:34 ` [PATCH v2 4/8] scsi: hisi_sas: use sas_find_attathed_phy() " Jason Yan
2022-09-24 7:34 ` [PATCH v2 5/8] scsi: libsas: introduce sas address comparation helpers Jason Yan
2022-09-26 11:44 ` John Garry
2022-09-26 12:16 ` Jason Yan
2022-09-24 7:34 ` [PATCH v2 6/8] scsi: libsas: use sas_phy_match_dev_addr() instead of open coded Jason Yan
2022-09-26 11:43 ` John Garry
2022-09-26 12:18 ` Jason Yan
2022-09-24 7:34 ` [PATCH v2 7/8] scsi: libsas: use sas_phy_addr_same() " Jason Yan
2022-09-24 7:34 ` [PATCH v2 8/8] scsi: libsas: use sas_phy_match_port_addr() " Jason Yan
2022-09-26 6:09 ` [PATCH v2 0/8] scsi: libsas: sas address comparation refactor Jinpu Wang
2022-09-26 6:37 ` Jason Yan [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b1cd66fa-411c-2d68-45d7-89aa6219c3cf@huawei.com \
--to=yanaijie@huawei.com \
--cc=bvanassche@acm.org \
--cc=hare@suse.com \
--cc=hch@lst.de \
--cc=jejb@linux.ibm.com \
--cc=jinpu.wang@ionos.com \
--cc=john.garry@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox