Linux Security Modules development
 help / color / mirror / Atom feed
From: Paul Moore <paul@paul-moore.com>
To: "Mickaël Salaün" <mic@digikod.net>,
	"Christian Brauner" <brauner@kernel.org>,
	"Günther Noack" <gnoack@google.com>,
	"Serge E . Hallyn" <serge@hallyn.com>
Cc: "Mickaël Salaün" <mic@digikod.net>,
	"Daniel Durning" <danieldurning.work@gmail.com>,
	"Jonathan Corbet" <corbet@lwn.net>,
	"Justin Suess" <utilityemal77@gmail.com>,
	"Lennart Poettering" <lennart@poettering.net>,
	"Mikhail Ivanov" <ivanov.mikhail1@huawei-partners.com>,
	"Nicolas Bouchinet" <nicolas.bouchinet@oss.cyber.gouv.fr>,
	"Shervin Oloumi" <enlightened@google.com>,
	"Tingmao Wang" <m@maowtm.org>,
	kernel-team@cloudflare.com, linux-fsdevel@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-security-module@vger.kernel.org
Subject: Re: [PATCH v3 3/12] security: Add LSM_AUDIT_DATA_NS for namespace  audit records
Date: Tue, 11 Aug 2026 16:16:35 -0400	[thread overview]
Message-ID: <5cabf9b33a20f130cedcc423b8b2d151@paul-moore.com> (raw)
In-Reply-To: <20260726161400.3010511-4-mic@digikod.net>

On Jul 26, 2026 =?UTF-8?q?Micka=C3=ABl=20Sala=C3=BCn?= <mic@digikod.net> wrote:
> 
> Add a new LSM audit data type LSM_AUDIT_DATA_NS that logs namespace
> information in audit records.  Two fields are provided:
> 
> - ns_type: the CLONE_NEW* flag identifying the namespace type, logged
>   in hexadecimal.
> 
> - ns_id: the unique 64-bit namespace identifier, retrievable from
>   userspace via NS_GET_ID or listns(2).  Unlike the proc inode number
>   (inum), ns_id is never recycled.  For namespace creation denials,
>   ns_id is 0 because the namespace does not exist yet.

Based on the code in this patch, "ns_type" should be "namespace_type"
and a similar change needs to be done for "ns_id".  Regardless, the
first three patches look fine to me (I can fixup the above during a
merge).

As mentioned previously, I want to merge at least the first three
patches via the LSM tree since we have multiple LSMs which depend on
these new hooks.  I'm happy to also merge the remaining Landlock
patches in this patchset via the LSM tree, or you can manage those
separately; let me know how you would like to proceed with that.

Since we are at -rc7, this is obviously something for after the
upcoming merge window so I'm going to merge the first three patches
into the lsm/dev-staging branch now with the understanding that they
will move over to the lsm/dev branch after the upcoming merge window
is finished.  If you want me to merge the Landlock patches too, just
let me know.

> A new audit data type is needed because no existing LSM_AUDIT_DATA_*
> type carries namespace information.  The closest alternatives (e.g.
> LSM_AUDIT_DATA_TASK or LSM_AUDIT_DATA_NONE with custom strings) would
> either lose the namespace type or require ad-hoc formatting that
> bypasses the structured audit data union.
> 
> Cc: Günther Noack <gnoack@google.com>
> Cc: Paul Moore <paul@paul-moore.com>
> Reviewed-by: Christian Brauner <brauner@kernel.org>
> Reviewed-by: Günther Noack <gnoack@google.com>
> Signed-off-by: Mickaël Salaün <mic@digikod.net>
> ---
> Changes since v1:
> https://patch.msgid.link/20260312100444.2609563-3-mic@digikod.net
> - Replace inum with ns_id in the audit record: ns_id is the stable
>   64-bit namespace identifier (never recycled), accessible to
>   userspace via NS_GET_ID and listns(2) (suggested by Christian
>   Brauner).
> - Add Reviewed-by: Christian Brauner.
> - Add Reviewed-by: Günther Noack.
> ---
>  include/linux/lsm_audit.h | 5 +++++
>  security/lsm_audit.c      | 4 ++++
>  2 files changed, 9 insertions(+)

--
paul-moore.com

  reply	other threads:[~2026-08-11 20:16 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-26 16:13 [PATCH v3 00/12] Landlock: Namespace and capability control Mickaël Salaün
2026-07-26 16:13 ` [PATCH v3 01/12] ns: Free anonymous mount namespaces via ns_common_free() Mickaël Salaün
2026-07-30 10:44   ` Christian Brauner
2026-07-26 16:13 ` [PATCH v3 02/12] security: add LSM blob and hooks for namespaces Mickaël Salaün
2026-07-26 16:13 ` [PATCH v3 03/12] security: Add LSM_AUDIT_DATA_NS for namespace audit records Mickaël Salaün
2026-08-11 20:16   ` Paul Moore [this message]
2026-07-26 16:13 ` [PATCH v3 04/12] landlock: Rename quiet_masks to quiet_access Mickaël Salaün
2026-08-09 16:01   ` Tingmao Wang
2026-07-26 16:13 ` [PATCH v3 05/12] landlock: Wrap per-layer access masks in struct layer_config Mickaël Salaün
2026-08-09 16:01   ` Tingmao Wang
2026-07-26 16:13 ` [PATCH v3 06/12] landlock: Copy the quiet mask in the ruleset merge helper Mickaël Salaün
2026-08-09 16:01   ` Tingmao Wang
2026-07-26 16:13 ` [PATCH v3 07/12] landlock: Enforce namespace use restrictions Mickaël Salaün
2026-08-09 16:01   ` Tingmao Wang
2026-07-26 16:13 ` [PATCH v3 08/12] landlock: Enforce capability restrictions Mickaël Salaün
2026-08-09 16:01   ` Tingmao Wang
2026-07-26 16:13 ` [PATCH v3 09/12] selftests/landlock: Add namespace restriction tests Mickaël Salaün
2026-07-26 16:13 ` [PATCH v3 10/12] selftests/landlock: Add capability " Mickaël Salaün
2026-07-26 16:13 ` [PATCH v3 11/12] samples/landlock: Add capability and namespace restriction support Mickaël Salaün
2026-07-26 16:13 ` [PATCH v3 12/12] landlock: Add documentation for capability and namespace restrictions Mickaël Salaün

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5cabf9b33a20f130cedcc423b8b2d151@paul-moore.com \
    --to=paul@paul-moore.com \
    --cc=brauner@kernel.org \
    --cc=corbet@lwn.net \
    --cc=danieldurning.work@gmail.com \
    --cc=enlightened@google.com \
    --cc=gnoack@google.com \
    --cc=ivanov.mikhail1@huawei-partners.com \
    --cc=kernel-team@cloudflare.com \
    --cc=lennart@poettering.net \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=m@maowtm.org \
    --cc=mic@digikod.net \
    --cc=nicolas.bouchinet@oss.cyber.gouv.fr \
    --cc=serge@hallyn.com \
    --cc=utilityemal77@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox