Linux Sound subsystem development
 help / color / mirror / Atom feed
* [PATCH v2 0/9] ASoC: add new DAI functions
@ 2026-09-18  1:40 Kuninori Morimoto
  2026-09-18  1:41 ` [PATCH v2 1/9] ASoC: soc-dai: use snd_soc_dai_stream_active() Kuninori Morimoto
                   ` (9 more replies)
  0 siblings, 10 replies; 15+ messages in thread
From: Kuninori Morimoto @ 2026-09-18  1:40 UTC (permalink / raw)
  To: Mark Brown, Alvin Sipraga; +Cc: linux-sound


Hi Mark

This is v2 patch-set.
I'm now posting ASoC Capsuling patches.
Current status, and this patch-set postion is below.

x: done
o: This patch-set

[x] move DAI functions
[o] add new DAI functions
[ ] move Component functions
[ ] move Card functions
[ ] add new Component functions
[ ] rename DAI/Component list
[ ] move Card functions
[ ] add new Card functions
[ ] adjust Test
[ ] use new Card register
[ ] use new functions on all drivers  -- (A)
[ ] Capsule DAI/Component/Card

This patch-set adds new DAI functions to get dai->xxx, because each
driver will not be access to them directly when capsuling has done.
This patch-set just adds new functions. Basically it is just adding new
function, but it will update driver in the same time if it user was very few.
All user will use them at (A) timing.

v1 -> v2

	- Add Reviewed-by on each patches
	- snd_soc_dai_symmetric_get_params() is decomposed to
	  snd_soc_dai_get_symmetric_rate()
	  snd_soc_dai_get_symmetric_channels()
	  snd_soc_dai_get_symmetric_sample_bits()
	- snd_soc_dai_xxx_active_xxx() patches are merged
	- snd_soc_dai_active_xxx() functions are renamed
	  - I have discussed with Alvin to rename .active to .count,
	    but it will be kept as-is for now
	- fixup/tidyup git-log
	- don't update mediatek for now

Link: https://lore.kernel.org/r/87qziwliaj.wl-kuninori.morimoto.gx@renesas.com

Kuninori Morimoto (9):
  ASoC: soc-dai: use snd_soc_dai_stream_active()
  ASoC: soc-dai: add snd_soc_dai_id()
  ASoC: soc-dai: add snd_soc_dai_to_component()
  ASoC: soc-dai: add snd_soc_dai_to_driver()
  ASoC: soc-dai: add snd_soc_dai_{to/from}_list()
  ASoC: soc-dai: add snd_soc_dai_get_symmetric_xxx()
  ASoC: soc-dai: add snd_soc_dai_{set/to}_priv()
  ASoC: soc-dai: add snd_soc_dai_get_bclk[_ratio]()
  ASoC: soc-dai: rename snd_soc_dai_action() to snd_soc_dai_active_update()

 include/sound/soc-component.h | 14 +++++--
 include/sound/soc-dai.h       | 23 +++++------
 sound/soc/sdca/sdca_asoc.c    |  4 +-
 sound/soc/soc-dai.c           | 78 ++++++++++++++++++++++++++++++++---
 sound/soc/soc-dapm.c          |  9 ++--
 sound/soc/soc-internal.h      |  3 ++
 sound/soc/soc-pcm.c           | 21 ++++++----
 7 files changed, 118 insertions(+), 34 deletions(-)

-- 
2.53.0


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2026-09-28 21:02 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-09-18  1:40 [PATCH v2 0/9] ASoC: add new DAI functions Kuninori Morimoto
2026-09-18  1:41 ` [PATCH v2 1/9] ASoC: soc-dai: use snd_soc_dai_stream_active() Kuninori Morimoto
2026-09-24  9:34   ` Alvin Šipraga
2026-09-18  1:41 ` [PATCH v2 2/9] ASoC: soc-dai: add snd_soc_dai_id() Kuninori Morimoto
2026-09-18  1:43 ` [PATCH v2 3/9] ASoC: soc-dai: add snd_soc_dai_to_component() Kuninori Morimoto
2026-09-18  1:43 ` [PATCH v2 4/9] ASoC: soc-dai: add snd_soc_dai_to_driver() Kuninori Morimoto
2026-09-18  1:43 ` [PATCH v2 5/9] ASoC: soc-dai: add snd_soc_dai_{to/from}_list() Kuninori Morimoto
2026-09-18  1:44 ` [PATCH v2 6/9] ASoC: soc-dai: add snd_soc_dai_get_symmetric_xxx() Kuninori Morimoto
2026-09-24  9:35   ` Alvin Šipraga
2026-09-18  1:45 ` [PATCH v2 7/9] ASoC: soc-dai: add snd_soc_dai_{set/to}_priv() Kuninori Morimoto
2026-09-18  1:45 ` [PATCH v2 8/9] ASoC: soc-dai: add snd_soc_dai_get_bclk[_ratio]() Kuninori Morimoto
2026-09-24  9:36   ` Alvin Šipraga
2026-09-18  1:46 ` [PATCH v2 9/9] ASoC: soc-dai: rename snd_soc_dai_action() to snd_soc_dai_active_update() Kuninori Morimoto
2026-09-24  9:33   ` Alvin Šipraga
2026-09-28 12:36 ` [PATCH v2 0/9] ASoC: add new DAI functions Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox