* [PATCH 00/35] Documentation fixes for Kernel 5.8
@ 2020-04-08 15:45 Mauro Carvalho Chehab
2020-04-08 15:46 ` [PATCH 21/35] docs: spi: spi.h: fix a doc building warning Mauro Carvalho Chehab
0 siblings, 1 reply; 6+ messages in thread
From: Mauro Carvalho Chehab @ 2020-04-08 15:45 UTC (permalink / raw)
To: Linux Doc Mailing List
Cc: Mauro Carvalho Chehab, linux-kernel, Jonathan Corbet, Rob Herring,
Maxime Ripard, Yuti Amonkar, Kishon Vijay Abraham I, devicetree,
linux-arch, kvm, kvm-ppc, linuxppc-dev, dri-devel,
linux-arm-kernel, linux-fsdevel, linux-unionfs, linux-mm,
linux-rdma, kvmarm, linux-crypto, linux-media, linux-arm-msm,
freedreno, linux-afs, ecryptfs, linux-ntfs-dev, ocfs2-devel,
linux-pci, linux1394-devel, linux-ide, linux-edac, linux-spi,
MPT-FusionLinux.pdl, linux-scsi, Stephen Boyd, Sandeep Maheswaram,
Matthias Kaehlcke, linux-usb, Linus Walleij, Sudeep Holla,
Geert Uytterhoeven, Matthias Brugger, netdev, linux-i2c
Hi Jon,
I have a large list of patches this time for the Documentation/. So, I'm
starting sending them a little earier. Yet, those are meant to be applied
after the end of the merge window. They're based on today's linux-next,
with has only 49 patches pending to be applied upstream touching
Documentation/, so I don't expect much conflicts if applied early at
-rc cycle.
Most of the patches here were already submitted, but weren't
merged yet at next. So, it seems that nobody picked them yet.
In any case, most of those patches here are independent from
the others.
The number of doc build warnings have been rising with time.
The main goal with this series is to get rid of most Sphinx warnings
and other errors.
Patches 1 to 5: fix broken references detected by this tool:
./scripts/documentation-file-ref-check
The other patches fix other random errors due to tags being
mis-interpreted or mis-used.
You should notice that several patches touch kernel-doc scripts.
IMHO, some of the warnings are actually due to kernel-doc being
too pedantic. So, I ended by improving some things at the toolset,
in order to make it smarter. That's the case of those patches:
docs: scripts/kernel-doc: accept blank lines on parameter description
scripts: kernel-doc: accept negation like !@var
scripts: kernel-doc: proper handle @foo->bar()
The last 4 patches address problems with PDF building.
The first one address a conflict that will rise during the merge
window: Documentation/media will be removed. Instead of
just drop it from the list of PDF documents, I opted to drop the
entire list, as conf.py will auto-generate from the sources:
docs: LaTeX/PDF: drop list of documents
Also, right now, PDF output is broken due to a namespace conflict
at I2c (two pdf outputs there will have the same name).
docs: i2c: rename i2c.svg to i2c_bus.svg
The third PDF patch is not really a fix, but it helps a lot to identify
if the build succeeded or not, by placing the final PDF output on
a separate dir:
docs: Makefile: place final pdf docs on a separate dir
Finally, the last one solves a bug since the first supported Sphinx
version, with also impacts PDF output: basically while nested tables
are valid with ReST notation, the toolset only started supporting
it on PDF output since version 2.4:
docs: update recommended Sphinx version to 2.4.4
PS.: Due to the large number of C/C, I opted to keep a smaller
set of C/C at this first e-mail (only e-mails with "L:" tag from
MAINTAINERS file).
Mauro Carvalho Chehab (35):
MAINTAINERS: dt: update display/allwinner file entry
docs: dt: fix broken reference to phy-cadence-torrent.yaml
docs: fix broken references to text files
docs: fix broken references for ReST files that moved around
docs: filesystems: fix renamed references
docs: amu: supress some Sphinx warnings
docs: arm64: booting.rst: get rid of some warnings
docs: pci: boot-interrupts.rst: improve html output
futex: get rid of a kernel-docs build warning
firewire: firewire-cdev.hL get rid of a docs warning
scripts: kernel-doc: proper handle @foo->bar()
lib: bitmap.c: get rid of some doc warnings
ata: libata-core: fix a doc warning
fs: inode.c: get rid of docs warnings
docs: ras: get rid of some warnings
docs: ras: don't need to repeat twice the same thing
docs: watch_queue.rst: supress some Sphinx warnings
scripts: kernel-doc: accept negation like !@var
docs: infiniband: verbs.c: fix some documentation warnings
docs: scripts/kernel-doc: accept blank lines on parameter description
docs: spi: spi.h: fix a doc building warning
docs: drivers: fix some warnings at base/platform.c when building docs
docs: fusion: mptbase.c: get rid of a doc build warning
docs: mm: slab.h: fix a broken cross-reference
docs mm: userfaultfd.rst: use ``foo`` for literals
docs: mm: userfaultfd.rst: use a cross-reference for a section
docs: vm: index.rst: add an orphan doc to the building system
docs: dt: qcom,dwc3.txt: fix cross-reference for a converted file
MAINTAINERS: dt: fix pointers for ARM Integrator, Versatile and
RealView
docs: dt: fix a broken reference for a file converted to json
powerpc: docs: cxl.rst: mark two section titles as such
docs: LaTeX/PDF: drop list of documents
docs: i2c: rename i2c.svg to i2c_bus.svg
docs: Makefile: place final pdf docs on a separate dir
docs: update recommended Sphinx version to 2.4.4
Documentation/ABI/stable/sysfs-devices-node | 2 +-
Documentation/ABI/testing/procfs-smaps_rollup | 2 +-
Documentation/Makefile | 6 +-
Documentation/PCI/boot-interrupts.rst | 34 +--
Documentation/admin-guide/cpu-load.rst | 2 +-
Documentation/admin-guide/mm/userfaultfd.rst | 209 +++++++++---------
Documentation/admin-guide/nfs/nfsroot.rst | 2 +-
Documentation/admin-guide/ras.rst | 18 +-
Documentation/arm64/amu.rst | 5 +
Documentation/arm64/booting.rst | 36 +--
Documentation/conf.py | 38 ----
.../bindings/net/qualcomm-bluetooth.txt | 2 +-
.../bindings/phy/ti,phy-j721e-wiz.yaml | 2 +-
.../devicetree/bindings/usb/qcom,dwc3.txt | 4 +-
.../doc-guide/maintainer-profile.rst | 2 +-
.../driver-api/driver-model/device.rst | 4 +-
.../driver-api/driver-model/overview.rst | 2 +-
Documentation/filesystems/dax.txt | 2 +-
Documentation/filesystems/dnotify.txt | 2 +-
.../filesystems/ramfs-rootfs-initramfs.rst | 2 +-
Documentation/filesystems/sysfs.rst | 2 +-
Documentation/i2c/{i2c.svg => i2c_bus.svg} | 2 +-
Documentation/i2c/summary.rst | 2 +-
Documentation/memory-barriers.txt | 2 +-
Documentation/powerpc/cxl.rst | 2 +
.../powerpc/firmware-assisted-dump.rst | 2 +-
Documentation/process/adding-syscalls.rst | 2 +-
Documentation/process/submit-checklist.rst | 2 +-
Documentation/sphinx/requirements.txt | 2 +-
.../it_IT/process/adding-syscalls.rst | 2 +-
.../it_IT/process/submit-checklist.rst | 2 +-
.../translations/ko_KR/memory-barriers.txt | 2 +-
.../translations/zh_CN/filesystems/sysfs.txt | 8 +-
.../zh_CN/process/submit-checklist.rst | 2 +-
Documentation/virt/kvm/arm/pvtime.rst | 2 +-
Documentation/virt/kvm/devices/vcpu.rst | 2 +-
Documentation/virt/kvm/hypercalls.rst | 4 +-
Documentation/virt/kvm/mmu.rst | 2 +-
Documentation/virt/kvm/review-checklist.rst | 2 +-
Documentation/vm/index.rst | 1 +
Documentation/watch_queue.rst | 34 ++-
MAINTAINERS | 7 +-
arch/powerpc/include/uapi/asm/kvm_para.h | 2 +-
arch/x86/kvm/mmu/mmu.c | 2 +-
drivers/ata/libata-core.c | 2 +-
drivers/base/core.c | 2 +-
drivers/base/platform.c | 6 +-
.../allwinner/sun8i-ce/sun8i-ce-cipher.c | 2 +-
.../crypto/allwinner/sun8i-ce/sun8i-ce-core.c | 2 +-
.../allwinner/sun8i-ss/sun8i-ss-cipher.c | 2 +-
.../crypto/allwinner/sun8i-ss/sun8i-ss-core.c | 2 +-
drivers/gpu/drm/Kconfig | 2 +-
drivers/gpu/drm/drm_ioctl.c | 2 +-
drivers/gpu/drm/msm/disp/dpu1/dpu_kms.h | 2 +-
drivers/hwtracing/coresight/Kconfig | 2 +-
drivers/infiniband/core/verbs.c | 7 +-
drivers/media/v4l2-core/v4l2-fwnode.c | 2 +-
drivers/message/fusion/mptbase.c | 8 +-
fs/Kconfig | 2 +-
fs/Kconfig.binfmt | 2 +-
fs/adfs/Kconfig | 2 +-
fs/affs/Kconfig | 2 +-
fs/afs/Kconfig | 6 +-
fs/bfs/Kconfig | 2 +-
fs/cramfs/Kconfig | 2 +-
fs/ecryptfs/Kconfig | 2 +-
fs/fat/Kconfig | 8 +-
fs/fuse/Kconfig | 2 +-
fs/fuse/dev.c | 2 +-
fs/hfs/Kconfig | 2 +-
fs/hpfs/Kconfig | 2 +-
fs/inode.c | 6 +-
fs/isofs/Kconfig | 2 +-
fs/namespace.c | 2 +-
fs/notify/inotify/Kconfig | 2 +-
fs/ntfs/Kconfig | 2 +-
fs/ocfs2/Kconfig | 2 +-
fs/overlayfs/Kconfig | 6 +-
fs/proc/Kconfig | 4 +-
fs/romfs/Kconfig | 2 +-
fs/sysfs/dir.c | 2 +-
fs/sysfs/file.c | 2 +-
fs/sysfs/mount.c | 2 +-
fs/sysfs/symlink.c | 2 +-
fs/sysv/Kconfig | 2 +-
fs/udf/Kconfig | 2 +-
include/linux/kobject.h | 2 +-
include/linux/kobject_ns.h | 2 +-
include/linux/mm.h | 4 +-
include/linux/relay.h | 2 +-
include/linux/slab.h | 2 +-
include/linux/spi/spi.h | 1 +
include/linux/sysfs.h | 2 +-
include/uapi/linux/ethtool_netlink.h | 2 +-
include/uapi/linux/firewire-cdev.h | 2 +-
include/uapi/linux/kvm.h | 4 +-
include/uapi/rdma/rdma_user_ioctl_cmds.h | 2 +-
kernel/futex.c | 3 +
kernel/relay.c | 2 +-
lib/bitmap.c | 27 +--
lib/kobject.c | 4 +-
mm/gup.c | 12 +-
scripts/kernel-doc | 41 ++--
tools/include/uapi/linux/kvm.h | 4 +-
virt/kvm/arm/vgic/vgic-mmio-v3.c | 2 +-
virt/kvm/arm/vgic/vgic.h | 4 +-
106 files changed, 373 insertions(+), 338 deletions(-)
rename Documentation/i2c/{i2c.svg => i2c_bus.svg} (99%)
--
2.25.2
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 21/35] docs: spi: spi.h: fix a doc building warning
2020-04-08 15:45 [PATCH 00/35] Documentation fixes for Kernel 5.8 Mauro Carvalho Chehab
@ 2020-04-08 15:46 ` Mauro Carvalho Chehab
2020-04-08 15:49 ` Mark Brown
0 siblings, 1 reply; 6+ messages in thread
From: Mauro Carvalho Chehab @ 2020-04-08 15:46 UTC (permalink / raw)
To: Linux Doc Mailing List
Cc: Mauro Carvalho Chehab, linux-kernel, Jonathan Corbet, Mark Brown,
linux-spi
We need to add a blank line to avoid this warning:
./include/linux/spi/spi.h:401: WARNING: Unexpected indentation.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
---
include/linux/spi/spi.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/linux/spi/spi.h b/include/linux/spi/spi.h
index 38286de779e3..aac57b5b7c21 100644
--- a/include/linux/spi/spi.h
+++ b/include/linux/spi/spi.h
@@ -394,6 +394,7 @@ static inline void spi_unregister_driver(struct spi_driver *sdrv)
* for example doing DMA mapping. Called from threaded
* context.
* @transfer_one: transfer a single spi_transfer.
+ *
* - return 0 if the transfer is finished,
* - return 1 if the transfer is still in progress. When
* the driver is finished with this transfer it must
--
2.25.2
^ permalink raw reply related [flat|nested] 6+ messages in thread
* Re: [PATCH 21/35] docs: spi: spi.h: fix a doc building warning
2020-04-08 15:46 ` [PATCH 21/35] docs: spi: spi.h: fix a doc building warning Mauro Carvalho Chehab
@ 2020-04-08 15:49 ` Mark Brown
2020-04-08 16:11 ` Mauro Carvalho Chehab
0 siblings, 1 reply; 6+ messages in thread
From: Mark Brown @ 2020-04-08 15:49 UTC (permalink / raw)
To: Mauro Carvalho Chehab
Cc: Linux Doc Mailing List, linux-kernel, Jonathan Corbet, linux-spi
[-- Attachment #1: Type: text/plain, Size: 637 bytes --]
On Wed, Apr 08, 2020 at 05:46:13PM +0200, Mauro Carvalho Chehab wrote:
> We need to add a blank line to avoid this warning:
>
> ./include/linux/spi/spi.h:401: WARNING: Unexpected indentation.
> * @transfer_one: transfer a single spi_transfer.
> + *
> * - return 0 if the transfer is finished,
> * - return 1 if the transfer is still in progress. When
> * the driver is finished with this transfer it must
Are you sure this is a sensible fix? The following lines should be part
of the documentation for transfer_one, will that be the case after your
change?
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 21/35] docs: spi: spi.h: fix a doc building warning
2020-04-08 15:49 ` Mark Brown
@ 2020-04-08 16:11 ` Mauro Carvalho Chehab
2020-04-08 16:16 ` Mark Brown
0 siblings, 1 reply; 6+ messages in thread
From: Mauro Carvalho Chehab @ 2020-04-08 16:11 UTC (permalink / raw)
To: Mark Brown
Cc: Linux Doc Mailing List, linux-kernel, Jonathan Corbet, linux-spi
Hi Mark,
Em Wed, 8 Apr 2020 16:49:25 +0100
Mark Brown <broonie@kernel.org> escreveu:
> On Wed, Apr 08, 2020 at 05:46:13PM +0200, Mauro Carvalho Chehab wrote:
> > We need to add a blank line to avoid this warning:
> >
> > ./include/linux/spi/spi.h:401: WARNING: Unexpected indentation.
>
> > * @transfer_one: transfer a single spi_transfer.
> > + *
> > * - return 0 if the transfer is finished,
> > * - return 1 if the transfer is still in progress. When
> > * the driver is finished with this transfer it must
>
> Are you sure this is a sensible fix? The following lines should be part
> of the documentation for transfer_one, will that be the case after your
> change?
Without that, Sphinx will warn and may produce something unexpected.
Yet, right now, kernel-doc is not prepared for the above change.
When kernel-doc finds a blank line, it just assumes that the
remaining content is part of the description. That is due to some
laziness on its parser.
This is fixed by patch 20/35 on this series:
Subject: [PATCH 20/35] docs: scripts/kernel-doc: accept blank lines on parameter description
If this patch is applied after 20/25, the output should produce the
correct result:
https://www.infradead.org/~mchehab/kernel_docs/driver-api/spi.html#spi-master-methods
Thanks,
Mauro
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 21/35] docs: spi: spi.h: fix a doc building warning
2020-04-08 16:11 ` Mauro Carvalho Chehab
@ 2020-04-08 16:16 ` Mark Brown
2020-04-08 16:42 ` Mauro Carvalho Chehab
0 siblings, 1 reply; 6+ messages in thread
From: Mark Brown @ 2020-04-08 16:16 UTC (permalink / raw)
To: Mauro Carvalho Chehab
Cc: Linux Doc Mailing List, linux-kernel, Jonathan Corbet, linux-spi
[-- Attachment #1: Type: text/plain, Size: 692 bytes --]
On Wed, Apr 08, 2020 at 06:11:54PM +0200, Mauro Carvalho Chehab wrote:
> Mark Brown <broonie@kernel.org> escreveu:
> > Are you sure this is a sensible fix? The following lines should be part
> > of the documentation for transfer_one, will that be the case after your
> > change?
> Without that, Sphinx will warn and may produce something unexpected.
Right, but if the warning is telling us something useful we want to
handle it rather than just shutting it up.
> If this patch is applied after 20/25, the output should produce the
> correct result:
> https://www.infradead.org/~mchehab/kernel_docs/driver-api/spi.html#spi-master-methods
OK.
Acked-by: Mark Brown <broonie@kernel.org>
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 21/35] docs: spi: spi.h: fix a doc building warning
2020-04-08 16:16 ` Mark Brown
@ 2020-04-08 16:42 ` Mauro Carvalho Chehab
0 siblings, 0 replies; 6+ messages in thread
From: Mauro Carvalho Chehab @ 2020-04-08 16:42 UTC (permalink / raw)
To: Mark Brown
Cc: Linux Doc Mailing List, linux-kernel, Jonathan Corbet, linux-spi
Em Wed, 8 Apr 2020 17:16:29 +0100
Mark Brown <broonie@kernel.org> escreveu:
> On Wed, Apr 08, 2020 at 06:11:54PM +0200, Mauro Carvalho Chehab wrote:
> > Mark Brown <broonie@kernel.org> escreveu:
>
> > > Are you sure this is a sensible fix? The following lines should be part
> > > of the documentation for transfer_one, will that be the case after your
> > > change?
>
> > Without that, Sphinx will warn and may produce something unexpected.
>
> Right, but if the warning is telling us something useful we want to
> handle it rather than just shutting it up.
True. Without adding the blank line, kernel-doc would output this as:
``transfer_one``
transfer a single spi_transfer.
- return 0 if the transfer is finished,
- return 1 if the transfer is still in progress. When
the driver is finished with this transfer it must
call spi_finalize_current_transfer() so the subsystem
can issue the next transfer. Note: transfer_one and
transfer_one_message are mutually exclusive; when both
are set, the generic subsystem does not call your
transfer_one callback.
This would be parsed by Sphinx (newer versions) as if the second line:
transfer a single spi_transfer.
would be a sort of subtitle that should be highlighted with a
vertical line before that. E. g. something equivalent to:
============
|transfer_one|
-------------------------------
|transfer a single spi_transfer.|
- return 0 if the transfer is finished,
- return 1 if the transfer is still in progress. When
the driver is finished with this transfer it must
call spi_finalize_current_transfer() so the subsystem
can issue the next transfer. Note: transfer_one and
transfer_one_message are mutually exclusive; when both
are set, the generic subsystem does not call your
transfer_one callback.
Which is not the desired result.
Adding a blank line after it fixes the issue, making it produce the
expected output.
>
> > If this patch is applied after 20/25, the output should produce the
> > correct result:
>
> > https://www.infradead.org/~mchehab/kernel_docs/driver-api/spi.html#spi-master-methods
>
> OK.
>
> Acked-by: Mark Brown <broonie@kernel.org>
Thanks,
Mauro
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2020-04-08 16:42 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2020-04-08 15:45 [PATCH 00/35] Documentation fixes for Kernel 5.8 Mauro Carvalho Chehab
2020-04-08 15:46 ` [PATCH 21/35] docs: spi: spi.h: fix a doc building warning Mauro Carvalho Chehab
2020-04-08 15:49 ` Mark Brown
2020-04-08 16:11 ` Mauro Carvalho Chehab
2020-04-08 16:16 ` Mark Brown
2020-04-08 16:42 ` Mauro Carvalho Chehab
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox