From: Greg KH <gregkh@linuxfoundation.org>
To: Vivek BalachandharTN <vivek.balachandhar@gmail.com>
Cc: linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 1/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix index name
Date: Fri, 18 Jul 2025 09:43:28 +0200 [thread overview]
Message-ID: <2025071809-sulfur-unvaried-8e9a@gregkh> (raw)
In-Reply-To: <20250718025206.171361-2-vivek.balachandhar@gmail.com>
On Fri, Jul 18, 2025 at 02:52:06AM +0000, Vivek BalachandharTN wrote:
> This patch renames the global array ChannelPlan to channel_plan
> to follow Linux kernel coding style. Also renamed the index
> variable from channel_plan to chan_plan_idx to avoid
> shadowing and improve readability.
>
> v2:
> - Fixed Cc list to include Greg and staging list
>
> v3:
> - Removed EXTRAVERSION = -vivek from Makefile.
>
> v4:
> - Tested and verified Makefile EXTRAVERSION removal does not break build
> - Removed EXTRAVERSION = -vivek to keep version clean
>
> v5:
> - Renamed chan_plan_idx to chan per Dan Carpenter's feedback.
> - Removed mistaken blank line addition in init/main.c.
> - Removed unrelated changes to Makefile and init/main.c.
>
> Signed-off-by: Vivek BalachandharTN <vivek.balachandhar@gmail.com>
> ---
> drivers/staging/rtl8192u/r8192U_core.c | 16 +++++++++-------
> 1 file changed, 9 insertions(+), 7 deletions(-)
Again, please read the documentation file for how to properly put a
version log for the patch (it goes below the --- line.) Look at the
hundreds/thousands of examples on the public mailing lists for examples
of what to do here.
And also, please make sure that your patch actually applies against the
latest development tree (i.e. linux-next or the subsystem development
tree.) I don't think that's the case here at all :(
thanks,
greg k-h
next prev parent reply other threads:[~2025-07-18 7:43 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-18 2:52 [PATCH v5 0/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix shadowed index Vivek BalachandharTN
2025-07-18 2:52 ` [PATCH v5 1/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix index name Vivek BalachandharTN
2025-07-18 7:43 ` Greg KH [this message]
2025-07-18 18:29 ` Vivek BalachandharTN
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2025071809-sulfur-unvaried-8e9a@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=vivek.balachandhar@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox