Linux kernel staging patches
 help / color / mirror / Atom feed
* [PATCH v5 0/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix shadowed index
@ 2025-07-18  2:52 Vivek BalachandharTN
  2025-07-18  2:52 ` [PATCH v5 1/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix index name Vivek BalachandharTN
  0 siblings, 1 reply; 4+ messages in thread
From: Vivek BalachandharTN @ 2025-07-18  2:52 UTC (permalink / raw)
  To: gregkh; +Cc: linux-staging, linux-kernel, Vivek BalachandharTN

This is my first contribution to Linux Kernel. 
This patch addresses a naming inconsistency in the rtl8192u driver.

- The global array `ChannelPlan` has been renamed to `channel_plan` to follow Linux kernel naming conventions.
- The local variable used as an index into this array was also named `channel_plan`, which caused shadowing. It has been renamed to `chan` for clarity and to avoid confusion.

Changes since v4:
- Renamed `chan_plan_idx` to `chan` per Dan Carpenter’s suggestion.
- Removed unrelated and accidental changes to `Makefile` and `init/main.c`.

This change improves code readability and compliance with kernel coding style.

---

Vivek BalachandharTN (1):
  staging: rtl8192u: Rename ChannelPlan to channel_plan and fix index
    name

 drivers/staging/rtl8192u/r8192U_core.c | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

-- 
2.39.5

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2025-07-18 18:29 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-07-18  2:52 [PATCH v5 0/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix shadowed index Vivek BalachandharTN
2025-07-18  2:52 ` [PATCH v5 1/1] staging: rtl8192u: Rename ChannelPlan to channel_plan and fix index name Vivek BalachandharTN
2025-07-18  7:43   ` Greg KH
2025-07-18 18:29     ` Vivek BalachandharTN

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox