Linux kernel staging patches
 help / color / mirror / Atom feed
* [PATCH] staging: media: atomisp: use kmalloc_array() for sh_css_blob_info
@ 2026-03-12 21:08 Lin YuChen
  2026-03-13  9:40 ` Andy Shevchenko
  0 siblings, 1 reply; 2+ messages in thread
From: Lin YuChen @ 2026-03-12 21:08 UTC (permalink / raw)
  To: andy, hansg, mchehab, gregkh
  Cc: sakari.ailus, linux-kernel, linux-media, linux-staging,
	starpt.official

Replace the open-coded multiplication in kmalloc() with kmalloc_array()
to provide overflow protection and improve code readability.

Signed-off-by: Lin YuChen <starpt.official@gmail.com>
---
 drivers/staging/media/atomisp/pci/sh_css_firmware.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/media/atomisp/pci/sh_css_firmware.c b/drivers/staging/media/atomisp/pci/sh_css_firmware.c
index 57ecf5549c23..88757076c950 100644
--- a/drivers/staging/media/atomisp/pci/sh_css_firmware.c
+++ b/drivers/staging/media/atomisp/pci/sh_css_firmware.c
@@ -253,9 +253,9 @@ sh_css_load_firmware(struct device *dev, const char *fw_data,
 	sh_css_num_binaries = file_header->binary_nr;
 	/* Only allocate memory for ISP blob info */
 	if (sh_css_num_binaries > NUM_OF_SPS) {
-		sh_css_blob_info = kmalloc(
-		    (sh_css_num_binaries - NUM_OF_SPS) *
-		    sizeof(*sh_css_blob_info), GFP_KERNEL);
+		sh_css_blob_info =
+			kmalloc_array((sh_css_num_binaries - NUM_OF_SPS),
+				      sizeof(*sh_css_blob_info), GFP_KERNEL);
 		if (!sh_css_blob_info)
 			return -ENOMEM;
 	} else {
-- 
2.34.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] staging: media: atomisp: use kmalloc_array() for sh_css_blob_info
  2026-03-12 21:08 [PATCH] staging: media: atomisp: use kmalloc_array() for sh_css_blob_info Lin YuChen
@ 2026-03-13  9:40 ` Andy Shevchenko
  0 siblings, 0 replies; 2+ messages in thread
From: Andy Shevchenko @ 2026-03-13  9:40 UTC (permalink / raw)
  To: Lin YuChen
  Cc: andy, hansg, mchehab, gregkh, sakari.ailus, linux-kernel,
	linux-media, linux-staging

On Fri, Mar 13, 2026 at 05:08:01AM +0800, Lin YuChen wrote:
> Replace the open-coded multiplication in kmalloc() with kmalloc_array()
> to provide overflow protection and improve code readability.

...

> +		sh_css_blob_info =
> +			kmalloc_array((sh_css_num_binaries - NUM_OF_SPS),

Too many parentheses.

> +				      sizeof(*sh_css_blob_info), GFP_KERNEL);
>  		if (!sh_css_blob_info)
>  			return -ENOMEM;

-- 
With Best Regards,
Andy Shevchenko



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-03-13  9:40 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-03-12 21:08 [PATCH] staging: media: atomisp: use kmalloc_array() for sh_css_blob_info Lin YuChen
2026-03-13  9:40 ` Andy Shevchenko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox