Linux kernel staging patches
 help / color / mirror / Atom feed
* [PATCH v2] staging: rtl8712: Change type and name of local variable
@ 2024-03-20 19:50 Ayush Tiwari
  2024-03-20 21:05 ` Julia Lawall
  0 siblings, 1 reply; 2+ messages in thread
From: Ayush Tiwari @ 2024-03-20 19:50 UTC (permalink / raw)
  To: Larry.Finger, florian.c.schilhabel, gregkh, linux-kernel,
	linux-staging
  Cc: outreachy

Change data type of local variable blnPending from u8 to bool and
renamed it to len_padding since it only assumes 0 or 1 values and
seems to add a padding based on wr_sz. This change also address the
checkpatch warning "Avoid Camelcase".

Signed-off-by: Ayush Tiwari <ayushtiw0110@gmail.com>
---
Changes in v2: Changed values of blnPending from 0/1 to false/true
and renamed blnPending to len_padding

 drivers/staging/rtl8712/rtl8712_cmd.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/rtl8712/rtl8712_cmd.c b/drivers/staging/rtl8712/rtl8712_cmd.c
index bb7db96ed821..f499bbbf5bf5 100644
--- a/drivers/staging/rtl8712/rtl8712_cmd.c
+++ b/drivers/staging/rtl8712/rtl8712_cmd.c
@@ -284,7 +284,7 @@ int r8712_cmd_thread(void *context)
 		pcmd = cmd_hdl_filter(padapter, pcmd);
 		if (pcmd) { /* if pcmd != NULL, cmd will be handled by f/w */
 			struct dvobj_priv *pdvobj = &padapter->dvobjpriv;
-			u8 blnPending = 0;
+			bool len_padding = false;
 			u16 cmdcode = pcmd->cmdcode;
 
 			pcmdpriv->cmd_issued_cnt++;
@@ -294,12 +294,12 @@ int r8712_cmd_thread(void *context)
 						     0x0000ffff);
 			if (pdvobj->ishighspeed) {
 				if ((wr_sz % 512) == 0)
-					blnPending = 1;
+					len_padding = true;
 			} else {
 				if ((wr_sz % 64) == 0)
-					blnPending = 1;
+					len_padding = true;
 			}
-			if (blnPending) { /* 32 bytes for TX Desc - 8 offset */
+			if (len_padding) { /* 32 bytes for TX Desc - 8 offset */
 				pdesc->txdw0 |= cpu_to_le32(((TXDESC_SIZE +
 						OFFSET_SZ + 8) << OFFSET_SHT) &
 						0x00ff0000);
@@ -318,7 +318,7 @@ int r8712_cmd_thread(void *context)
 					       (pcmdpriv->cmd_seq << 24));
 			pcmdbuf += 2; /* 8 bytes alignment */
 			memcpy((u8 *)pcmdbuf, pcmd->parmbuf, pcmd->cmdsz);
-			if (blnPending)
+			if (len_padding)
 				wr_sz += 8;   /* Append 8 bytes */
 			r8712_write_mem(padapter, RTL8712_DMA_H2CCMD, wr_sz,
 					(u8 *)pdesc);
-- 
2.40.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2024-03-20 21:05 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2024-03-20 19:50 [PATCH v2] staging: rtl8712: Change type and name of local variable Ayush Tiwari
2024-03-20 21:05 ` Julia Lawall

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox