From: Andre Przywara <andre.przywara@arm.com>
To: Chen-Yu Tsai <wens@kernel.org>
Cc: Andrew Lunn <andrew@lunn.ch>, Andrew Lunn <andrew+netdev@lunn.ch>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Jernej Skrabec <jernej@kernel.org>,
Samuel Holland <samuel@sholland.org>,
netdev@vger.kernel.org, devicetree@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-sunxi@lists.linux.dev
Subject: Re: [PATCH net 0/2] allwinner: a523: Rename emac0 to gmac0
Date: Mon, 7 Jul 2025 18:15:13 +0100 [thread overview]
Message-ID: <20250707181513.6efc6558@donnerap.manchester.arm.com> (raw)
In-Reply-To: <CAGb2v64vxtAVi3QK3a=mvDz2u+gKQ6XPMN-JB46eEuwfusMG2w@mail.gmail.com>
On Sun, 6 Jul 2025 21:14:09 +0800
Chen-Yu Tsai <wens@kernel.org> wrote:
Hi,
> On Sun, Jul 6, 2025 at 7:23 AM Andre Przywara <andre.przywara@arm.com> wrote:
> >
> > On Sat, 5 Jul 2025 17:53:17 +0200
> > Andrew Lunn <andrew@lunn.ch> wrote:
> >
> > Hi Andrew,
> >
> > > > So it's really whatever Allwinner wants to call it. I would rather have
> > > > the names follow the datasheet than us making some scheme up.
> > >
> > > Are the datasheets publicly available?
> >
> > We collect them in the sunxi wiki (see the links below), but just to
> > make sure:
> > I am not disputing that GMAC is the name mentioned in the A523 manual,
> > and would have probably been the right name to use originally - even
> > though it's not very consistent, as the same IP is called EMAC in the
> > older SoCs' manuals. I am also not against renaming identifiers or even
> > (internal) DT labels. But the problem here is that the renaming affects
> > the DT compatible string and the pinctrl function name, both of which
> > are used as an interface between the devicetree and its users, which is
> > not only the Linux kernel, but also U-Boot and other OSes like the BSDs.
>
> I reiterate my position: they are not stable until they actually hit a
> release. This provides some time to fix mistakes before they are set in
> stone.
>
> > In this particular case we would probably get away with it, because
> > it's indeed very early in the development cycle for this SoC, but for
> > instance the "emac0" function name is already used in some U-Boot
> > patch series on the list:
> > https://lore.kernel.org/linux-sunxi/20250323113544.7933-18-andre.przywara@arm.com/
> >
> > If we REALLY need to rename this, it wouldn't be the end of the world,
> > but would create some churn on the U-Boot side.
> >
> > I just wanted to point out that any changes to the DT bindings have
> > some impact to other projects, even if they are proposed as a coherent
> > series on the Linux side. Hence my question if this is really necessary.
>
> For the compatible string, I can live with having a comment in the binding
> stating the name used in the datasheet for reference.
For the compatible string going with a fallback name, I can live with
renaming it ;-)
> For the pinctrl stuff, which is the contentious bit here, I thought the
> whole idea of the newer pinctrl bindings is that the driver uses
> "allwinner,pinmux" instead of "function". I think having both being valid
> is confusing, and likely to cause conflicts later on. If we're going to
> use the hardware register values in the device tree, I'd really like them
> to be the only source of truth. The commit message for the binding also
> sort of suggests that "allwinner,pinmux" is the part that matters.
Yes, it should be, but it turns out to be convenient for U-Boot to
continue using the old method - until someone writes a driver for the new
schema. And a function name is still mandatory, it's just mostly for
reference now (so would indeed be fine to rename).
So if you really insist on this: please go ahead and merge it, so that
the 6.16 release contains the new name.
But please note my silent protest about those cosmetic name changes in the
DT realm, which establishes an interface reaching beyond just the Linux
kernel. When it comes to new boards, the U-Boot DT sync process is rather
slow, so I really am eager to cherry-pick -rc1 DTs already, instead of
waiting another 7 weeks - which bites me in this case. It's not merged
yet, so is fine in this case, but I would really like to avoid similar
hiccups in the future.
Cheers,
Andre.
next prev parent reply other threads:[~2025-07-07 17:15 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-28 5:44 [PATCH net 0/2] allwinner: a523: Rename emac0 to gmac0 Chen-Yu Tsai
2025-06-28 5:44 ` [PATCH net 1/2] dt-bindings: net: sun8i-emac: Rename A523 EMAC0 to GMAC0 Chen-Yu Tsai
2025-07-08 12:48 ` Rob Herring (Arm)
2025-06-28 5:44 ` [PATCH net 2/2] arm64: dts: allwinner: a523: Rename emac0 to gmac0 Chen-Yu Tsai
2025-07-05 7:36 ` [PATCH net 0/2] " Andre Przywara
2025-07-05 12:20 ` Chen-Yu Tsai
2025-07-05 15:53 ` Andrew Lunn
2025-07-05 23:22 ` Andre Przywara
2025-07-06 7:50 ` Andrew Lunn
2025-07-06 13:14 ` Chen-Yu Tsai
2025-07-07 17:15 ` Andre Przywara [this message]
2025-07-07 17:34 ` Chen-Yu Tsai
2025-07-08 9:20 ` Paolo Abeni
2025-07-08 15:10 ` patchwork-bot+netdevbpf
2025-07-08 16:25 ` (subset) " Chen-Yu Tsai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250707181513.6efc6558@donnerap.manchester.arm.com \
--to=andre.przywara@arm.com \
--cc=andrew+netdev@lunn.ch \
--cc=andrew@lunn.ch \
--cc=conor+dt@kernel.org \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=edumazet@google.com \
--cc=jernej@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=kuba@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-sunxi@lists.linux.dev \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=robh@kernel.org \
--cc=samuel@sholland.org \
--cc=wens@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox