Linux USB
 help / color / mirror / Atom feed
From: bugzilla-daemon@kernel.org
To: linux-usb@vger.kernel.org
Subject: [Bug 222071] New: [Bisected] [Regression] xhci_hcd: Resuming from hibernation fails with "Not enough host resources"
Date: Tue, 29 Sep 2026 08:10:48 +0000	[thread overview]
Message-ID: <bug-222071-208809@https.bugzilla.kernel.org/> (raw)

https://bugzilla.kernel.org/show_bug.cgi?id=222071

            Bug ID: 222071
           Summary: [Bisected] [Regression] xhci_hcd: Resuming from
                    hibernation fails with "Not enough host resources"
           Product: Drivers
           Version: 2.5
          Hardware: All
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: USB
          Assignee: drivers_usb@kernel-bugs.kernel.org
          Reporter: h.judt@gmx.at
        Regression: No

Created attachment 310955
  --> https://bugzilla.kernel.org/attachment.cgi?id=310955&action=edit
dmesg-7.2.6.bz2

Commit 2a70e5dc0301ad961b198f086a39e2479f6b8933 "usb: xhci: optimize resuming
from S4 (suspend-to-disk)" causes hibernate/resume cycles to fail.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=2a70e5dc0301ad961b198f086a39e2479f6b8933
Reverting it seems to make it good again.

dmesg excerpt:
usb 2-1.1.2: device descriptor read/64, error -32
xhci_hcd 0000:00:14.0: Not enough host resources, active endpoint contexts = 63
usb 2-1.1.2: Busted HC?  Not enough HCD resources for old configuration.
OOM killer enabled.
Restarting tasks: Starting
usb 2-1.1.2: USB disconnect, device number 5
Restarting tasks: Done
PM: hibernation: hibernation exit
usb 2-1.1.2: new full-speed USB device number 6 using xhci_hcd
usb 2-1.1.2: device descriptor read/64, error -32
xhci_hcd 0000:00:14.0: Not enough host resources, active endpoint contexts = 63
usb 2-1.1.2: can't set config #1, error -12

I will of course attach the full logs (one from today with kernel 7.2.6 and an
older one with kernel 7.1.1).

Maybe something does not get cleaned up properly, because it starts happen
after a few cycles?

I will later also attach a dmesg with the commit reverted.

lsusb -tv after failure:
/:  Bus 001.Port 001: Dev 001, Class=root_hub, Driver=ehci-pci/2p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 001: Dev 002, If 0, Class=Hub, Driver=hub/8p, 480M
        ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
/:  Bus 002.Port 001: Dev 001, Class=root_hub, Driver=xhci_hcd/4p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 001: Dev 007, 480M
        ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub
/:  Bus 003.Port 001: Dev 001, Class=root_hub, Driver=ehci-pci/2p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 001: Dev 002, If 0, Class=Hub, Driver=hub/6p, 480M
        ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
        |__ Port 002: Dev 003, If 0, Class=Human Interface Device,
Driver=usbhid, 12M
            ID 258a:002f  
        |__ Port 002: Dev 003, If 1, Class=Human Interface Device,
Driver=usbhid, 12M
            ID 258a:002f  
        |__ Port 004: Dev 004, If 0, Class=Mass Storage, Driver=usb-storage,
480M
            ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
/:  Bus 004.Port 001: Dev 001, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub
/:  Bus 005.Port 001: Dev 001, Class=root_hub, Driver=xhci_hcd/2p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
/:  Bus 006.Port 001: Dev 001, Class=root_hub, Driver=xhci_hcd/2p, 5000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub


Interestingly, the Realtek Semiconductor Corp. RTS5411 Hub still gets
recognized, but no devices.
/:  Bus 002.Port 001: Dev 001, Class=root_hub, Driver=xhci_hcd/4p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 001: Dev 009, 480M
        ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are watching the assignee of the bug.

             reply	other threads:[~2026-09-29  8:10 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-29  8:10 bugzilla-daemon [this message]
2026-09-29  8:19 ` [Bug 222071] [Bisected] [Regression] xhci_hcd: Resuming from hibernation fails with "Not enough host resources" bugzilla-daemon
2026-09-29 10:47 ` bugzilla-daemon
2026-09-29 17:17 ` bugzilla-daemon
2026-09-29 17:19 ` bugzilla-daemon
2026-09-29 18:44 ` bugzilla-daemon
2026-09-29 18:46 ` bugzilla-daemon
2026-09-29 20:26 ` bugzilla-daemon
2026-09-30  6:45 ` bugzilla-daemon
2026-09-30  7:49 ` bugzilla-daemon
2026-09-30  9:25 ` bugzilla-daemon
2026-10-01 13:25 ` bugzilla-daemon
2026-10-01 23:29 ` bugzilla-daemon
2026-10-06 10:19 ` bugzilla-daemon
2026-10-06 12:14 ` bugzilla-daemon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=bug-222071-208809@https.bugzilla.kernel.org/ \
    --to=bugzilla-daemon@kernel.org \
    --cc=linux-usb@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox