Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH 1/3] mac80211: rename ieee80211_cfg.h to cfg.h
@ 2007-09-18 21:42 Michael Wu
  2007-09-19 10:21 ` Johannes Berg
  0 siblings, 1 reply; 2+ messages in thread
From: Michael Wu @ 2007-09-18 21:42 UTC (permalink / raw)
  To: John Linville; +Cc: linux-wireless, Johannes Berg

From: Michael Wu <flamingice@sourmilk.net>

Might as well rename ieee80211_cfg.h to cfg.h to keep things consistent.

Signed-off-by: Michael Wu <flamingice@sourmilk.net>
---

 net/mac80211/cfg.c           |    2 +-
 net/mac80211/cfg.h           |    9 +++++++++
 net/mac80211/ieee80211.c     |    2 +-
 net/mac80211/ieee80211_cfg.h |    9 ---------
 4 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/net/mac80211/cfg.c b/net/mac80211/cfg.c
index b1c13bc..3018815 100644
--- a/net/mac80211/cfg.c
+++ b/net/mac80211/cfg.c
@@ -11,7 +11,7 @@
 #include <net/net_namespace.h>
 #include <net/cfg80211.h>
 #include "ieee80211_i.h"
-#include "ieee80211_cfg.h"
+#include "cfg.h"
 
 static int ieee80211_add_iface(struct wiphy *wiphy, char *name,
 			       unsigned int type)
diff --git a/net/mac80211/cfg.h b/net/mac80211/cfg.h
new file mode 100644
index 0000000..7d7879f
--- /dev/null
+++ b/net/mac80211/cfg.h
@@ -0,0 +1,9 @@
+/*
+ * mac80211 configuration hooks for cfg80211
+ */
+#ifndef __CFG_H
+#define __CFG_H
+
+extern struct cfg80211_ops mac80211_config_ops;
+
+#endif /* __CFG_H */
diff --git a/net/mac80211/ieee80211.c b/net/mac80211/ieee80211.c
index 784f03f..d287470 100644
--- a/net/mac80211/ieee80211.c
+++ b/net/mac80211/ieee80211.c
@@ -31,7 +31,7 @@
 #include "wme.h"
 #include "aes_ccm.h"
 #include "ieee80211_led.h"
-#include "ieee80211_cfg.h"
+#include "cfg.h"
 #include "debugfs.h"
 #include "debugfs_netdev.h"
 
diff --git a/net/mac80211/ieee80211_cfg.h b/net/mac80211/ieee80211_cfg.h
deleted file mode 100644
index 85ed2c9..0000000
--- a/net/mac80211/ieee80211_cfg.h
+++ /dev/null
@@ -1,9 +0,0 @@
-/*
- * mac80211 configuration hooks for cfg80211
- */
-#ifndef __IEEE80211_CFG_H
-#define __IEEE80211_CFG_H
-
-extern struct cfg80211_ops mac80211_config_ops;
-
-#endif /* __IEEE80211_CFG_H */


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 1/3] mac80211: rename ieee80211_cfg.h to cfg.h
  2007-09-18 21:42 [PATCH 1/3] mac80211: rename ieee80211_cfg.h to cfg.h Michael Wu
@ 2007-09-19 10:21 ` Johannes Berg
  0 siblings, 0 replies; 2+ messages in thread
From: Johannes Berg @ 2007-09-19 10:21 UTC (permalink / raw)
  To: Michael Wu; +Cc: John Linville, linux-wireless

[-- Attachment #1: Type: text/plain, Size: 273 bytes --]

On Tue, 2007-09-18 at 17:42 -0400, Michael Wu wrote:
> From: Michael Wu <flamingice@sourmilk.net>
> 
> Might as well rename ieee80211_cfg.h to cfg.h to keep things consistent.

Maybe we should just get rid of it and put the one thing into
ieee80211_i.h?

johannes

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 190 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2007-09-19 10:20 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2007-09-18 21:42 [PATCH 1/3] mac80211: rename ieee80211_cfg.h to cfg.h Michael Wu
2007-09-19 10:21 ` Johannes Berg

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox