Linux wireless drivers development
 help / color / mirror / Atom feed
From: Johannes Berg <johannes@sipsolutions.net>
To: Tomas Winkler <tomasw@gmail.com>
Cc: linville@tuxdriver.com, yi.zhu@intel.com,
	linux-wireless@vger.kernel.org, Guy Cohen <guy.cohen@intel.com>
Subject: Re: [PATCH 1/1] mac80211: move netif_carrier_on to after ieee80211_bss_info_change_notify
Date: Thu, 03 Jul 2008 19:57:32 +0200	[thread overview]
Message-ID: <1215107852.9975.23.camel@johannes.berg> (raw)
In-Reply-To: <1ba2fa240807031045q74065c7bna6e66b5aa219d41c@mail.gmail.com> (sfid-20080703_194548_657379_3D82C675)

[-- Attachment #1: Type: text/plain, Size: 1922 bytes --]

On Thu, 2008-07-03 at 20:45 +0300, Tomas Winkler wrote:
> On Thu, Jul 3, 2008 at 8:33 PM, Johannes Berg <johannes@sipsolutions.net> wrote:
> > On Thu, 2008-07-03 at 20:26 +0300, Tomas Winkler wrote:
> >> On Thu, Jul 3, 2008 at 8:07 PM, Johannes Berg <johannes@sipsolutions.net> wrote:
> >> >
> >> >> -             netif_carrier_on(dev);
> >> >>               ifsta->flags |= IEEE80211_STA_PREV_BSSID_SET;
> >> >>               memcpy(ifsta->prev_bssid, sdata->u.sta.bssid, ETH_ALEN);
> >> >>               memcpy(wrqu.ap_addr.sa_data, sdata->u.sta.bssid, ETH_ALEN);
> >> >>               ieee80211_sta_send_associnfo(dev, ifsta);
> >> >>       } else {
> >> >> +             netif_carrier_off(dev);
> >> >>               ieee80211_sta_tear_down_BA_sessions(dev, ifsta->bssid);
> >> >>               ifsta->flags &= ~IEEE80211_STA_ASSOCIATED;
> >> >> -             netif_carrier_off(dev);
> >> >
> >> > Maybe it should then be symmetric so that callers of the function have
> >> > to do it in both cases? Other than that, looks good.
> >>
> >> The sequence now is
> >>   configure association in the driver  -> carrier_on ..... carrier_off
> >> -> configure disassociation in the driver
> >>
> >> So this is already symmetric or I don't understand what  you mean.
> >
> > Yes, the call sequence is symmetric, but I was thinking whether it would
> > be better API-wise to have the caller of ieee80211_set_associated() do
> > both carrier_on and carrier_off, instead of requiring that it calls
> > carrier_on but calling carrier_off for it.
> 
> I think it's actually okay to be  inside and I would rather prefer to
> split this function; there is already one function called
> ieee80211_set_disassociated. But since we have to fix dissacosiation
> anway and we need to investigate it more I would first use this little
> fix.

Sure ok, thanks for looking into this stuff.

johannes

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

      reply	other threads:[~2008-07-03 17:58 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-07-03 16:56 [PATCH 1/1] mac80211: move netif_carrier_on to after ieee80211_bss_info_change_notify Tomas Winkler
2008-07-03 17:07 ` Johannes Berg
2008-07-03 17:26   ` Tomas Winkler
2008-07-03 17:33     ` Johannes Berg
2008-07-03 17:45       ` Tomas Winkler
2008-07-03 17:57         ` Johannes Berg [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1215107852.9975.23.camel@johannes.berg \
    --to=johannes@sipsolutions.net \
    --cc=guy.cohen@intel.com \
    --cc=linux-wireless@vger.kernel.org \
    --cc=linville@tuxdriver.com \
    --cc=tomasw@gmail.com \
    --cc=yi.zhu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox