Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH] wl12xx/sdio_test.c: fix build breakage from WL127X_FW_NAME change
@ 2011-08-29 19:53 John W. Linville
  2011-08-30  5:41 ` Luciano Coelho
  0 siblings, 1 reply; 2+ messages in thread
From: John W. Linville @ 2011-08-29 19:53 UTC (permalink / raw)
  To: linux-wireless; +Cc: Luciano Coelho, John W. Linville

Commit c302b2c959164622558474871ae942da0e484a38 ("wl12xx: Use a single
fw for both STA and AP roles") changed the name of the firmware name
definition, breaking the build of wl12xx/sdio_test.c.

Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
 drivers/net/wireless/wl12xx/sdio_test.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/net/wireless/wl12xx/sdio_test.c b/drivers/net/wireless/wl12xx/sdio_test.c
index f289153..c361049 100644
--- a/drivers/net/wireless/wl12xx/sdio_test.c
+++ b/drivers/net/wireless/wl12xx/sdio_test.c
@@ -193,7 +193,7 @@ static int wl1271_fetch_firmware(struct wl1271 *wl)
 		ret = request_firmware(&fw, WL128X_FW_NAME,
 				       wl1271_wl_to_dev(wl));
 	else
-		ret = request_firmware(&fw, WL1271_FW_NAME,
+		ret = request_firmware(&fw, WL127X_FW_NAME,
 				       wl1271_wl_to_dev(wl));
 
 	if (ret < 0) {
-- 
1.7.4.4


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] wl12xx/sdio_test.c: fix build breakage from WL127X_FW_NAME change
  2011-08-29 19:53 [PATCH] wl12xx/sdio_test.c: fix build breakage from WL127X_FW_NAME change John W. Linville
@ 2011-08-30  5:41 ` Luciano Coelho
  0 siblings, 0 replies; 2+ messages in thread
From: Luciano Coelho @ 2011-08-30  5:41 UTC (permalink / raw)
  To: John W. Linville; +Cc: linux-wireless

On Mon, 2011-08-29 at 15:53 -0400, John W. Linville wrote: 
> Commit c302b2c959164622558474871ae942da0e484a38 ("wl12xx: Use a single
> fw for both STA and AP roles") changed the name of the firmware name
> definition, breaking the build of wl12xx/sdio_test.c.
> 
> Signed-off-by: John W. Linville <linville@tuxdriver.com>
> ---

Thanks, John.  For some weird reason, WL12XX_SDIO_TEST sneaked away from
my kernel configuration and this slipped through.

-- 
Cheers,
Luca.


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-08-30  5:41 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2011-08-29 19:53 [PATCH] wl12xx/sdio_test.c: fix build breakage from WL127X_FW_NAME change John W. Linville
2011-08-30  5:41 ` Luciano Coelho

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox