Linux wireless drivers development
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Joe Perches <joe@perches.com>
Cc: Andrei Emeltchenko <Andrei.Emeltchenko.news@gmail.com>,
	linux-wireless@vger.kernel.org, bzhao@marvell.com
Subject: Re: [PATCH] mwifiex: Using %*phD instead of print_hex_dump_bytes
Date: Fri, 05 Oct 2012 09:53:16 +0300	[thread overview]
Message-ID: <1349419996.10584.5.camel@smile> (raw)
In-Reply-To: <1349368379.2008.16.camel@joe-AO722>

On Thu, 2012-10-04 at 09:32 -0700, Joe Perches wrote: 
> On Thu, 2012-10-04 at 12:16 +0300, Andrei Emeltchenko wrote:
> > From: Andrei Emeltchenko <andrei.emeltchenko@intel.com>
> > 
> > Make output more readable and remove unneeded function call.
> > 
> > ...
> > mwifiex_sdio mmc0:0001:1: last_cmd_index = 3
> > last_cmd_id: 00000000: 28 00 28 00 28                            (.(.(
> > ...
> > 
> > would be changed to:
> > 
> > ...
> > mwifiex_sdio mmc0:0001:1: last_cmd_index = 3
> > mwifiex_sdio mmc0:0001:1: last_cmd_id: 28 00 28 00 28
> > ...
> 
> (added Andy Shevchenko)
> 
> Hi Andrei.  That's probably a better output style too
> as the ascii isn't likely useful.
> 
> One non-nit as a style issue for Andy Shevchenko:
> 
> > diff --git a/drivers/net/wireless/mwifiex/cmdevt.c b/drivers/net/wireless/mwifiex/cmdevt.c
> []
> > @@ -917,21 +917,20 @@ mwifiex_cmd_timeout_func(unsigned long function_context)
> []
> > +		dev_err(adapter->dev, "last_cmd_id: %*ph\n", DBG_CMD_NUM,
> > +			adapter->dbg.last_cmd_id);
> > +		dev_err(adapter->dev, "last_cmd_act: %*ph\n", DBG_CMD_NUM,
> > +			adapter->dbg.last_cmd_act);
> 
> When the number of bytes is fixed, it might be nicer
> to use a format like "%<num>ph" so that the function
> argument stack doesn't have the width pushed but it's
> fixed in the format.
> 
> This case would definitely not work well though as it's
> a #define rather than a simple number and I think
> using "%" stringize(some_define) "ph" is not nice.
> 
> Maybe this case argues more for always using "%*ph".
> At least that's easily greppable.
> 
> Andy?
First of all, the current linux-next has at least two definitions of
that constant:
drivers/net/wireless/mwifiex/ioctl.h:175:#define DBG_CMD_NUM    5
drivers/net/wireless/mwifiex/main.h:118:#define DBG_CMD_NUM 5

I checked briefly the code and found that the constant is heavily used
as a definition for the length of static byte arrays. So, in that case
probably better to use %*ph, but apply sizeof(cool_var) instead of
putting constant there.


-- 
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy

  reply	other threads:[~2012-10-05  6:53 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-10-04  9:16 [PATCH] mwifiex: Using %*phD instead of print_hex_dump_bytes Andrei Emeltchenko
2012-10-04 16:32 ` Joe Perches
2012-10-05  6:53   ` Andy Shevchenko [this message]
2012-10-05  7:00     ` Andy Shevchenko
2012-10-05 10:07       ` Andrei Emeltchenko
2012-10-05 10:19         ` Andy Shevchenko
2012-10-05 12:58           ` Andrei Emeltchenko
2012-10-05 19:43       ` Bing Zhao
2012-10-05 10:11     ` Andrei Emeltchenko
2012-10-05 10:18       ` Andy Shevchenko
2012-10-05 10:27         ` Andrei Emeltchenko
2012-10-05 19:35     ` Bing Zhao

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1349419996.10584.5.camel@smile \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=Andrei.Emeltchenko.news@gmail.com \
    --cc=bzhao@marvell.com \
    --cc=joe@perches.com \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox