* [PATCH 0/1] *** mac80211: delete duplicate code *** @ 2013-08-17 12:16 Sergey K 2013-08-17 12:16 ` [PATCH 1/1] Delete duplicate code. Use of the variable instead call a function Sergey K 0 siblings, 1 reply; 3+ messages in thread From: Sergey K @ 2013-08-17 12:16 UTC (permalink / raw) To: linux-wireless; +Cc: Sergey K *** BLURB HERE *** Sergey K (1): Delete duplicate code. Use of the variable instead call a function net/mac80211/tx.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) -- 1.8.1.5 ^ permalink raw reply [flat|nested] 3+ messages in thread
* [PATCH 1/1] Delete duplicate code. Use of the variable instead call a function 2013-08-17 12:16 [PATCH 0/1] *** mac80211: delete duplicate code *** Sergey K @ 2013-08-17 12:16 ` Sergey K 2013-08-17 15:53 ` Sergey K 0 siblings, 1 reply; 3+ messages in thread From: Sergey K @ 2013-08-17 12:16 UTC (permalink / raw) To: linux-wireless; +Cc: Sergey K --- net/mac80211/tx.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c index 098ae85..79db7f3 100644 --- a/net/mac80211/tx.c +++ b/net/mac80211/tx.c @@ -1769,8 +1769,6 @@ netdev_tx_t ieee80211_subif_start_xmit(struct sk_buff *skb, memcpy(hdr.addr3, skb->data, ETH_ALEN); memcpy(hdr.addr4, skb->data + ETH_ALEN, ETH_ALEN); hdrlen = 30; - authorized = test_sta_flag(sta, WLAN_STA_AUTHORIZED); - wme_sta = test_sta_flag(sta, WLAN_STA_WME); } ap_sdata = container_of(sdata->bss, struct ieee80211_sub_if_data, u.ap); @@ -1979,7 +1977,7 @@ netdev_tx_t ieee80211_subif_start_xmit(struct sk_buff *skb, * EAPOL frames from the local station. */ if (unlikely(!ieee80211_vif_is_mesh(&sdata->vif) && - !is_multicast_ether_addr(hdr.addr1) && !authorized && + !multicast && !authorized && (cpu_to_be16(ethertype) != sdata->control_port_protocol || !ether_addr_equal(sdata->vif.addr, skb->data + ETH_ALEN)))) { #ifdef CONFIG_MAC80211_VERBOSE_DEBUG -- 1.8.1.5 ^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [PATCH 1/1] Delete duplicate code. Use of the variable instead call a function 2013-08-17 12:16 ` [PATCH 1/1] Delete duplicate code. Use of the variable instead call a function Sergey K @ 2013-08-17 15:53 ` Sergey K 0 siblings, 0 replies; 3+ messages in thread From: Sergey K @ 2013-08-17 15:53 UTC (permalink / raw) To: linux-wireless Sergey K <perplexus@...> writes: > > --- > net/mac80211/tx.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c > index 098ae85..79db7f3 100644 > --- a/net/mac80211/tx.c > +++ b/net/mac80211/tx.c > <at> <at> -1769,8 +1769,6 <at> <at> netdev_tx_t ieee80211_subif_start_xmit(struct sk_buff *skb, > memcpy(hdr.addr3, skb->data, ETH_ALEN); > memcpy(hdr.addr4, skb->data + ETH_ALEN, ETH_ALEN); > hdrlen = 30; > - authorized = test_sta_flag(sta, WLAN_STA_AUTHORIZED); > - wme_sta = test_sta_flag(sta, WLAN_STA_WME); > } > ap_sdata = container_of(sdata->bss, struct ieee80211_sub_if_data, > u.ap); > <at> <at> -1979,7 +1977,7 <at> <at> netdev_tx_t ieee80211_subif_start_xmit(struct sk_buff *skb, > * EAPOL frames from the local station. > */ > if (unlikely(!ieee80211_vif_is_mesh(&sdata->vif) && > - !is_multicast_ether_addr(hdr.addr1) && !authorized && > + !multicast && !authorized && > (cpu_to_be16(ethertype) != sdata- >control_port_protocol || > !ether_addr_equal(sdata->vif.addr, skb->data + ETH_ALEN)))) { > #ifdef CONFIG_MAC80211_VERBOSE_DEBUG We need to delete authorized and wme_sta flags, because these flags are set below: 1956 multicast = is_multicast_ether_addr(hdr.addr1); 1957 if (!multicast) { 1958 sta = sta_info_get(sdata, hdr.addr1); 1959 if (sta) { 1960 authorized = test_sta_flag(sta, WLAN_STA_AUTHORIZED); 1961 wme_sta = test_sta_flag(sta, WLAN_STA_WME); 1962 } 1963 } ^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2013-08-17 15:55 UTC | newest] Thread overview: 3+ messages (download: mbox.gz follow: Atom feed -- links below jump to the message on this page -- 2013-08-17 12:16 [PATCH 0/1] *** mac80211: delete duplicate code *** Sergey K 2013-08-17 12:16 ` [PATCH 1/1] Delete duplicate code. Use of the variable instead call a function Sergey K 2013-08-17 15:53 ` Sergey K
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox