Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH 0/4 v1] Refactoring ieee80211_iface_work
@ 2016-07-13 20:19 Alex Briskin
  2016-07-13 20:19 ` [PATCH 1/4 v1] Refactoring ieee80211_iface_work to reduce complexity and improve readability Alex Briskin
                   ` (4 more replies)
  0 siblings, 5 replies; 8+ messages in thread
From: Alex Briskin @ 2016-07-13 20:19 UTC (permalink / raw)
  To: linux-wireless, johannes; +Cc: Alex Briskin

Hi All,
This is my first patch(s).

I've decided to refactor ieee80211_iface_work function and break it down
to smaller better defined function.

I think these changes make the code much more readable and do not impose
no overhead.

I've tested these patches with sparse and checkpatch.pl 

Function names might not be descriptive enough.
Hope you find this useful.

Alex Briskin (4):
  0) [28e464b19aaaba90c8946fb979b58709d55dffcf] 
	Added new function ieee80211_is_skb_handled_by_pkt_type and moved
	some code from ieee80211_iface_work to reduce complexity and 
	improve readability

  1) [486e3d5abb4dc6361cdd923254a2b68d43dcdaba]
	Refactored code in ieee80211_is_skb_handled_by_pkt_type.
	"if () {} else if ()" replaced by switch case. 

  2) [9ef2eab8e831420bc6748a4466ffa6b7a99bf447]
	Added new function ieee80211_is_handled_by_frame_control and moved
	some code from ieee80211_iface_work to it.

  3) [1de8cdf9a0c05c6a21d9e43e5b55862f6efcf450] 
	Added new function ieee80211_handle_by_vif_type with code from
	ieee80211_iface_work.

	At this point ieee80211_iface_work seems to me much more readable
	and better understood. 

 net/mac80211/iface.c | 264 +++++++++++++++++++++++++++++----------------------
 1 file changed, 150 insertions(+), 114 deletions(-)

-- 
2.5.0


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2016-07-14 13:04 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2016-07-13 20:19 [PATCH 0/4 v1] Refactoring ieee80211_iface_work Alex Briskin
2016-07-13 20:19 ` [PATCH 1/4 v1] Refactoring ieee80211_iface_work to reduce complexity and improve readability Alex Briskin
2016-07-13 20:19 ` [PATCH 2/4 v1] even better readability Alex Briskin
2016-07-13 20:19 ` [PATCH 3/4 v1] Continue breaking down to smaller functions Alex Briskin
2016-07-13 20:41   ` kbuild test robot
2016-07-13 20:19 ` [PATCH 4/4 v1] Simple and well understood logic Alex Briskin
2016-07-14  7:56 ` [PATCH 0/4 v1] Refactoring ieee80211_iface_work Arend Van Spriel
2016-07-14 13:04   ` Alex Briskin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox