Linux wireless drivers development
 help / color / mirror / Atom feed
From: Michael Buesch <mb@bu3sch.de>
To: Harvey Harrison <harvey.harrison@gmail.com>
Cc: Johannes Berg <johannes@sipsolutions.net>,
	linux-wireless <linux-wireless@vger.kernel.org>
Subject: Re: [RFC 3/2] get rid of rx handler function pointers
Date: Thu, 19 Jun 2008 19:44:52 +0200	[thread overview]
Message-ID: <200806191944.52164.mb@bu3sch.de> (raw)
In-Reply-To: <1213896016.2125.51.camel@brick>

On Thursday 19 June 2008 19:20:16 Harvey Harrison wrote:
> > =EF=BB=BF#define CALL_RXH(rxh) if ((res =3D rxh(rx)) !=3D RX_CONTIN=
UE) goto rxh_done;
>=20
> Would it really be so bad to just open-code them rather than the macr=
o approach?

I think the macro makes it readable. And as it is defined locally it
does not obfuscate it.

> 	res =3D =EF=BB=BFieee80211_rx_h_passive_scan(rx);
> 	if (res !=3D RX_CONTINUE) goto rxh_done;

This would most likely need to look like this, if opencoded:

	res =3D =EF=BB=BFieee80211_rx_h_passive_scan(rx);
	if (res !=3D RX_CONTINUE)
		goto rxh_done;

>=20
> 	res =3D =EF=BB=BFieee80211_rx_h_check(rx);
> 	if (res !=3D RX_CONTINUE) goto rxh_done;
>=20
> 	...
>
--=20
Greetings Michael.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireles=
s" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

  parent reply	other threads:[~2008-06-19 17:45 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-06-19 12:38 [RFC 3/2] get rid of rx handler function pointers Johannes Berg
2008-06-19 17:20 ` Harvey Harrison
2008-06-19 17:24   ` Johannes Berg
2008-06-19 17:44   ` Michael Buesch [this message]
2008-06-19 17:46     ` Johannes Berg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200806191944.52164.mb@bu3sch.de \
    --to=mb@bu3sch.de \
    --cc=harvey.harrison@gmail.com \
    --cc=johannes@sipsolutions.net \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox