Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH] NFC: Fix next target_idx type and rename for clarity
@ 2012-03-23 10:46 Eric Lapuyade
  2012-03-23 11:07 ` Samuel Ortiz
  0 siblings, 1 reply; 2+ messages in thread
From: Eric Lapuyade @ 2012-03-23 10:46 UTC (permalink / raw)
  To: linux-wireless; +Cc: Lauro Ramos Venancio, Aloisio Almeida Jr, Samuel Ortiz

There are many idx in this code, so make it clearer that this one is the base for the next target that will be discoved.

Signed-off-by: Eric Lapuyade <eric.lapuyade@intel.com>
Signed-off-by: Samuel Ortiz <sameo@linux.intel.com>
---
 include/net/nfc/nfc.h |    2 +-
 net/nfc/core.c        |    2 +-
 net/nfc/rawsock.c     |    4 ++--
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/net/nfc/nfc.h b/include/net/nfc/nfc.h
index 45f0563..f4f6950 100644
--- a/include/net/nfc/nfc.h
+++ b/include/net/nfc/nfc.h
@@ -89,7 +89,7 @@ struct nfc_genl_data {
 
 struct nfc_dev {
 	unsigned idx;
-	unsigned target_idx;
+	u32 target_next_idx;
 	struct nfc_target *targets;
 	int n_targets;
 	int targets_generation;
diff --git a/net/nfc/core.c b/net/nfc/core.c
index 2818582..d3a2cfb 100644
--- a/net/nfc/core.c
+++ b/net/nfc/core.c
@@ -435,7 +435,7 @@ int nfc_targets_found(struct nfc_dev *dev,
 	dev->polling = false;
 
 	for (i = 0; i < n_targets; i++)
-		targets[i].idx = dev->target_idx++;
+		targets[i].idx = dev->target_next_idx++;
 
 	spin_lock_bh(&dev->targets_lock);
 
diff --git a/net/nfc/rawsock.c b/net/nfc/rawsock.c
index b2825aa..ec1134c 100644
--- a/net/nfc/rawsock.c
+++ b/net/nfc/rawsock.c
@@ -92,8 +92,8 @@ static int rawsock_connect(struct socket *sock, struct sockaddr *_addr,
 		goto error;
 	}
 
-	if (addr->target_idx > dev->target_idx - 1 ||
-	    addr->target_idx < dev->target_idx - dev->n_targets) {
+	if (addr->target_idx > dev->target_next_idx - 1 ||
+	    addr->target_idx < dev->target_next_idx - dev->n_targets) {
 		rc = -EINVAL;
 		goto error;
 	}
-- 
1.7.6.5


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] NFC: Fix next target_idx type and rename for clarity
  2012-03-23 10:46 [PATCH] NFC: Fix next target_idx type and rename for clarity Eric Lapuyade
@ 2012-03-23 11:07 ` Samuel Ortiz
  0 siblings, 0 replies; 2+ messages in thread
From: Samuel Ortiz @ 2012-03-23 11:07 UTC (permalink / raw)
  To: Eric Lapuyade, John W. Linville
  Cc: linux-wireless, Lauro Ramos Venancio, Aloisio Almeida Jr

Hi Eric,

On Fri, Mar 23, 2012 at 11:46:23AM +0100, Eric Lapuyade wrote:
> There are many idx in this code, so make it clearer that this one is the base for the next target that will be discoved.
> 

John, I'm queuing this one to my nfc-next branch. It will be part of my next
pull request (After wireless-next is open for business again), unless someone
has some comments about it.

Cheers,
Samuel.

> Signed-off-by: Eric Lapuyade <eric.lapuyade@intel.com>
> Signed-off-by: Samuel Ortiz <sameo@linux.intel.com>
> ---
>  include/net/nfc/nfc.h |    2 +-
>  net/nfc/core.c        |    2 +-
>  net/nfc/rawsock.c     |    4 ++--
>  3 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/include/net/nfc/nfc.h b/include/net/nfc/nfc.h
> index 45f0563..f4f6950 100644
> --- a/include/net/nfc/nfc.h
> +++ b/include/net/nfc/nfc.h
> @@ -89,7 +89,7 @@ struct nfc_genl_data {
>  
>  struct nfc_dev {
>  	unsigned idx;
> -	unsigned target_idx;
> +	u32 target_next_idx;
>  	struct nfc_target *targets;
>  	int n_targets;
>  	int targets_generation;
> diff --git a/net/nfc/core.c b/net/nfc/core.c
> index 2818582..d3a2cfb 100644
> --- a/net/nfc/core.c
> +++ b/net/nfc/core.c
> @@ -435,7 +435,7 @@ int nfc_targets_found(struct nfc_dev *dev,
>  	dev->polling = false;
>  
>  	for (i = 0; i < n_targets; i++)
> -		targets[i].idx = dev->target_idx++;
> +		targets[i].idx = dev->target_next_idx++;
>  
>  	spin_lock_bh(&dev->targets_lock);
>  
> diff --git a/net/nfc/rawsock.c b/net/nfc/rawsock.c
> index b2825aa..ec1134c 100644
> --- a/net/nfc/rawsock.c
> +++ b/net/nfc/rawsock.c
> @@ -92,8 +92,8 @@ static int rawsock_connect(struct socket *sock, struct sockaddr *_addr,
>  		goto error;
>  	}
>  
> -	if (addr->target_idx > dev->target_idx - 1 ||
> -	    addr->target_idx < dev->target_idx - dev->n_targets) {
> +	if (addr->target_idx > dev->target_next_idx - 1 ||
> +	    addr->target_idx < dev->target_next_idx - dev->n_targets) {
>  		rc = -EINVAL;
>  		goto error;
>  	}
> -- 
> 1.7.6.5
> 

-- 
Intel Open Source Technology Centre
http://oss.intel.com/

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2012-03-23 10:59 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2012-03-23 10:46 [PATCH] NFC: Fix next target_idx type and rename for clarity Eric Lapuyade
2012-03-23 11:07 ` Samuel Ortiz

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox