* [PATCH 41/82] wil6210: Refactor intentional wrap-around test [not found] <20240122235208.work.748-kees@kernel.org> @ 2024-01-23 0:27 ` Kees Cook 2024-01-23 6:36 ` Kalle Valo 2024-01-23 11:50 ` Kalle Valo 2024-01-23 0:27 ` [PATCH 62/82] mwifiex: pcie: " Kees Cook 1 sibling, 2 replies; 6+ messages in thread From: Kees Cook @ 2024-01-23 0:27 UTC (permalink / raw) To: linux-hardening Cc: Kees Cook, Kalle Valo, Johannes Berg, Max Chen, Yang Shen, linux-wireless, Gustavo A. R. Silva, Bill Wendling, Justin Stitt, linux-kernel In an effort to separate intentional arithmetic wrap-around from unexpected wrap-around, we need to refactor places that depend on this kind of math. One of the most common code patterns of this is: VAR + value < VAR Notably, this is considered "undefined behavior" for signed and pointer types, which the kernel works around by using the -fno-strict-overflow option in the build[1] (which used to just be -fwrapv). Regardless, we want to get the kernel source to the position where we can meaningfully instrument arithmetic wrap-around conditions and catch them when they are unexpected, regardless of whether they are signed[2], unsigned[3], or pointer[4] types. Refactor open-coded wrap-around addition test to use add_would_overflow(). This paves the way to enabling the wrap-around sanitizers in the future. Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] Link: https://github.com/KSPP/linux/issues/26 [2] Link: https://github.com/KSPP/linux/issues/27 [3] Link: https://github.com/KSPP/linux/issues/344 [4] Cc: Kalle Valo <kvalo@kernel.org> Cc: Johannes Berg <johannes.berg@intel.com> Cc: Max Chen <mxchen@codeaurora.org> Cc: Yang Shen <shenyang39@huawei.com> Cc: linux-wireless@vger.kernel.org Signed-off-by: Kees Cook <keescook@chromium.org> --- drivers/net/wireless/ath/wil6210/wmi.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ath/wil6210/wmi.c b/drivers/net/wireless/ath/wil6210/wmi.c index 6fdb77d4c59e..3b3c991f77e9 100644 --- a/drivers/net/wireless/ath/wil6210/wmi.c +++ b/drivers/net/wireless/ath/wil6210/wmi.c @@ -286,7 +286,7 @@ void __iomem *wmi_buffer_block(struct wil6210_priv *wil, __le32 ptr_, u32 size) off = HOSTADDR(ptr); if (off > wil->bar_size - 4) return NULL; - if (size && ((off + size > wil->bar_size) || (off + size < off))) + if (size && ((off + size > wil->bar_size) || (add_would_overflow(off, size)))) return NULL; return wil->csr + off; -- 2.34.1 ^ permalink raw reply related [flat|nested] 6+ messages in thread
* Re: [PATCH 41/82] wil6210: Refactor intentional wrap-around test 2024-01-23 0:27 ` [PATCH 41/82] wil6210: Refactor intentional wrap-around test Kees Cook @ 2024-01-23 6:36 ` Kalle Valo 2024-01-23 11:50 ` Kalle Valo 1 sibling, 0 replies; 6+ messages in thread From: Kalle Valo @ 2024-01-23 6:36 UTC (permalink / raw) To: Kees Cook Cc: linux-hardening, Johannes Berg, Max Chen, Yang Shen, linux-wireless, Gustavo A. R. Silva, Bill Wendling, Justin Stitt, linux-kernel Kees Cook <keescook@chromium.org> writes: > In an effort to separate intentional arithmetic wrap-around from > unexpected wrap-around, we need to refactor places that depend on this > kind of math. One of the most common code patterns of this is: > > VAR + value < VAR > > Notably, this is considered "undefined behavior" for signed and pointer > types, which the kernel works around by using the -fno-strict-overflow > option in the build[1] (which used to just be -fwrapv). Regardless, we > want to get the kernel source to the position where we can meaningfully > instrument arithmetic wrap-around conditions and catch them when they > are unexpected, regardless of whether they are signed[2], unsigned[3], > or pointer[4] types. > > Refactor open-coded wrap-around addition test to use add_would_overflow(). > This paves the way to enabling the wrap-around sanitizers in the future. > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > Link: https://github.com/KSPP/linux/issues/26 [2] > Link: https://github.com/KSPP/linux/issues/27 [3] > Link: https://github.com/KSPP/linux/issues/344 [4] > Cc: Kalle Valo <kvalo@kernel.org> > Cc: Johannes Berg <johannes.berg@intel.com> > Cc: Max Chen <mxchen@codeaurora.org> > Cc: Yang Shen <shenyang39@huawei.com> > Cc: linux-wireless@vger.kernel.org > Signed-off-by: Kees Cook <keescook@chromium.org> I assume this goes via some other tree than wireless-next so: Acked-by: Kalle Valo <kvalo@kernel.org> -- https://patchwork.kernel.org/project/linux-wireless/list/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches ^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 41/82] wil6210: Refactor intentional wrap-around test 2024-01-23 0:27 ` [PATCH 41/82] wil6210: Refactor intentional wrap-around test Kees Cook 2024-01-23 6:36 ` Kalle Valo @ 2024-01-23 11:50 ` Kalle Valo 2024-01-23 22:52 ` Kees Cook 1 sibling, 1 reply; 6+ messages in thread From: Kalle Valo @ 2024-01-23 11:50 UTC (permalink / raw) To: Kees Cook Cc: linux-hardening, Kees Cook, Johannes Berg, Max Chen, Yang Shen, linux-wireless, Gustavo A. R. Silva, Bill Wendling, Justin Stitt, linux-kernel Kees Cook <keescook@chromium.org> wrote: > In an effort to separate intentional arithmetic wrap-around from > unexpected wrap-around, we need to refactor places that depend on this > kind of math. One of the most common code patterns of this is: > > VAR + value < VAR > > Notably, this is considered "undefined behavior" for signed and pointer > types, which the kernel works around by using the -fno-strict-overflow > option in the build[1] (which used to just be -fwrapv). Regardless, we > want to get the kernel source to the position where we can meaningfully > instrument arithmetic wrap-around conditions and catch them when they > are unexpected, regardless of whether they are signed[2], unsigned[3], > or pointer[4] types. > > Refactor open-coded wrap-around addition test to use add_would_overflow(). > This paves the way to enabling the wrap-around sanitizers in the future. > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > Link: https://github.com/KSPP/linux/issues/26 [2] > Link: https://github.com/KSPP/linux/issues/27 [3] > Link: https://github.com/KSPP/linux/issues/344 [4] > Cc: Kalle Valo <kvalo@kernel.org> > Cc: Johannes Berg <johannes.berg@intel.com> > Cc: Max Chen <mxchen@codeaurora.org> > Cc: Yang Shen <shenyang39@huawei.com> > Cc: linux-wireless@vger.kernel.org > Signed-off-by: Kees Cook <keescook@chromium.org> > Acked-by: Kalle Valo <kvalo@kernel.org> If you can edit before commit please add "wifi:" prefix to the wireless patches: ERROR: 'wifi:' prefix missing: '[PATCH 41/82] wil6210: Refactor intentional wrap-around test' ERROR: 'wifi:' prefix missing: '[PATCH 62/82] mwifiex: pcie: Refactor intentional wrap-around test' 2 patches set to Not Applicable. 13526631 [41/82] wil6210: Refactor intentional wrap-around test 13526632 [62/82] mwifiex: pcie: Refactor intentional wrap-around test -- https://patchwork.kernel.org/project/linux-wireless/patch/20240123002814.1396804-41-keescook@chromium.org/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches ^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 41/82] wil6210: Refactor intentional wrap-around test 2024-01-23 11:50 ` Kalle Valo @ 2024-01-23 22:52 ` Kees Cook 0 siblings, 0 replies; 6+ messages in thread From: Kees Cook @ 2024-01-23 22:52 UTC (permalink / raw) To: Kalle Valo Cc: linux-hardening, Johannes Berg, Max Chen, Yang Shen, linux-wireless, Gustavo A. R. Silva, Bill Wendling, Justin Stitt, linux-kernel On Tue, Jan 23, 2024 at 11:50:34AM +0000, Kalle Valo wrote: > Kees Cook <keescook@chromium.org> wrote: > > > In an effort to separate intentional arithmetic wrap-around from > > unexpected wrap-around, we need to refactor places that depend on this > > kind of math. One of the most common code patterns of this is: > > > > VAR + value < VAR > > > > Notably, this is considered "undefined behavior" for signed and pointer > > types, which the kernel works around by using the -fno-strict-overflow > > option in the build[1] (which used to just be -fwrapv). Regardless, we > > want to get the kernel source to the position where we can meaningfully > > instrument arithmetic wrap-around conditions and catch them when they > > are unexpected, regardless of whether they are signed[2], unsigned[3], > > or pointer[4] types. > > > > Refactor open-coded wrap-around addition test to use add_would_overflow(). > > This paves the way to enabling the wrap-around sanitizers in the future. > > > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > > Link: https://github.com/KSPP/linux/issues/26 [2] > > Link: https://github.com/KSPP/linux/issues/27 [3] > > Link: https://github.com/KSPP/linux/issues/344 [4] > > Cc: Kalle Valo <kvalo@kernel.org> > > Cc: Johannes Berg <johannes.berg@intel.com> > > Cc: Max Chen <mxchen@codeaurora.org> > > Cc: Yang Shen <shenyang39@huawei.com> > > Cc: linux-wireless@vger.kernel.org > > Signed-off-by: Kees Cook <keescook@chromium.org> > > Acked-by: Kalle Valo <kvalo@kernel.org> > > If you can edit before commit please add "wifi:" prefix to the wireless patches: > > ERROR: 'wifi:' prefix missing: '[PATCH 41/82] wil6210: Refactor intentional wrap-around test' > ERROR: 'wifi:' prefix missing: '[PATCH 62/82] mwifiex: pcie: Refactor intentional wrap-around test' Ah yes, thank you! I will adjust them. -Kees > > 2 patches set to Not Applicable. > > 13526631 [41/82] wil6210: Refactor intentional wrap-around test > 13526632 [62/82] mwifiex: pcie: Refactor intentional wrap-around test > > -- > https://patchwork.kernel.org/project/linux-wireless/patch/20240123002814.1396804-41-keescook@chromium.org/ > > https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches > -- Kees Cook ^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 62/82] mwifiex: pcie: Refactor intentional wrap-around test [not found] <20240122235208.work.748-kees@kernel.org> 2024-01-23 0:27 ` [PATCH 41/82] wil6210: Refactor intentional wrap-around test Kees Cook @ 2024-01-23 0:27 ` Kees Cook 2024-01-23 6:36 ` Kalle Valo 1 sibling, 1 reply; 6+ messages in thread From: Kees Cook @ 2024-01-23 0:27 UTC (permalink / raw) To: linux-hardening Cc: Kees Cook, Brian Norris, Kalle Valo, Jonas Dreßler, Dmitry Antipov, Tsuchiya Yuto, linux-wireless, Gustavo A. R. Silva, Bill Wendling, Justin Stitt, linux-kernel In an effort to separate intentional arithmetic wrap-around from unexpected wrap-around, we need to refactor places that depend on this kind of math. One of the most common code patterns of this is: VAR + value < VAR Notably, this is considered "undefined behavior" for signed and pointer types, which the kernel works around by using the -fno-strict-overflow option in the build[1] (which used to just be -fwrapv). Regardless, we want to get the kernel source to the position where we can meaningfully instrument arithmetic wrap-around conditions and catch them when they are unexpected, regardless of whether they are signed[2], unsigned[3], or pointer[4] types. Refactor open-coded wrap-around addition test to use add_would_overflow(). This paves the way to enabling the wrap-around sanitizers in the future. Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] Link: https://github.com/KSPP/linux/issues/26 [2] Link: https://github.com/KSPP/linux/issues/27 [3] Link: https://github.com/KSPP/linux/issues/344 [4] Cc: Brian Norris <briannorris@chromium.org> Cc: Kalle Valo <kvalo@kernel.org> Cc: "Jonas Dreßler" <verdre@v0yd.nl> Cc: Dmitry Antipov <dmantipov@yandex.ru> Cc: Tsuchiya Yuto <kitakar@gmail.com> Cc: linux-wireless@vger.kernel.org Signed-off-by: Kees Cook <keescook@chromium.org> --- drivers/net/wireless/marvell/mwifiex/pcie.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/net/wireless/marvell/mwifiex/pcie.c b/drivers/net/wireless/marvell/mwifiex/pcie.c index 5f997becdbaa..e69347e65f0e 100644 --- a/drivers/net/wireless/marvell/mwifiex/pcie.c +++ b/drivers/net/wireless/marvell/mwifiex/pcie.c @@ -2086,7 +2086,7 @@ static int mwifiex_extract_wifi_fw(struct mwifiex_adapter *adapter, switch (dnld_cmd) { case MWIFIEX_FW_DNLD_CMD_1: - if (offset + data_len < data_len) { + if (add_would_overflow(data_len, offset)) { mwifiex_dbg(adapter, ERROR, "bad FW parse\n"); ret = -1; goto done; @@ -2110,7 +2110,7 @@ static int mwifiex_extract_wifi_fw(struct mwifiex_adapter *adapter, case MWIFIEX_FW_DNLD_CMD_5: first_cmd = true; /* Check for integer overflow */ - if (offset + data_len < data_len) { + if (add_would_overflow(data_len, offset)) { mwifiex_dbg(adapter, ERROR, "bad FW parse\n"); ret = -1; goto done; @@ -2120,7 +2120,7 @@ static int mwifiex_extract_wifi_fw(struct mwifiex_adapter *adapter, case MWIFIEX_FW_DNLD_CMD_6: first_cmd = true; /* Check for integer overflow */ - if (offset + data_len < data_len) { + if (add_would_overflow(data_len, offset)) { mwifiex_dbg(adapter, ERROR, "bad FW parse\n"); ret = -1; goto done; -- 2.34.1 ^ permalink raw reply related [flat|nested] 6+ messages in thread
* Re: [PATCH 62/82] mwifiex: pcie: Refactor intentional wrap-around test 2024-01-23 0:27 ` [PATCH 62/82] mwifiex: pcie: " Kees Cook @ 2024-01-23 6:36 ` Kalle Valo 0 siblings, 0 replies; 6+ messages in thread From: Kalle Valo @ 2024-01-23 6:36 UTC (permalink / raw) To: Kees Cook Cc: linux-hardening, Brian Norris, Jonas Dreßler, Dmitry Antipov, Tsuchiya Yuto, linux-wireless, Gustavo A. R. Silva, Bill Wendling, Justin Stitt, linux-kernel Kees Cook <keescook@chromium.org> writes: > In an effort to separate intentional arithmetic wrap-around from > unexpected wrap-around, we need to refactor places that depend on this > kind of math. One of the most common code patterns of this is: > > VAR + value < VAR > > Notably, this is considered "undefined behavior" for signed and pointer > types, which the kernel works around by using the -fno-strict-overflow > option in the build[1] (which used to just be -fwrapv). Regardless, we > want to get the kernel source to the position where we can meaningfully > instrument arithmetic wrap-around conditions and catch them when they > are unexpected, regardless of whether they are signed[2], unsigned[3], > or pointer[4] types. > > Refactor open-coded wrap-around addition test to use add_would_overflow(). > This paves the way to enabling the wrap-around sanitizers in the future. > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > Link: https://github.com/KSPP/linux/issues/26 [2] > Link: https://github.com/KSPP/linux/issues/27 [3] > Link: https://github.com/KSPP/linux/issues/344 [4] > Cc: Brian Norris <briannorris@chromium.org> > Cc: Kalle Valo <kvalo@kernel.org> > Cc: "Jonas Dreßler" <verdre@v0yd.nl> > Cc: Dmitry Antipov <dmantipov@yandex.ru> > Cc: Tsuchiya Yuto <kitakar@gmail.com> > Cc: linux-wireless@vger.kernel.org > Signed-off-by: Kees Cook <keescook@chromium.org> I assume this goes via some other tree than wireless-next so: Acked-by: Kalle Valo <kvalo@kernel.org> -- https://patchwork.kernel.org/project/linux-wireless/list/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches ^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2024-01-23 22:52 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <20240122235208.work.748-kees@kernel.org>
2024-01-23 0:27 ` [PATCH 41/82] wil6210: Refactor intentional wrap-around test Kees Cook
2024-01-23 6:36 ` Kalle Valo
2024-01-23 11:50 ` Kalle Valo
2024-01-23 22:52 ` Kees Cook
2024-01-23 0:27 ` [PATCH 62/82] mwifiex: pcie: " Kees Cook
2024-01-23 6:36 ` Kalle Valo
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox