Linux wireless drivers development
 help / color / mirror / Atom feed
From: "Luis R. Rodriguez" <mcgrof@gmail.com>
To: "Johannes Berg" <johannes@sipsolutions.net>
Cc: linux-wireless <linux-wireless@vger.kernel.org>,
	"Michael Wu" <flamingice@sourmilk.net>
Subject: Re: [RFC] mac80211: don't use if_id, use if_priv
Date: Fri, 30 Nov 2007 11:33:17 -0500	[thread overview]
Message-ID: <43e72e890711300833m20bb79ffof1cc228c6ec4922c@mail.gmail.com> (raw)
In-Reply-To: <1196423301.6058.187.camel@johannes.berg>

On Nov 30, 2007 6:48 AM, Johannes Berg <johannes@sipsolutions.net> wrote:
> Here's a non-functioning (except for b43/b43legacy) patch that gets rid
> of the if_id stuff all over in favour of a new if_priv pointer.
>
> This has two advantages:
>  * no more looking up interfaces by if_id, this is better for network
>    namespaces and performance
>  * allows drivers to store and retrieve per-interface data without
>    having to allocate own lists/hash tables
>
> and a small disadvantage:
>  * storage size can increase by four bytes on 64-bit machines.
>
> Comments welcome. I'll be improving this and making it at least compile
> with all other drivers.

What will ieee80211_sub_if_data's if_priv look like?

>  Maybe "struct if_priv" should be renamed?

Yeah, hm... mac80211_priv, iw_priv, subif_priv??

  Luis

  reply	other threads:[~2007-11-30 16:33 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-11-30 11:48 [RFC] mac80211: don't use if_id, use if_priv Johannes Berg
2007-11-30 16:33 ` Luis R. Rodriguez [this message]
2007-12-03 10:42   ` Johannes Berg
2007-12-01  1:59 ` Michael Wu
2007-12-03 10:44   ` Johannes Berg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=43e72e890711300833m20bb79ffof1cc228c6ec4922c@mail.gmail.com \
    --to=mcgrof@gmail.com \
    --cc=flamingice@sourmilk.net \
    --cc=johannes@sipsolutions.net \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox