From: Johannes Berg <johannes@sipsolutions.net>
To: Karthikeyan Kathirvel <karthikeyan.kathirvel@oss.qualcomm.com>
Cc: linux-wireless@vger.kernel.org, ath12k@lists.infradead.org
Subject: Re: [PATCH wireless-next v4 1/2] wifi: UHR: define DPS/DBE/P-EDCA elements and fix size parsing
Date: Tue, 24 Feb 2026 17:42:36 +0100 [thread overview]
Message-ID: <c71a84fe19a632ccd748d0f1fded1a8b1277e0b1.camel@sipsolutions.net> (raw)
In-Reply-To: <20260217054731.3667600-2-karthikeyan.kathirvel@oss.qualcomm.com>
Oh, another thing
> + * @dbe_params:
> + * B0-B2 - DBE Bandwidth field is set to indicate
> + * expanded bandwidth for DBE mode
> + * Value 0 is reserved.
> + * Set to 1 to indicate 40 MHz DBE bandwidth.
> + * Set to 2 to indicate 80 MHz DBE bandwidth.
> + * Set to 3 to indicate 160 MHz DBE bandwidth.
> + * Set to 4 to indicate 320-1 MHz DBE bandwidth.
> + * Set to 5 to indicate 320-2 MHz DBE bandwidth.
> + * Values 6 to 7 are reserved.
> + * B3 - DBE Disabled Subchannel Bitmap Present.
Seems we should have an enum for the possible bandwidth values?
And also, it's confusing:
> +/**
> + * enum ieee80211_dbe_bandwidth - DBE Bandwidth
because this one is just "DBE Bandwidth" - I think you should rename
this to "DBE Maximum Supported Bandwidth" or something related, and add
the operational, since there's a 4/5 difference with 320 vs. 320-1/320-2
(the latter in UHR operation)
johannes
next prev parent reply other threads:[~2026-02-24 16:42 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-17 5:47 [PATCH wireless-next v4 00/02] wifi: ieee80211/mac80211: Add UHR (802.11bn) Capability and Operation parsing helpers Karthikeyan Kathirvel
2026-02-17 5:47 ` [PATCH wireless-next v4 1/2] wifi: UHR: define DPS/DBE/P-EDCA elements and fix size parsing Karthikeyan Kathirvel
2026-02-24 16:32 ` Johannes Berg
2026-03-03 10:11 ` Karthikeyan Kathirvel
2026-02-24 16:42 ` Johannes Berg [this message]
2026-02-24 17:38 ` Johannes Berg
2026-03-03 10:11 ` Karthikeyan Kathirvel
2026-02-24 20:47 ` Johannes Berg
2026-02-17 5:47 ` [PATCH wireless-next v4 2/2] wifi: mac80211_hwsim: Add UHR capabilities to the driver Karthikeyan Kathirvel
2026-02-24 16:20 ` Johannes Berg
2026-03-03 11:41 ` Karthikeyan Kathirvel
2026-03-03 11:44 ` Johannes Berg
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c71a84fe19a632ccd748d0f1fded1a8b1277e0b1.camel@sipsolutions.net \
--to=johannes@sipsolutions.net \
--cc=ath12k@lists.infradead.org \
--cc=karthikeyan.kathirvel@oss.qualcomm.com \
--cc=linux-wireless@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox