Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH 0/8] unify rx datapath between mt76x0 and mt76x2 drivers
@ 2018-10-05  8:28 Lorenzo Bianconi
  2018-10-05  8:28 ` [PATCH 1/8] mt76: move tpc routines in mt76x02-lib module Lorenzo Bianconi
                   ` (8 more replies)
  0 siblings, 9 replies; 10+ messages in thread
From: Lorenzo Bianconi @ 2018-10-05  8:28 UTC (permalink / raw)
  To: nbd; +Cc: sgruszka, linux-wireless

Move mt76x02_irq_handler irq handler in mt76x02-lib module in order
to unify rx datapath between mt76x0 and mt76x2 drivers and remove
duplicated code

Changes since rfc:
- drop patch 9/9 ("mt76x0: pci: add mt76x0_register_device in
  mt76x0e_register_device") for the moment
- rebase on top of 'unify rxwi parsing between mt76x0 and mt76x2 drivers'
  https://marc.info/?l=linux-wireless&m=153869000528661&w=2

Lorenzo Bianconi (8):
  mt76: move tpc routines in mt76x02-lib module
  mt76: move mt76x02_tx_prepare_skb in mt76x02_txrx.c
  mt76: usb: move mt76x02u_tx_complete_skb in mt76x02_usb_core.c
  mt76: move mt76x02_mac_poll_tx_status in mt76x02-lib moudle
  mt76: move mt76x02_tx_complete in mt76x02-lib module
  mt76: use mt76x02_dev instead of mt76_dev in mt76x02_mmio.c
  mt76: move tx_tasklet management in mt76x02-lib moudle
  mt76: move irq handler in mt76x02-lib moudle

 drivers/net/wireless/mediatek/mt76/Makefile   |   3 +-
 drivers/net/wireless/mediatek/mt76/mt76.h     |   6 +-
 .../net/wireless/mediatek/mt76/mt76x0/pci.c   |   8 +-
 .../net/wireless/mediatek/mt76/mt76x0/usb.c   |   2 +-
 drivers/net/wireless/mediatek/mt76/mt76x02.h  |  18 +-
 .../net/wireless/mediatek/mt76/mt76x02_dma.h  |   8 +-
 .../net/wireless/mediatek/mt76/mt76x02_mac.c  |  70 ++++++-
 .../net/wireless/mediatek/mt76/mt76x02_mac.h  |  20 ++
 .../net/wireless/mediatek/mt76/mt76x02_mmio.c | 174 ++++++++++++++----
 .../{mt76x2/pci_trace.c => mt76x02_trace.c}   |   2 +-
 .../mt76/{mt76x2/trace.h => mt76x02_trace.h}  |  21 +--
 .../net/wireless/mediatek/mt76/mt76x02_txrx.c |  72 ++++++--
 .../net/wireless/mediatek/mt76/mt76x02_usb.h  |   2 +
 .../wireless/mediatek/mt76/mt76x02_usb_core.c |  18 ++
 .../wireless/mediatek/mt76/mt76x2/Makefile    |   7 +-
 .../net/wireless/mediatek/mt76/mt76x2/mac.h   |  20 --
 .../wireless/mediatek/mt76/mt76x2/mt76x2.h    |  16 --
 .../net/wireless/mediatek/mt76/mt76x2/pci.c   |   3 +-
 .../wireless/mediatek/mt76/mt76x2/pci_core.c  |  75 --------
 .../wireless/mediatek/mt76/mt76x2/pci_dfs.c   |   6 +-
 .../wireless/mediatek/mt76/mt76x2/pci_dma.c   |  37 ----
 .../wireless/mediatek/mt76/mt76x2/pci_init.c  |  24 +--
 .../wireless/mediatek/mt76/mt76x2/pci_mac.c   |  73 +-------
 .../wireless/mediatek/mt76/mt76x2/pci_main.c  |   2 +-
 .../wireless/mediatek/mt76/mt76x2/pci_tx.c    |  31 ----
 .../net/wireless/mediatek/mt76/mt76x2/tx.c    |  49 -----
 .../wireless/mediatek/mt76/mt76x2/usb_init.c  |   2 +-
 27 files changed, 355 insertions(+), 414 deletions(-)
 rename drivers/net/wireless/mediatek/mt76/{mt76x2/pci_trace.c => mt76x02_trace.c} (97%)
 rename drivers/net/wireless/mediatek/mt76/{mt76x2/trace.h => mt76x02_trace.h} (94%)
 delete mode 100644 drivers/net/wireless/mediatek/mt76/mt76x2/pci_core.c
 delete mode 100644 drivers/net/wireless/mediatek/mt76/mt76x2/pci_dma.c
 delete mode 100644 drivers/net/wireless/mediatek/mt76/mt76x2/tx.c

-- 
2.17.1


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2018-10-05  9:57 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2018-10-05  8:28 [PATCH 0/8] unify rx datapath between mt76x0 and mt76x2 drivers Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 1/8] mt76: move tpc routines in mt76x02-lib module Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 2/8] mt76: move mt76x02_tx_prepare_skb in mt76x02_txrx.c Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 3/8] mt76: usb: move mt76x02u_tx_complete_skb in mt76x02_usb_core.c Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 4/8] mt76: move mt76x02_mac_poll_tx_status in mt76x02-lib moudle Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 5/8] mt76: move mt76x02_tx_complete in mt76x02-lib module Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 6/8] mt76: use mt76x02_dev instead of mt76_dev in mt76x02_mmio.c Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 7/8] mt76: move tx_tasklet management in mt76x02-lib moudle Lorenzo Bianconi
2018-10-05  8:28 ` [PATCH 8/8] mt76: move irq handler " Lorenzo Bianconi
2018-10-05  9:57 ` [PATCH 0/8] unify rx datapath between mt76x0 and mt76x2 drivers Felix Fietkau

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox