Linux IEEE 802.15.4 and 6LoWPAN development
 help / color / mirror / Atom feed
* [PATCH bluetooth-next 00/16] ieee802154: rework receive handling
@ 2014-10-27 11:42 Alexander Aring
  2014-10-27 11:42 ` [PATCH bluetooth-next 01/16] mac802154: tx: use put_unaligned_le16 for copy crc Alexander Aring
                   ` (15 more replies)
  0 siblings, 16 replies; 19+ messages in thread
From: Alexander Aring @ 2014-10-27 11:42 UTC (permalink / raw)
  To: linux-wpan; +Cc: kernel, Alexander Aring

This patch serie improves and cleanups the receive handling.
Instead workqueue we use a tasklet now for parsing frames.
The first patch is a fix for using put_unaligned_le16 to copy
checksum in skb data which was reported by Marcel Holtmann.

Other patches are cleanups for preparing further patches to
introduce a frame parsing like mac80211. We don't change
the printout function to netdev_foo now because the most
code will be replaced by the new frame parsing implementation.

Alexander Aring (16):
  mac802154: tx: use put_unaligned_le16 for copy crc
  ieee802154: drivers: use dev_alloc_skb
  mac802154: rx: use tasklet instead workqueue
  mac802154: rx: warn if ieee80211_rx call from irq
  mac802154: rx: move receive handling into rx.c
  mac802154: tx: remove monitor receive while xmit
  mac802154: rx: rename remove mac802154_subif_rx
  mac802154: rx: move skb->protocol setting
  mac802154: rx: add CHECKSUM_UNNECESSARY
  mac802154: rx: add monitor pkt_type information
  mac802154: rx: move skb_reset_mac_header
  mac802154: rx: move rcu locking
  ieee802154: add valid psdu length helper
  at86rf230: use ieee802154_is_valid_psdu_len helper
  at86rf230: improve receive handling
  mac802154: rx: change naming convention

 drivers/net/ieee802154/at86rf230.c |  32 ++---
 drivers/net/ieee802154/cc2520.c    |   2 +-
 drivers/net/ieee802154/mrf24j40.c  |   2 +-
 include/linux/ieee802154.h         |  11 ++
 include/net/mac802154.h            |   1 +
 net/mac802154/ieee802154_i.h       |   9 +-
 net/mac802154/iface.c              | 186 -------------------------
 net/mac802154/main.c               |  30 ++++
 net/mac802154/monitor.c            |  27 ----
 net/mac802154/rx.c                 | 279 +++++++++++++++++++++++++++++++------
 net/mac802154/tx.c                 |   7 +-
 11 files changed, 296 insertions(+), 290 deletions(-)

-- 
2.1.2


^ permalink raw reply	[flat|nested] 19+ messages in thread

end of thread, other threads:[~2014-10-27 12:29 UTC | newest]

Thread overview: 19+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-10-27 11:42 [PATCH bluetooth-next 00/16] ieee802154: rework receive handling Alexander Aring
2014-10-27 11:42 ` [PATCH bluetooth-next 01/16] mac802154: tx: use put_unaligned_le16 for copy crc Alexander Aring
2014-10-27 11:42 ` [PATCH bluetooth-next 02/16] ieee802154: drivers: use dev_alloc_skb Alexander Aring
2014-10-27 11:42 ` [PATCH bluetooth-next 03/16] mac802154: rx: use tasklet instead workqueue Alexander Aring
2014-10-27 11:42 ` [PATCH bluetooth-next 04/16] mac802154: rx: warn if ieee80211_rx call from irq Alexander Aring
2014-10-27 12:10   ` Marc Kleine-Budde
2014-10-27 12:29     ` Alexander Aring
2014-10-27 11:42 ` [PATCH bluetooth-next 05/16] mac802154: rx: move receive handling into rx.c Alexander Aring
2014-10-27 11:42 ` [PATCH bluetooth-next 06/16] mac802154: tx: remove monitor receive while xmit Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 07/16] mac802154: rx: rename remove mac802154_subif_rx Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 08/16] mac802154: rx: move skb->protocol setting Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 09/16] mac802154: rx: add CHECKSUM_UNNECESSARY Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 10/16] mac802154: rx: add monitor pkt_type information Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 11/16] mac802154: rx: move skb_reset_mac_header Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 12/16] mac802154: rx: move rcu locking Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 13/16] ieee802154: add valid psdu length helper Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 14/16] at86rf230: use ieee802154_is_valid_psdu_len helper Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 15/16] at86rf230: improve receive handling Alexander Aring
2014-10-27 11:43 ` [PATCH bluetooth-next 16/16] mac802154: rx: change naming convention Alexander Aring

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox