Linux XFS filesystem development
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Chandan Babu R <chandan.babu@oracle.com>
Cc: "Darrick J. Wong" <djwong@kernel.org>, linux-xfs@vger.kernel.org
Subject: [PATCH 14/22] xfs: merge the calls to xfs_rtallocate_range in xfs_rtallocate_block
Date: Mon, 18 Dec 2023 05:57:30 +0100	[thread overview]
Message-ID: <20231218045738.711465-15-hch@lst.de> (raw)
In-Reply-To: <20231218045738.711465-1-hch@lst.de>

Use a goto to use a common tail for the case of being able to allocate
an extent.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 fs/xfs/xfs_rtalloc.c | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

diff --git a/fs/xfs/xfs_rtalloc.c b/fs/xfs/xfs_rtalloc.c
index 6fcc847b116273..9604acd7aa6cec 100644
--- a/fs/xfs/xfs_rtalloc.c
+++ b/fs/xfs/xfs_rtalloc.c
@@ -252,19 +252,15 @@ xfs_rtallocate_extent_block(
 		error = xfs_rtcheck_range(args, i, maxlen, 1, &next, &stat);
 		if (error)
 			return error;
-
 		if (stat) {
 			/*
 			 * i for maxlen is all free, allocate and return that.
 			 */
-			error = xfs_rtallocate_range(args, i, maxlen);
-			if (error)
-				return error;
-
-			*len = maxlen;
-			*rtx = i;
-			return 0;
+			bestlen = maxlen;
+			besti = i;
+			goto allocate;
 		}
+
 		/*
 		 * In the case where we have a variable-sized allocation
 		 * request, figure out how big this free piece is,
@@ -315,6 +311,7 @@ xfs_rtallocate_extent_block(
 	/*
 	 * Allocate besti for bestlen & return that.
 	 */
+allocate:
 	error = xfs_rtallocate_range(args, besti, bestlen);
 	if (error)
 		return error;
-- 
2.39.2


  parent reply	other threads:[~2023-12-18  4:58 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-18  4:57 RT allocator tidy ups v2 Christoph Hellwig
2023-12-18  4:57 ` [PATCH 01/22] xfs: consider minlen sized extents in xfs_rtallocate_extent_block Christoph Hellwig
2023-12-18  4:57 ` [PATCH 02/22] xfs: turn the xfs_trans_mod_dquot_byino stub into an inline function Christoph Hellwig
2023-12-18  4:57 ` [PATCH 03/22] xfs: remove the xfs_alloc_arg argument to xfs_bmap_btalloc_accounting Christoph Hellwig
2023-12-18  4:57 ` [PATCH 04/22] xfs: also use xfs_bmap_btalloc_accounting for RT allocations Christoph Hellwig
2023-12-18  4:57 ` [PATCH 05/22] xfs: move xfs_bmap_rtalloc to xfs_rtalloc.c Christoph Hellwig
2023-12-18  4:57 ` [PATCH 06/22] xfs: return -ENOSPC from xfs_rtallocate_* Christoph Hellwig
2023-12-18  4:57 ` [PATCH 07/22] xfs: reflow the tail end of xfs_bmap_rtalloc Christoph Hellwig
2023-12-18  4:57 ` [PATCH 08/22] xfs: indicate if xfs_bmap_adjacent changed ap->blkno Christoph Hellwig
2023-12-18  4:57 ` [PATCH 09/22] xfs: cleanup picking the start extent hint in xfs_bmap_rtalloc Christoph Hellwig
2023-12-18  4:57 ` [PATCH 10/22] xfs: move xfs_rtget_summary to xfs_rtbitmap.c Christoph Hellwig
2023-12-18  4:57 ` [PATCH 11/22] xfs: split xfs_rtmodify_summary_int Christoph Hellwig
2023-12-18  4:57 ` [PATCH 12/22] xfs: invert a check in xfs_rtallocate_extent_block Christoph Hellwig
2023-12-18 17:50   ` Darrick J. Wong
2023-12-18  4:57 ` [PATCH 13/22] xfs: reflow the tail end of xfs_rtallocate_extent_block Christoph Hellwig
2023-12-18 17:51   ` Darrick J. Wong
2023-12-18  4:57 ` Christoph Hellwig [this message]
2023-12-18 17:52   ` [PATCH 14/22] xfs: merge the calls to xfs_rtallocate_range in xfs_rtallocate_block Darrick J. Wong
2023-12-18  4:57 ` [PATCH 15/22] xfs: tidy up xfs_rtallocate_extent_exact Christoph Hellwig
2023-12-18  4:57 ` [PATCH 16/22] xfs: factor out a xfs_rtalloc_sumlevel helper Christoph Hellwig
2023-12-18  4:57 ` [PATCH 17/22] xfs: remove rt-wrappers from xfs_format.h Christoph Hellwig
2023-12-18  4:57 ` [PATCH 18/22] xfs: remove XFS_RTMIN/XFS_RTMAX Christoph Hellwig
2023-12-18  4:57 ` [PATCH 19/22] xfs: reorder the minlen and prod calculations in xfs_bmap_rtalloc Christoph Hellwig
2023-12-18  4:57 ` [PATCH 20/22] xfs: simplify and optimize the RT allocation fallback cascade Christoph Hellwig
2023-12-18 22:17   ` Darrick J. Wong
2023-12-18  4:57 ` [PATCH 21/22] xfs: fold xfs_rtallocate_extent into xfs_bmap_rtalloc Christoph Hellwig
2023-12-18  4:57 ` [PATCH 22/22] xfs: rename xfs_bmap_rtalloc to xfs_rtallocate_extent Christoph Hellwig
2023-12-18 22:24   ` Darrick J. Wong
2023-12-19  4:17     ` Christoph Hellwig
2023-12-19  4:51       ` Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20231218045738.711465-15-hch@lst.de \
    --to=hch@lst.de \
    --cc=chandan.babu@oracle.com \
    --cc=djwong@kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox