From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: Chandan Babu R <chandan.babu@oracle.com>, linux-xfs@vger.kernel.org
Subject: Re: [PATCH 22/22] xfs: rename xfs_bmap_rtalloc to xfs_rtallocate_extent
Date: Mon, 18 Dec 2023 14:24:30 -0800 [thread overview]
Message-ID: <20231218222430.GW361584@frogsfrogsfrogs> (raw)
In-Reply-To: <20231218045738.711465-23-hch@lst.de>
On Mon, Dec 18, 2023 at 05:57:38AM +0100, Christoph Hellwig wrote:
> Now that the xfs_rtallocate_extent name has been freed, use it for what
> so far is xfs_bmap_rtalloc as the name is a lot better fitting.
>
> Also drop the !CONFIG_XFS_RT stub as the compiler will eliminate the
> call for that case given that XFS_IS_REALTIME_INODE is hard wire to
> return 0 in the !CONFIG_XFS_RT case.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
> fs/xfs/libxfs/xfs_bmap.c | 2 +-
> fs/xfs/xfs_bmap_util.h | 15 +--------------
> fs/xfs/xfs_rtalloc.c | 2 +-
> 3 files changed, 3 insertions(+), 16 deletions(-)
>
> diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> index 46a9b22a3733e3..245f7045da15c4 100644
> --- a/fs/xfs/libxfs/xfs_bmap.c
> +++ b/fs/xfs/libxfs/xfs_bmap.c
> @@ -4091,7 +4091,7 @@ xfs_bmap_alloc_userdata(
> }
>
> if (XFS_IS_REALTIME_INODE(bma->ip))
> - return xfs_bmap_rtalloc(bma);
> + return xfs_rtallocate_extent(bma);
> }
>
> if (unlikely(XFS_TEST_ERROR(false, mp,
> diff --git a/fs/xfs/xfs_bmap_util.h b/fs/xfs/xfs_bmap_util.h
> index 77ecbb753ef207..233bbbd2a4676d 100644
> --- a/fs/xfs/xfs_bmap_util.h
> +++ b/fs/xfs/xfs_bmap_util.h
> @@ -16,20 +16,7 @@ struct xfs_mount;
> struct xfs_trans;
> struct xfs_bmalloca;
>
> -#ifdef CONFIG_XFS_RT
> -int xfs_bmap_rtalloc(struct xfs_bmalloca *ap);
> -#else /* !CONFIG_XFS_RT */
> -/*
> - * Attempts to allocate RT extents when RT is disable indicates corruption and
> - * should trigger a shutdown.
> - */
> -static inline int
> -xfs_bmap_rtalloc(struct xfs_bmalloca *ap)
> -{
> - return -EFSCORRUPTED;
> -}
> -#endif /* CONFIG_XFS_RT */
> -
> +int xfs_rtallocate_extent(struct xfs_bmalloca *ap);
> int xfs_bmap_punch_delalloc_range(struct xfs_inode *ip,
> xfs_off_t start_byte, xfs_off_t end_byte);
>
> diff --git a/fs/xfs/xfs_rtalloc.c b/fs/xfs/xfs_rtalloc.c
> index 4b2de22bdd70cc..6344e499af8e27 100644
> --- a/fs/xfs/xfs_rtalloc.c
> +++ b/fs/xfs/xfs_rtalloc.c
> @@ -1312,7 +1312,7 @@ xfs_rtalloc_align_minmax(
> }
>
> int
> -xfs_bmap_rtalloc(
> +xfs_rtallocate_extent(
> struct xfs_bmalloca *ap)
Hmm. I'm still not sure I like the name here -- we're doing an rt
allocation for a bmap allocation args structure.
xfs_rtalloc_bmap?
(Or just drop this one, I've lost my will to fight over naming.)
--D
> {
> struct xfs_mount *mp = ap->ip->i_mount;
> --
> 2.39.2
>
>
next prev parent reply other threads:[~2023-12-18 22:24 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-18 4:57 RT allocator tidy ups v2 Christoph Hellwig
2023-12-18 4:57 ` [PATCH 01/22] xfs: consider minlen sized extents in xfs_rtallocate_extent_block Christoph Hellwig
2023-12-18 4:57 ` [PATCH 02/22] xfs: turn the xfs_trans_mod_dquot_byino stub into an inline function Christoph Hellwig
2023-12-18 4:57 ` [PATCH 03/22] xfs: remove the xfs_alloc_arg argument to xfs_bmap_btalloc_accounting Christoph Hellwig
2023-12-18 4:57 ` [PATCH 04/22] xfs: also use xfs_bmap_btalloc_accounting for RT allocations Christoph Hellwig
2023-12-18 4:57 ` [PATCH 05/22] xfs: move xfs_bmap_rtalloc to xfs_rtalloc.c Christoph Hellwig
2023-12-18 4:57 ` [PATCH 06/22] xfs: return -ENOSPC from xfs_rtallocate_* Christoph Hellwig
2023-12-18 4:57 ` [PATCH 07/22] xfs: reflow the tail end of xfs_bmap_rtalloc Christoph Hellwig
2023-12-18 4:57 ` [PATCH 08/22] xfs: indicate if xfs_bmap_adjacent changed ap->blkno Christoph Hellwig
2023-12-18 4:57 ` [PATCH 09/22] xfs: cleanup picking the start extent hint in xfs_bmap_rtalloc Christoph Hellwig
2023-12-18 4:57 ` [PATCH 10/22] xfs: move xfs_rtget_summary to xfs_rtbitmap.c Christoph Hellwig
2023-12-18 4:57 ` [PATCH 11/22] xfs: split xfs_rtmodify_summary_int Christoph Hellwig
2023-12-18 4:57 ` [PATCH 12/22] xfs: invert a check in xfs_rtallocate_extent_block Christoph Hellwig
2023-12-18 17:50 ` Darrick J. Wong
2023-12-18 4:57 ` [PATCH 13/22] xfs: reflow the tail end of xfs_rtallocate_extent_block Christoph Hellwig
2023-12-18 17:51 ` Darrick J. Wong
2023-12-18 4:57 ` [PATCH 14/22] xfs: merge the calls to xfs_rtallocate_range in xfs_rtallocate_block Christoph Hellwig
2023-12-18 17:52 ` Darrick J. Wong
2023-12-18 4:57 ` [PATCH 15/22] xfs: tidy up xfs_rtallocate_extent_exact Christoph Hellwig
2023-12-18 4:57 ` [PATCH 16/22] xfs: factor out a xfs_rtalloc_sumlevel helper Christoph Hellwig
2023-12-18 4:57 ` [PATCH 17/22] xfs: remove rt-wrappers from xfs_format.h Christoph Hellwig
2023-12-18 4:57 ` [PATCH 18/22] xfs: remove XFS_RTMIN/XFS_RTMAX Christoph Hellwig
2023-12-18 4:57 ` [PATCH 19/22] xfs: reorder the minlen and prod calculations in xfs_bmap_rtalloc Christoph Hellwig
2023-12-18 4:57 ` [PATCH 20/22] xfs: simplify and optimize the RT allocation fallback cascade Christoph Hellwig
2023-12-18 22:17 ` Darrick J. Wong
2023-12-18 4:57 ` [PATCH 21/22] xfs: fold xfs_rtallocate_extent into xfs_bmap_rtalloc Christoph Hellwig
2023-12-18 4:57 ` [PATCH 22/22] xfs: rename xfs_bmap_rtalloc to xfs_rtallocate_extent Christoph Hellwig
2023-12-18 22:24 ` Darrick J. Wong [this message]
2023-12-19 4:17 ` Christoph Hellwig
2023-12-19 4:51 ` Darrick J. Wong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20231218222430.GW361584@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=chandan.babu@oracle.com \
--cc=hch@lst.de \
--cc=linux-xfs@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox