Linux XFS filesystem development
 help / color / mirror / Atom feed
* [PATCH 0/6] xfs: cleanup key comparing routines
@ 2025-06-12 10:24 Fedor Pchelkin
  2025-06-12 10:24 ` [PATCH 1/6] xfs: rename diff_two_keys routines Fedor Pchelkin
                   ` (6 more replies)
  0 siblings, 7 replies; 9+ messages in thread
From: Fedor Pchelkin @ 2025-06-12 10:24 UTC (permalink / raw)
  To: Carlos Maiolino, Darrick J. Wong
  Cc: Fedor Pchelkin, Christoph Hellwig, linux-xfs, linux-kernel,
	lvc-project

Key comparing routines are currently opencoded with extra casts and
subtractions which is error prone and can be replaced with a neat
cmp_int() helper which is now in a generic header file.

Started from:
https://lore.kernel.org/linux-xfs/20250426134232.128864-1-pchelkin@ispras.ru/T/#u

Thanks Darrick for suggestion!

Fedor Pchelkin (6):
  xfs: rename diff_two_keys routines
  xfs: rename key_diff routines
  xfs: refactor cmp_two_keys routines to take advantage of cmp_int()
  xfs: refactor cmp_key_with_cur routines to take advantage of cmp_int()
  xfs: use a proper variable name and type for storing a comparison
    result
  xfs: refactor xfs_btree_diff_two_ptrs() to take advantage of cmp_int()

 fs/xfs/libxfs/xfs_alloc_btree.c      | 52 +++++++++------------
 fs/xfs/libxfs/xfs_bmap_btree.c       | 32 +++++--------
 fs/xfs/libxfs/xfs_btree.c            | 31 ++++++-------
 fs/xfs/libxfs/xfs_btree.h            | 41 +++++++++--------
 fs/xfs/libxfs/xfs_ialloc_btree.c     | 24 +++++-----
 fs/xfs/libxfs/xfs_refcount_btree.c   | 18 ++++----
 fs/xfs/libxfs/xfs_rmap_btree.c       | 67 ++++++++++------------------
 fs/xfs/libxfs/xfs_rtrefcount_btree.c | 18 ++++----
 fs/xfs/libxfs/xfs_rtrmap_btree.c     | 67 ++++++++++------------------
 fs/xfs/scrub/rcbag_btree.c           | 38 +++++-----------
 10 files changed, 156 insertions(+), 232 deletions(-)

-- 
2.49.0


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2025-07-01 14:53 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-06-12 10:24 [PATCH 0/6] xfs: cleanup key comparing routines Fedor Pchelkin
2025-06-12 10:24 ` [PATCH 1/6] xfs: rename diff_two_keys routines Fedor Pchelkin
2025-06-12 10:24 ` [PATCH 2/6] xfs: rename key_diff routines Fedor Pchelkin
2025-06-12 10:24 ` [PATCH 3/6] xfs: refactor cmp_two_keys routines to take advantage of cmp_int() Fedor Pchelkin
2025-06-12 10:24 ` [PATCH 4/6] xfs: refactor cmp_key_with_cur " Fedor Pchelkin
2025-06-12 10:24 ` [PATCH 5/6] xfs: use a proper variable name and type for storing a comparison result Fedor Pchelkin
2025-06-12 10:24 ` [PATCH 6/6] xfs: refactor xfs_btree_diff_two_ptrs() to take advantage of cmp_int() Fedor Pchelkin
2025-07-01 14:53   ` Darrick J. Wong
2025-07-01 14:53 ` [PATCH 0/6] xfs: cleanup key comparing routines Darrick J. Wong

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox