Live Patching
 help / color / mirror / Atom feed
From: Song Liu <song@kernel.org>
To: live-patching@vger.kernel.org
Cc: jpoimboe@kernel.org, peterz@infradead.org, jikos@kernel.org,
	mbenes@suse.cz, pmladek@suse.com, joe.lawrence@redhat.com,
	puranjay@kernel.org, kernel-team@meta.com,
	Song Liu <song@kernel.org>
Subject: [PATCH v3 39/58] objtool/klp: Add test for static locals which must not be correlated
Date: Mon, 14 Sep 2026 16:03:36 -0700	[thread overview]
Message-ID: <20260914230355.3422996-40-song@kernel.org> (raw)
In-Reply-To: <20260914230355.3422996-1-song@kernel.org>

Most static locals have to be correlated so the patched code keeps using
the running kernel's copy.  Two kinds must not: anything in .data..once,
the flag behind WARN_ONCE and friends, and the well-known names the kernel
generates for per-instance things (__warned, __key, __func__).

Sharing a .data..once flag means a patch inherits "already warned" from
before it was applied, and the warning it was meant to surface never fires.

The fixture deliberately does not name its .data..once variable __warned:
the name rule would then catch it and the section rule would go untested.
gcc spells these <var>.<id> and Clang <func>.<var>, so both are covered.

This tests the behavior of commit ff529864e738 ("objtool/klp: Fix
.data..once static local non-correlation") and commit 84c304a534b8
("objtool/klp: Fix is_uncorrelated_static_local() for Clang").

Assisted-by: Claude:claude-opus-4
Based-on-test-by: Joe Lawrence <joe.lawrence@redhat.com>
Assisted-by: Claude:claude-opus-5
Signed-off-by: Song Liu <song@kernel.org>
---
 .../fixtures/static_local_uncorrelated.c      | 41 +++++++++++++++++++
 .../generic/test-static-local-uncorrelated.sh | 40 ++++++++++++++++++
 2 files changed, 81 insertions(+)
 create mode 100644 tools/objtool/tests/generic/fixtures/static_local_uncorrelated.c
 create mode 100755 tools/objtool/tests/generic/test-static-local-uncorrelated.sh

diff --git a/tools/objtool/tests/generic/fixtures/static_local_uncorrelated.c b/tools/objtool/tests/generic/fixtures/static_local_uncorrelated.c
new file mode 100644
index 000000000000..cb4cdd7a496e
--- /dev/null
+++ b/tools/objtool/tests/generic/fixtures/static_local_uncorrelated.c
@@ -0,0 +1,41 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * Static locals of three kinds, in one patched function.
+ *
+ * Most static locals must be correlated, so the patched code keeps using the
+ * running kernel's copy.  Two kinds must not:
+ *
+ *   - anything in .data..once, the flag behind WARN_ONCE and friends.  Sharing
+ *     it would mean a patch inherits "already warned" from before the patch.
+ *   - the well-known names the kernel generates for such things (__warned,
+ *     __key, __func__, ...), which are per-instance by nature.  gcc names them
+ *     <var>.<id> and Clang <func>.<var>, so both spellings have to be caught.
+ */
+
+static const char __modinfo[]
+	__attribute__((section(".modinfo"), used, aligned(1))) = "\0name=vmlinux";
+
+int target(int x)
+{
+	/*
+	 * A .data..once variable whose name is *not* on the list below, so
+	 * only the section can disqualify it.  Naming it __warned would let
+	 * the name rule catch it and the section rule go untested.
+	 */
+	static int once_flag __attribute__((section(".data..once")));
+	/* a never-correlate name, in an ordinary section */
+	static int __key;
+	/* and one that must be correlated */
+	static int ordinary;
+
+	if (!once_flag)
+		once_flag = 1;
+	__key += x;
+	ordinary += x;
+
+#ifdef PATCHED
+	return __key + ordinary + once_flag + 2;
+#else
+	return __key + ordinary + once_flag + 1;
+#endif
+}
diff --git a/tools/objtool/tests/generic/test-static-local-uncorrelated.sh b/tools/objtool/tests/generic/test-static-local-uncorrelated.sh
new file mode 100755
index 000000000000..fa4ce88a79b1
--- /dev/null
+++ b/tools/objtool/tests/generic/test-static-local-uncorrelated.sh
@@ -0,0 +1,40 @@
+#!/bin/bash
+# SPDX-License-Identifier: GPL-2.0
+#
+# Some static locals must not be correlated with their counterparts in the
+# running kernel; the patched code has to use a fresh copy instead.
+#
+# .data..once holds the "have we warned yet" flags behind WARN_ONCE.  Correlate
+# one and the patched function inherits the flag from before the patch, so the
+# warning the patch was written to produce never fires.  The same goes for the
+# names the kernel generates for per-instance state -- __warned, __key,
+# __func__ and friends.
+#
+# Both directions matter, so an ordinary static local is here too: a rule that
+# refuses to correlate anything would pass a test that only checks the
+# refusals.
+
+. "$(dirname "$0")/../lib.sh"
+
+setup
+build_pair static_local_uncorrelated.c
+run_diff
+
+# Compilers mangle static locals differently -- gcc gives __key.1, Clang
+# target.__key -- so match on the base name.
+
+# Correlated: referenced through a klp symbol, pointing at the kernel's copy.
+out_symbols | grep -q '\.klp\.sym\..*ordinary' ||
+	fail "ordinary static local was not correlated"
+
+# Not correlated: no klp symbol, and a copy cloned into the patch instead.
+out_symbols | grep -q '\.klp\.sym\..*__key' &&
+	fail "__key was correlated; it must use a fresh copy"
+out_sections | grep -qE '\.(bss|data)[^ ]*__key' ||
+	fail "__key was neither correlated nor cloned"
+
+out_symbols | grep -q '\.klp\.sym\..*once_flag' &&
+	fail ".data..once variable was correlated; it must use a fresh copy"
+assert_section '.data..once'
+
+pass "per-instance static locals cloned, ordinary ones correlated"
-- 
2.53.0-Meta


  parent reply	other threads:[~2026-09-14 23:07 UTC|newest]

Thread overview: 82+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-14 23:02 [PATCH v3 00/58] Unit test framework for klp-build toolchain Song Liu
2026-09-14 23:02 ` [PATCH v3 01/58] objtool: Add test harness for the klp subcommands Song Liu
2026-09-14 23:28   ` sashiko-bot
2026-09-15 18:26     ` Song Liu
2026-09-14 23:02 ` [PATCH v3 02/58] objtool/klp: Check the klp test environment once, before any test Song Liu
2026-09-14 23:03 ` [PATCH v3 03/58] objtool/klp: Group the klp tests by architecture Song Liu
2026-09-14 23:03 ` [PATCH v3 04/58] objtool/klp: Classify klp test outcomes Song Liu
2026-09-14 23:03 ` [PATCH v3 05/58] objtool/klp: Build klp test fixtures through the harness Song Liu
2026-09-14 23:34   ` sashiko-bot
2026-09-15 19:26     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 06/58] objtool/klp: Grow the klp test harness vocabulary Song Liu
2026-09-14 23:35   ` sashiko-bot
2026-09-15 20:30     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 07/58] objtool/klp: Give each run one working directory, one per test inside it Song Liu
2026-09-14 23:34   ` sashiko-bot
2026-09-15 20:51     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 08/58] objtool/klp: Run the klp tests under set -u Song Liu
2026-09-14 23:03 ` [PATCH v3 09/58] objtool/klp: Document the klp test harness Song Liu
2026-09-14 23:03 ` [PATCH v3 10/58] objtool: Keep failing test workdirs by default Song Liu
2026-09-14 23:41   ` sashiko-bot
2026-09-15 20:56     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 11/58] objtool: Forward toolchain variables to the klp test runner Song Liu
2026-09-14 23:45   ` sashiko-bot
2026-09-15 21:04     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 12/58] objtool/klp: Add test for rejecting changed data Song Liu
2026-09-14 23:03 ` [PATCH v3 13/58] objtool/klp: Add test for newly introduced data Song Liu
2026-09-14 23:03 ` [PATCH v3 14/58] objtool/klp: Add test for newly introduced functions Song Liu
2026-09-14 23:46   ` sashiko-bot
2026-09-15 21:56     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 15/58] objtool/klp: Add test for static local correlation Song Liu
2026-09-14 23:03 ` [PATCH v3 16/58] objtool/klp: Add test for cold function halves Song Liu
2026-09-14 23:03 ` [PATCH v3 17/58] objtool/klp: Add test for special section extraction Song Liu
2026-09-14 23:03 ` [PATCH v3 18/58] objtool/klp: Add test for selective " Song Liu
2026-09-14 23:03 ` [PATCH v3 19/58] objtool/klp: Add test for jump table key relocations Song Liu
2026-09-14 23:03 ` [PATCH v3 20/58] objtool/klp: Add test for rejecting module-owned static branch keys Song Liu
2026-09-14 23:03 ` [PATCH v3 21/58] objtool/klp: Add test for rejecting module-owned static call keys Song Liu
2026-09-15  0:05   ` sashiko-bot
2026-09-15 21:51     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 22/58] objtool/klp: Add test for symids in discarded sections Song Liu
2026-09-14 23:03 ` [PATCH v3 23/58] objtool/klp: Add test for rejecting references to init code/data Song Liu
2026-09-15  0:07   ` sashiko-bot
2026-09-15 23:11     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 24/58] objtool/klp: Add test for correlation across ThinLTO name mangling Song Liu
2026-09-14 23:03 ` [PATCH v3 25/58] objtool/klp: Add test for objects without .modinfo Song Liu
2026-09-14 23:03 ` [PATCH v3 26/58] objtool/klp: Add test for unchecksummed input Song Liu
2026-09-14 23:03 ` [PATCH v3 27/58] objtool/klp: Add klp diff and post-link regression tests Song Liu
2026-09-14 23:03 ` [PATCH v3 28/58] objtool/klp: Add test for klp reloc section naming in module objects Song Liu
2026-09-14 23:03 ` [PATCH v3 29/58] objtool/klp: Add test for vmlinux relocs in a patched module Song Liu
2026-09-14 23:03 ` [PATCH v3 30/58] objtool/klp: Add test for Module.symvers path normalization Song Liu
2026-09-14 23:03 ` [PATCH v3 31/58] objtool/klp: Add test for the contents of the klp_funcs list Song Liu
2026-09-14 23:03 ` [PATCH v3 32/58] objtool/klp: Add test for EXPORT_SYMBOL_FOR_MODULES references Song Liu
2026-09-14 23:03 ` [PATCH v3 33/58] objtool/klp: Add test for new references to exported symbols Song Liu
2026-09-14 23:03 ` [PATCH v3 34/58] objtool/klp: Add test for empty x86 alternative replacements Song Liu
2026-09-14 23:03 ` [PATCH v3 35/58] objtool/klp: Add test for recorded checksum values Song Liu
2026-09-14 23:03 ` [PATCH v3 36/58] objtool/klp: Add test for position-independent checksums Song Liu
2026-09-14 23:03 ` [PATCH v3 37/58] objtool/klp: Add test for sympos in module objects Song Liu
2026-09-14 23:03 ` [PATCH v3 38/58] objtool/klp: Add test for sympos resolved against a linked vmlinux Song Liu
2026-09-14 23:03 ` Song Liu [this message]
2026-09-14 23:03 ` [PATCH v3 40/58] objtool/klp: Add test for __bug_table, __ex_table and __mcount_loc extraction Song Liu
2026-09-15  0:26   ` sashiko-bot
2026-09-15 23:27     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 41/58] objtool/klp: Add test for kCFI prefix symbols and traps Song Liu
2026-09-14 23:03 ` [PATCH v3 42/58] objtool/klp: Add test for symbols whose linkage the patch changes Song Liu
2026-09-14 23:03 ` [PATCH v3 43/58] objtool/klp: Test rejection of a file-local static branch key Song Liu
2026-09-14 23:03 ` [PATCH v3 44/58] objtool/klp: Test a hand-built livepatch module's static call keys Song Liu
2026-09-14 23:03 ` [PATCH v3 45/58] objtool/klp: Test text annotations on alternative replacements Song Liu
2026-09-14 23:03 ` [PATCH v3 46/58] objtool/klp: Add test for data object checksums Song Liu
2026-09-14 23:03 ` [PATCH v3 47/58] objtool/klp: Add test for symbols with no checksum entry of their own Song Liu
2026-09-14 23:03 ` [PATCH v3 48/58] objtool/klp: Add test for a static branch introduced by the patch Song Liu
2026-09-14 23:03 ` [PATCH v3 49/58] objtool/klp: Add test for tracepoint and pr_debug static branch keys Song Liu
2026-09-15  0:32   ` sashiko-bot
2026-09-14 23:03 ` [PATCH v3 50/58] objtool/klp: Add test for a static call introduced by the patch Song Liu
2026-09-14 23:03 ` [PATCH v3 51/58] objtool/klp: Add test for instruction operand checksums Song Liu
2026-09-14 23:03 ` [PATCH v3 52/58] objtool/klp: Add test for alternative replacement code in checksums Song Liu
2026-09-14 23:03 ` [PATCH v3 53/58] objtool/klp: Add test for the alignment of cloned data sections Song Liu
2026-09-14 23:03 ` [PATCH v3 54/58] objtool/klp: Add test for a patch which strips a data annotation Song Liu
2026-09-14 23:03 ` [PATCH v3 55/58] objtool/klp: Add test for absolute and __ADDRESSABLE symbols Song Liu
2026-09-15  0:53   ` sashiko-bot
2026-09-15 23:29     ` Song Liu
2026-09-14 23:03 ` [PATCH v3 56/58] objtool/klp: Add test for UBSAN metadata in an unchanged function Song Liu
2026-09-14 23:03 ` [PATCH v3 57/58] objtool/klp: Add test for Clang switch jump tables Song Liu
2026-09-14 23:03 ` [PATCH v3 58/58] objtool/klp: Add test for ThinLTO symbols sharing a demangled name Song Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260914230355.3422996-40-song@kernel.org \
    --to=song@kernel.org \
    --cc=jikos@kernel.org \
    --cc=joe.lawrence@redhat.com \
    --cc=jpoimboe@kernel.org \
    --cc=kernel-team@meta.com \
    --cc=live-patching@vger.kernel.org \
    --cc=mbenes@suse.cz \
    --cc=peterz@infradead.org \
    --cc=pmladek@suse.com \
    --cc=puranjay@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox