The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Hannes Reinecke <hare@suse.de>
To: Daniel Wagner <wagi@kernel.org>,
	James Smart <james.smart@broadcom.com>,
	Christoph Hellwig <hch@lst.de>, Sagi Grimberg <sagi@grimberg.me>,
	Chaitanya Kulkarni <kch@nvidia.com>
Cc: Keith Busch <kbusch@kernel.org>,
	linux-nvme@lists.infradead.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 08/14] nvmet-fcloop: prevent double port deletion
Date: Thu, 24 Apr 2025 12:17:32 +0200	[thread overview]
Message-ID: <10fec246-82a6-40bf-a522-ea3de7fa0624@suse.de> (raw)
In-Reply-To: <20250423-nvmet-fcloop-v5-8-3d7f968728a5@kernel.org>

On 4/23/25 15:21, Daniel Wagner wrote:
> The delete callback can be called either via the unregister function or
> from the transport directly. Thus it is necessary ensure resources are
> not freed multiple times.
> 
> Signed-off-by: Daniel Wagner <wagi@kernel.org>
> ---
>   drivers/nvme/target/fcloop.c | 19 +++++++++++++++++++
>   1 file changed, 19 insertions(+)
> 
> diff --git a/drivers/nvme/target/fcloop.c b/drivers/nvme/target/fcloop.c
> index 9adaee3c7129f7e270842c5d09f78de2e108479a..014cc66f92cb1db0a81a79d2109eae3fff5fd38a 100644
> --- a/drivers/nvme/target/fcloop.c
> +++ b/drivers/nvme/target/fcloop.c
> @@ -215,6 +215,9 @@ struct fcloop_lport_priv {
>   	struct fcloop_lport *lport;
>   };
>   
> +/* The port is already being removed, avoid double free */
> +#define PORT_DELETED	0
> +
>   struct fcloop_rport {
>   	struct nvme_fc_remote_port	*remoteport;
>   	struct nvmet_fc_target_port	*targetport;
> @@ -223,6 +226,7 @@ struct fcloop_rport {
>   	spinlock_t			lock;
>   	struct list_head		ls_list;
>   	struct work_struct		ls_work;
> +	unsigned long			flags;
>   };
>   
>   struct fcloop_tport {
> @@ -233,6 +237,7 @@ struct fcloop_tport {
>   	spinlock_t			lock;
>   	struct list_head		ls_list;
>   	struct work_struct		ls_work;
> +	unsigned long			flags;
>   };
>   
>   struct fcloop_nport {
> @@ -1067,14 +1072,20 @@ static void
>   fcloop_remoteport_delete(struct nvme_fc_remote_port *remoteport)
>   {
>   	struct fcloop_rport *rport = remoteport->private;
> +	bool delete_port = true;
>   	unsigned long flags;
>   
>   	flush_work(&rport->ls_work);
>   
>   	spin_lock_irqsave(&fcloop_lock, flags);
> +	if (test_and_set_bit(PORT_DELETED, &rport->flags))
> +		delete_port = false;
>   	rport->nport->rport = NULL;
>   	spin_unlock_irqrestore(&fcloop_lock, flags);
>   
> +	if (!delete_port)
> +		return;
> +

The double negation is hard to follow. Can't you
rename it to 'put_port' or somesuch and invert the logic?

>   	fcloop_nport_put(rport->nport);
>   }
>   
> @@ -1082,14 +1093,20 @@ static void
>   fcloop_targetport_delete(struct nvmet_fc_target_port *targetport)
>   {
>   	struct fcloop_tport *tport = targetport->private;
> +	bool delete_port = true;
>   	unsigned long flags;
>   
>   	flush_work(&tport->ls_work);
>   
>   	spin_lock_irqsave(&fcloop_lock, flags);
> +	if (test_and_set_bit(PORT_DELETED, &tport->flags))
> +		delete_port = false;
>   	tport->nport->tport = NULL;
>   	spin_unlock_irqrestore(&fcloop_lock, flags);
>   
> +	if (!delete_port)
> +		return;
> +
Same here.

>   	fcloop_nport_put(tport->nport);
>   }
>   
> @@ -1433,6 +1450,7 @@ fcloop_create_remote_port(struct device *dev, struct device_attribute *attr,
>   	rport->nport = nport;
>   	rport->lport = nport->lport;
>   	nport->rport = rport;
> +	rport->flags = 0;
>   	spin_lock_init(&rport->lock);
>   	INIT_WORK(&rport->ls_work, fcloop_rport_lsrqst_work);
>   	INIT_LIST_HEAD(&rport->ls_list);
> @@ -1530,6 +1548,7 @@ fcloop_create_target_port(struct device *dev, struct device_attribute *attr,
>   	tport->nport = nport;
>   	tport->lport = nport->lport;
>   	nport->tport = tport;
> +	tport->flags = 0;
>   	spin_lock_init(&tport->lock);
>   	INIT_WORK(&tport->ls_work, fcloop_tport_lsrqst_work);
>   	INIT_LIST_HEAD(&tport->ls_list);
> 
Cheers,

Hannes
-- 
Dr. Hannes Reinecke                  Kernel Storage Architect
hare@suse.de                                +49 911 74053 688
SUSE Software Solutions GmbH, Frankenstr. 146, 90461 Nürnberg
HRB 36809 (AG Nürnberg), GF: I. Totev, A. McDonald, W. Knoblich

  reply	other threads:[~2025-04-24 10:17 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-23 13:21 [PATCH v5 00/14] nvmet-fcloop: track resources via reference counting Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 01/14] nvmet-fcloop: track ref counts for nports Daniel Wagner
2025-04-24 10:08   ` Hannes Reinecke
2025-04-24 11:13     ` Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 02/14] nvmet-fcloop: remove nport from list on last user Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 03/14] nvmet-fcloop: refactor fcloop_nport_alloc and track lport Daniel Wagner
2025-04-24 10:09   ` Hannes Reinecke
2025-04-23 13:21 ` [PATCH v5 04/14] nvmet-fcloop: refactor fcloop_delete_local_port Daniel Wagner
2025-04-24 10:10   ` Hannes Reinecke
2025-04-24 11:16     ` Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 05/14] nvmet-fcloop: update refs on tfcp_req Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 06/14] nvmet-fcloop: add missing fcloop_callback_host_done Daniel Wagner
2025-04-24 10:13   ` Hannes Reinecke
2025-04-24 11:26     ` Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 07/14] nvmet-fcloop: access fcpreq only when holding reqlock Daniel Wagner
2025-04-24 10:15   ` Hannes Reinecke
2025-04-24 11:31     ` Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 08/14] nvmet-fcloop: prevent double port deletion Daniel Wagner
2025-04-24 10:17   ` Hannes Reinecke [this message]
2025-04-24 11:32     ` Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 09/14] nvmet-fcloop: allocate/free fcloop_lsreq directly Daniel Wagner
2025-04-24 10:18   ` Hannes Reinecke
2025-05-07 10:48   ` kernel test robot
2025-04-23 13:21 ` [PATCH v5 10/14] nvmet-fcloop: don't wait for lport cleanup Daniel Wagner
2025-04-24 10:21   ` Hannes Reinecke
2025-04-24 11:48     ` Daniel Wagner
2025-04-24 12:10       ` Hannes Reinecke
2025-04-24 12:58         ` Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 11/14] nvmet-fcloop: drop response if targetport is gone Daniel Wagner
2025-04-24 10:21   ` Hannes Reinecke
2025-04-23 13:21 ` [PATCH v5 12/14] nvmet-fc: free pending reqs on tgtport unregister Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 13/14] nvmet-fc: take tgtport refs for portentry Daniel Wagner
2025-04-23 13:21 ` [PATCH v5 14/14] nvme-fc: do not reference lsrsp after failure Daniel Wagner
2025-05-06 16:36 ` [PATCH v5 00/14] nvmet-fcloop: track resources via reference counting Daniel Wagner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=10fec246-82a6-40bf-a522-ea3de7fa0624@suse.de \
    --to=hare@suse.de \
    --cc=hch@lst.de \
    --cc=james.smart@broadcom.com \
    --cc=kbusch@kernel.org \
    --cc=kch@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvme@lists.infradead.org \
    --cc=sagi@grimberg.me \
    --cc=wagi@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox