The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: "Jovi Zhang" <bookjovi@gmail.com>,
	"Frédéric Weisbecker" <fweisbec@gmail.com>,
	"Ingo Molnar" <mingo@redhat.com>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ftrace: using pr_fmt for better printk output
Date: Mon, 16 Jul 2012 22:07:33 -0700	[thread overview]
Message-ID: <1342501653.8377.123.camel@joe2Laptop> (raw)
In-Reply-To: <1342499125.24525.11.camel@gandalf.stny.rr.com>

On Tue, 2012-07-17 at 00:25 -0400, Steven Rostedt wrote:
> On Mon, 2012-07-16 at 20:42 -0700, Joe Perches wrote:
> 
> > > diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
> > []
> > > @@ -13,6 +13,8 @@
> > >   *  Copyright (C) 2004 William Lee Irwin III
> > >   */
> > > 
> > > +#define pr_fmt(fmt) "ftrace: " fmt
> > 
> > #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
> 
> Wouldn't a nicer patch be to move this into a header file and then
> remove all the defines throughout the kernel tree?

Maybe.  There are modules that use common header files
like you suggest.  It does mean that header must be the
#included before any other #include that might
#include <linux/kernel.h> or printk.h.

Right now, if pr_fmt isn't #defined, printk.h
has a default definition of:

#ifndef pr_fmt
#define pr_fmt(fmt) fmt
#endif

My goal is to change that to:

#ifndef pr_fmt
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
#endif

in 3.8 (maybe 3.7) and remove all of these then
useless, duplicate #defines shortly afterward.

https://lkml.org/lkml/2012/3/27/247

> Also, what is KBUILD_MODNAME defined as for non-modules? As ftrace is
> not a module.

It depends on the Makefile.

scripts/Makefile.lib:# $(modname_flags) #defines KBUILD_MODNAME as the name of the module it will 
scripts/Makefile.lib-# end up in (or would, if it gets compiled in)
scripts/Makefile.lib-# Note: Files that end up in two or more modules are compiled without the
scripts/Makefile.lib:#       KBUILD_MODNAME definition. The reason is that any made-up name would
scripts/Makefile.lib-#       differ in different configs.
scripts/Makefile.lib-name-fix = $(subst $(comma),_,$(subst -,_,$1))
scripts/Makefile.lib-basename_flags = -D"KBUILD_BASENAME=KBUILD_STR($(call name-fix,$(basetarget)))"
scripts/Makefile.lib-modname_flags  = $(if $(filter 1,$(words $(modname))),\
scripts/Makefile.lib:                 -D"KBUILD_MODNAME=KBUILD_STR($(call name-fix,$(modname)))")



  reply	other threads:[~2012-07-17  5:07 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-17  1:15 [PATCH] ftrace: using pr_fmt for better printk output Jovi Zhang
2012-07-17  3:42 ` Joe Perches
2012-07-17  4:25   ` Steven Rostedt
2012-07-17  5:07     ` Joe Perches [this message]
2012-07-17  5:32       ` Jovi Zhang
2012-07-17  5:37         ` Joe Perches
2012-07-17  6:47           ` Jovi Zhang
2012-07-17  5:23     ` Jovi Zhang
2012-07-17  5:27       ` Joe Perches
2012-07-17  5:29       ` Joe Perches

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1342501653.8377.123.camel@joe2Laptop \
    --to=joe@perches.com \
    --cc=bookjovi@gmail.com \
    --cc=fweisbec@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox