From: Joe Perches <joe@perches.com>
To: Jovi Zhang <bookjovi@gmail.com>
Cc: "Steven Rostedt" <rostedt@goodmis.org>,
"Frédéric Weisbecker" <fweisbec@gmail.com>,
"Ingo Molnar" <mingo@redhat.com>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ftrace: using pr_fmt for better printk output
Date: Mon, 16 Jul 2012 22:37:35 -0700 [thread overview]
Message-ID: <1342503455.8377.127.camel@joe2Laptop> (raw)
In-Reply-To: <CACV3sb+H_tLDw=d1pjR5znVZSst+DqJ08p4eBTRcsKhzqsgnwg@mail.gmail.com>
On Tue, 2012-07-17 at 13:32 +0800, Jovi Zhang wrote:
> On Tue, Jul 17, 2012 at 1:07 PM, Joe Perches <joe@perches.com> wrote:
> > On Tue, 2012-07-17 at 00:25 -0400, Steven Rostedt wrote:
[]
> >> Also, what is KBUILD_MODNAME defined as for non-modules? As ftrace is
> >> not a module.
> >
> > It depends on the Makefile.
> >
> > scripts/Makefile.lib:# $(modname_flags) #defines KBUILD_MODNAME as the name of the module it will
> > scripts/Makefile.lib-# end up in (or would, if it gets compiled in)
> > scripts/Makefile.lib-# Note: Files that end up in two or more modules are compiled without the
> > scripts/Makefile.lib:# KBUILD_MODNAME definition. The reason is that any made-up name would
> > scripts/Makefile.lib-# differ in different configs.
> > scripts/Makefile.lib-name-fix = $(subst $(comma),_,$(subst -,_,$1))
> > scripts/Makefile.lib-basename_flags = -D"KBUILD_BASENAME=KBUILD_STR($(call name-fix,$(basetarget)))"
> > scripts/Makefile.lib-modname_flags = $(if $(filter 1,$(words $(modname))),\
> > scripts/Makefile.lib: -D"KBUILD_MODNAME=KBUILD_STR($(call name-fix,$(modname)))")
> >
> Hmm, that would make sense, get subsystem name from Makefile.
>
> Joe, there will delete all this pr_fmt definition in .c file in 3.8(or
> 3.7) as you metioned, so we can ingnore this patch.
Not quite. The uses that have embedded prefixes need updating.
You've done that in bits of this patch.
next prev parent reply other threads:[~2012-07-17 5:37 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-07-17 1:15 [PATCH] ftrace: using pr_fmt for better printk output Jovi Zhang
2012-07-17 3:42 ` Joe Perches
2012-07-17 4:25 ` Steven Rostedt
2012-07-17 5:07 ` Joe Perches
2012-07-17 5:32 ` Jovi Zhang
2012-07-17 5:37 ` Joe Perches [this message]
2012-07-17 6:47 ` Jovi Zhang
2012-07-17 5:23 ` Jovi Zhang
2012-07-17 5:27 ` Joe Perches
2012-07-17 5:29 ` Joe Perches
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1342503455.8377.127.camel@joe2Laptop \
--to=joe@perches.com \
--cc=bookjovi@gmail.com \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox