The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Valentin Rothberg <valentinrothberg@gmail.com>
To: Randy Dunlap <rdunlap@infradead.org>
Cc: akpm@linux-foundation.org, linux-kernel@vger.kernel.org,
	pebolle@tiscali.nl
Subject: Re: [PATCH] lib: rename TEST_MODULE to TEST_LKM
Date: Tue, 23 Sep 2014 20:27:02 +0200	[thread overview]
Message-ID: <1411496822.31476.1.camel@nebuchadnezzar> (raw)
In-Reply-To: <5421A9D5.8020503@infradead.org>

On mar., 2014-09-23 at 10:11 -0700, Randy Dunlap wrote:
> On 09/23/14 10:10, Valentin Rothberg wrote:
> > On mar., 2014-09-23 at 09:49 -0700, Randy Dunlap wrote:
> >> On 09/22/14 23:58, Valentin Rothberg wrote:
> >>> The "_MODULE" suffix is reserved for tristates compiled as
> >>> loadable kernel modules (LKM). The "TEST_MODULE" feature thereby
> >>
> >> Is that documented anywhere?
> > 
> > Sadly this is not made explicit, but the Kconfig code documents it. The
> > following code (./scripts/kconfig/confdata.c) is used to generate the
> > autoconf.h header file during the build process. When a feature is
> > selected as a kernel module ('m'), it is suffixed with "_MODULE" to
> > indicate it. 
> > 
> > »   »   switch (*value) {
> > »   »   case 'n':
> > »   »   »   break;
> > »   »   case 'm':
> > »   »   »   suffix = "_MODULE";
> > »   »   »   /* fall through */
> > 
> >> Was this causing some kind of problem or error?  Please tell us what that was if so.
> > 
> > It causes problems for static code analysis, which assumes a consistent
> > use of the "_MODULE" suffix. 
> > 
> > Another possible change would be to rename the reference in the Makefile
> > to "TEST_MODULE_MODULE". Personally, I prefer my proposed patch.
> 
> Sure, your patch is fine, but we need to know *why* the patch is needed.

Thank you for pointing that out. I will take care to give more
information in future patches.

Thanks,
 Valentin

> Thanks.
> 
> >>
> >>
> >>> violates this convention. The feature is used to compile the
> >>> lib/test_module.c kernel module.
> >>>
> >>> This patch renames the feature and its reference in a Makefile
> >>> to "TEST_LKM", which still expresses the test of a LKM.
> >>>
> >>> Signed-off-by: Valentin Rothberg <valentinrothberg@gmail.com>
> >>> ---
> >>>  lib/Kconfig.debug | 2 +-
> >>>  lib/Makefile      | 2 +-
> >>>  2 files changed, 2 insertions(+), 2 deletions(-)
> >>>
> >>> diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
> >>> index 07c2832..db91c97 100644
> >>> --- a/lib/Kconfig.debug
> >>> +++ b/lib/Kconfig.debug
> >>> @@ -1627,7 +1627,7 @@ config DMA_API_DEBUG
> >>>  
> >>>  	  If unsure, say N.
> >>>  
> >>> -config TEST_MODULE
> >>> +config TEST_LKM
> >>>  	tristate "Test module loading with 'hello world' module"
> >>>  	default n
> >>>  	depends on m
> >>> diff --git a/lib/Makefile b/lib/Makefile
> >>> index d6b4bc4..382437a 100644
> >>> --- a/lib/Makefile
> >>> +++ b/lib/Makefile
> >>> @@ -31,7 +31,7 @@ obj-y += string_helpers.o
> >>>  obj-$(CONFIG_TEST_STRING_HELPERS) += test-string_helpers.o
> >>>  obj-y += kstrtox.o
> >>>  obj-$(CONFIG_TEST_KSTRTOX) += test-kstrtox.o
> >>> -obj-$(CONFIG_TEST_MODULE) += test_module.o
> >>> +obj-$(CONFIG_TEST_LKM) += test_module.o
> >>>  obj-$(CONFIG_TEST_USER_COPY) += test_user_copy.o
> >>>  obj-$(CONFIG_TEST_BPF) += test_bpf.o
> >>>  obj-$(CONFIG_TEST_FIRMWARE) += test_firmware.o
> 
> 



  reply	other threads:[~2014-09-23 18:27 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-23  6:58 [PATCH] lib: rename TEST_MODULE to TEST_LKM Valentin Rothberg
2014-09-23 16:49 ` Randy Dunlap
2014-09-23 17:10   ` Valentin Rothberg
2014-09-23 17:11     ` Randy Dunlap
2014-09-23 18:27       ` Valentin Rothberg [this message]
2014-09-29 20:18         ` Paul Bolle
2014-09-29 20:25           ` Valentin Rothberg
2014-09-29 20:36             ` Paul Bolle
2014-09-29 21:02               ` Kees Cook
2014-09-29 21:05             ` Kees Cook

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1411496822.31476.1.camel@nebuchadnezzar \
    --to=valentinrothberg@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pebolle@tiscali.nl \
    --cc=rdunlap@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox