From: Christoph Hellwig <hch@infradead.org>
To: Andrew Morton <akpm@osdl.org>
Cc: "Robert P. J. Day" <rpjday@mindspring.com>,
Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: [RFC][PATCH] Rewrite unnecessary duplicated code to use FIELD_SIZEOF().
Date: Fri, 22 Dec 2006 14:05:51 +0000 [thread overview]
Message-ID: <20061222140550.GB26033@infradead.org> (raw)
In-Reply-To: <20061220164651.4ee2e960.akpm@osdl.org>
On Wed, Dec 20, 2006 at 04:46:51PM -0800, Andrew Morton wrote:
> On Sun, 17 Dec 2006 07:43:39 -0500 (EST)
> "Robert P. J. Day" <rpjday@mindspring.com> wrote:
>
> > as with ARRAY_SIZE(), there are a number of places (mercifully, far
> > fewer) that recode what could be done with the FIELD_SIZEOF() macro in
> > kernel.h.
Who introduced FIELD_SIZEOF? The name is the wrong way around, it should
either be SIZEOF_FIELD if you want the SIZEOF part of FIELD_SIZE if you
want to follow the ARRAY_SIZE example/
next prev parent reply other threads:[~2006-12-22 14:05 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-12-17 12:43 [RFC][PATCH] Rewrite unnecessary duplicated code to use FIELD_SIZEOF() Robert P. J. Day
2006-12-21 0:46 ` Andrew Morton
2006-12-22 14:05 ` Christoph Hellwig [this message]
2006-12-22 14:43 ` Robert P. J. Day
2006-12-22 23:19 ` Jan Engelhardt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20061222140550.GB26033@infradead.org \
--to=hch@infradead.org \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rpjday@mindspring.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox