From: "Robert P. J. Day" <rpjday@mindspring.com>
To: Christoph Hellwig <hch@infradead.org>
Cc: Andrew Morton <akpm@osdl.org>,
Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: [RFC][PATCH] Rewrite unnecessary duplicated code to use FIELD_SIZEOF().
Date: Fri, 22 Dec 2006 09:43:31 -0500 (EST) [thread overview]
Message-ID: <Pine.LNX.4.64.0612220942140.2047@localhost.localdomain> (raw)
In-Reply-To: <20061222140550.GB26033@infradead.org>
On Fri, 22 Dec 2006, Christoph Hellwig wrote:
> On Wed, Dec 20, 2006 at 04:46:51PM -0800, Andrew Morton wrote:
> > On Sun, 17 Dec 2006 07:43:39 -0500 (EST)
> > "Robert P. J. Day" <rpjday@mindspring.com> wrote:
> >
> > > as with ARRAY_SIZE(), there are a number of places (mercifully, far
> > > fewer) that recode what could be done with the FIELD_SIZEOF() macro in
> > > kernel.h.
>
> Who introduced FIELD_SIZEOF? The name is the wrong way around, it
> should either be SIZEOF_FIELD if you want the SIZEOF part of
> FIELD_SIZE if you want to follow the ARRAY_SIZE example/
that's the name as it *already* existed in kernel.h. however, since
no one was actually using it yet, it's a piece of cake to give it a
better name. either FIELD_SIZE or MEMBER_SIZE would work just fine.
rday
next prev parent reply other threads:[~2006-12-22 14:52 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-12-17 12:43 [RFC][PATCH] Rewrite unnecessary duplicated code to use FIELD_SIZEOF() Robert P. J. Day
2006-12-21 0:46 ` Andrew Morton
2006-12-22 14:05 ` Christoph Hellwig
2006-12-22 14:43 ` Robert P. J. Day [this message]
2006-12-22 23:19 ` Jan Engelhardt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.0612220942140.2047@localhost.localdomain \
--to=rpjday@mindspring.com \
--cc=akpm@osdl.org \
--cc=hch@infradead.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox