* [2.6 patch] make tuner-core.c:tuner_list static
@ 2008-01-28 22:11 Adrian Bunk
0 siblings, 0 replies; only message in thread
From: Adrian Bunk @ 2008-01-28 22:11 UTC (permalink / raw)
To: Hans Verkuil, Mauro Carvalho Chehab; +Cc: v4l-dvb-maintainer, linux-kernel
tuner_list can become static - and it's anyway a way too generic name
for a global variable - see commit b00ef4b8d8c29bfb5f6f92ee60bc04b604f36ef2
for a completely different global variable of the same name I just made
static...
Signed-off-by: Adrian Bunk <bunk@kernel.org>
---
5cfd60a0b711973033b2acbed08e8696e126016f
diff --git a/drivers/media/video/tuner-core.c b/drivers/media/video/tuner-core.c
index ba538f6..78a09a2 100644
--- a/drivers/media/video/tuner-core.c
+++ b/drivers/media/video/tuner-core.c
@@ -1038,7 +1038,7 @@ static int tuner_resume(struct i2c_client *c)
/* ---------------------------------------------------------------------- */
-LIST_HEAD(tuner_list);
+static LIST_HEAD(tuner_list);
/* Search for existing radio and/or TV tuners on the given I2C adapter.
Note that when this function is called from tuner_probe you can be
^ permalink raw reply related [flat|nested] only message in thread
only message in thread, other threads:[~2008-01-28 22:14 UTC | newest]
Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2008-01-28 22:11 [2.6 patch] make tuner-core.c:tuner_list static Adrian Bunk
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox