From: Borislav Petkov <bp@alien8.de>
To: Daniel J Blueman <daniel@numascale-asia.com>
Cc: Ingo Molnar <mingo@redhat.com>,
Thomas Gleixner <tglx@linutronix.de>,
H Peter Anvin <hpa@zytor.com>,
Steffen Persvold <sp@numascale.com>,
x86@kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/4] AMD64 EDAC: Use appropriate name for NB indexing
Date: Wed, 31 Oct 2012 20:39:48 +0100 [thread overview]
Message-ID: <20121031193948.GM24389@liondog.tnic> (raw)
In-Reply-To: <1351662932-22279-4-git-send-email-daniel@numascale-asia.com>
On Wed, Oct 31, 2012 at 01:55:32PM +0800, Daniel J Blueman wrote:
> Use the same 'amd' prefix as related functions for clarity.
>
> Signed-off-by: Daniel J Blueman <daniel@numascale-asia.com>
> ---
> arch/x86/include/asm/amd_nb.h | 2 +-
> drivers/edac/amd64_edac.c | 6 +++---
> 2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/arch/x86/include/asm/amd_nb.h b/arch/x86/include/asm/amd_nb.h
> index 0cc1045..39b5ddd 100644
> --- a/arch/x86/include/asm/amd_nb.h
> +++ b/arch/x86/include/asm/amd_nb.h
> @@ -81,7 +81,7 @@ static inline struct amd_northbridge *node_to_amd_nb(u16 node)
> return (node < amd_northbridges.num) ? &amd_northbridges.nb[node] : NULL;
> }
>
> -static inline u16 get_node_id(struct pci_dev *pdev)
> +static inline u16 amd_get_node_id(struct pci_dev *pdev)
> {
> int i;
>
> diff --git a/drivers/edac/amd64_edac.c b/drivers/edac/amd64_edac.c
> index 12cd675..59658b9 100644
> --- a/drivers/edac/amd64_edac.c
> +++ b/drivers/edac/amd64_edac.c
> @@ -2558,7 +2558,7 @@ static int amd64_init_one_instance(struct pci_dev *F2)
> struct mem_ctl_info *mci = NULL;
> struct edac_mc_layer layers[2];
> int err = 0, ret;
> - u16 nid = get_node_id(F2);
> + u16 nid = amd_get_node_id(F2);
>
> ret = -ENOMEM;
> pvt = kzalloc(sizeof(struct amd64_pvt), GFP_KERNEL);
> @@ -2649,7 +2649,7 @@ err_ret:
> static int __devinit amd64_probe_one_instance(struct pci_dev *pdev,
> const struct pci_device_id *mc_type)
> {
> - u16 nid = get_node_id(pdev);
> + u16 nid = amd_get_node_id(pdev);
> struct pci_dev *F3 = node_to_amd_nb(nid)->misc;
> struct ecc_settings *s;
> int ret = 0;
> @@ -2699,7 +2699,7 @@ static void __devexit amd64_remove_one_instance(struct pci_dev *pdev)
> {
> struct mem_ctl_info *mci;
> struct amd64_pvt *pvt;
> - u16 nid = get_node_id(pdev);
> + u16 nid = amd_get_node_id(pdev);
> struct pci_dev *F3 = node_to_amd_nb(nid)->misc;
> struct ecc_settings *s = ecc_stngs[nid];
Yeah, you can fold that change into 1/4, actually.
Thanks.
--
Regards/Gruss,
Boris.
next prev parent reply other threads:[~2012-10-31 19:39 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-31 5:55 [PATCH 1/4, v4] AMD64 EDAC: Add multi-domain support to AMD EDAC Daniel J Blueman
2012-10-31 5:55 ` [PATCH 2/4] AMD64 EDAC: Add support for >255 memory controllers Daniel J Blueman
2012-10-31 8:18 ` Torsten Kaiser
2012-10-31 8:20 ` Daniel J Blueman
2012-10-31 8:48 ` [PATCH 2/4, v2] " Daniel J Blueman
2012-10-31 18:55 ` Borislav Petkov
2012-10-31 5:55 ` [PATCH 3/4] AMD64 EDAC: Cleanup type usage to be consistent Daniel J Blueman
2012-10-31 19:38 ` Borislav Petkov
2012-10-31 5:55 ` [PATCH 4/4] AMD64 EDAC: Use appropriate name for NB indexing Daniel J Blueman
2012-10-31 19:39 ` Borislav Petkov [this message]
2012-10-31 12:03 ` [PATCH 1/4, v4] AMD64 EDAC: Add multi-domain support to AMD EDAC Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20121031193948.GM24389@liondog.tnic \
--to=bp@alien8.de \
--cc=daniel@numascale-asia.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=sp@numascale.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox