The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [RFC PATCH 0/7] preempt: A few headers cleanups and preempt_schedule*() optimizations
@ 2015-05-11 15:08 Frederic Weisbecker
  2015-05-11 15:08 ` [PATCH 1/7] preempt: Merge preempt_mask.h into preempt.h Frederic Weisbecker
                   ` (6 more replies)
  0 siblings, 7 replies; 11+ messages in thread
From: Frederic Weisbecker @ 2015-05-11 15:08 UTC (permalink / raw)
  To: Peter Zijlstra
  Cc: LKML, Frederic Weisbecker, Ingo Molnar, Thomas Gleixner,
	Linus Torvalds

Hi,

Optimizing the preempt_count operations (PREEMPT_ACTIVE + preempt_disable())
in a single operation from __schedule() callers was an idea of Linus a
few month ago. Here is a re-iteration, with a few header cleanups along
the way.

git://git.kernel.org/pub/scm/linux/kernel/git/frederic/linux-dynticks.git
	sched/preempt

HEAD: c8bda0e6afc163e7e2804d30b9e4301652dc679c

Thanks,
	Frederic
---

Frederic Weisbecker (7):
      preempt: Merge preempt_mask.h into preempt.h
      preempt: Rearrange a few symbols after headers merge
      preempt: Rename PREEMPT_CHECK_OFFSET to PREEMPT_DISABLE_OFFSET
      preempt: Disable preemption from preempt_schedule*() callers
      sched: Pull preemption disablement duty up to __schedule() callers
      preempt: Fix out of date comment
      preempt: Remove PREEMPT_ACTIVE unmasking off in_atomic()


 arch/m68k/include/asm/irqflags.h |   3 -
 include/linux/bottom_half.h      |   1 -
 include/linux/hardirq.h          |   2 +-
 include/linux/preempt.h          | 123 ++++++++++++++++++++++++++++++++++++++-
 include/linux/preempt_mask.h     | 117 -------------------------------------
 include/linux/sched.h            |   2 +-
 kernel/sched/core.c              |  29 +++------
 lib/radix-tree.c                 |   2 +-
 8 files changed, 133 insertions(+), 146 deletions(-)

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2015-05-11 15:56 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2015-05-11 15:08 [RFC PATCH 0/7] preempt: A few headers cleanups and preempt_schedule*() optimizations Frederic Weisbecker
2015-05-11 15:08 ` [PATCH 1/7] preempt: Merge preempt_mask.h into preempt.h Frederic Weisbecker
2015-05-11 15:08 ` [PATCH 2/7] preempt: Rearrange a few symbols after headers merge Frederic Weisbecker
2015-05-11 15:08 ` [PATCH 3/7] preempt: Rename PREEMPT_CHECK_OFFSET to PREEMPT_DISABLE_OFFSET Frederic Weisbecker
2015-05-11 15:08 ` [PATCH 4/7] preempt: Disable preemption from preempt_schedule*() callers Frederic Weisbecker
2015-05-11 15:51   ` Peter Zijlstra
2015-05-11 15:08 ` [PATCH 5/7] sched: Pull preemption disablement duty up to __schedule() callers Frederic Weisbecker
2015-05-11 15:52   ` Peter Zijlstra
2015-05-11 15:56     ` Frederic Weisbecker
2015-05-11 15:08 ` [PATCH 6/7] preempt: Fix out of date comment Frederic Weisbecker
2015-05-11 15:08 ` [PATCH 7/7] preempt: Remove PREEMPT_ACTIVE unmasking off in_atomic() Frederic Weisbecker

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox