The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Jean Delvare <jdelvare@suse.de>
To: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
Cc: Greg KH <gregkh@linuxfoundation.org>,
	Dan Carpenter <dan.carpenter@oracle.com>,
	One Thousand Gnomes <gnomes@lxorguk.ukuu.org.uk>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 WIP 5/5] paride: use new parport device model
Date: Wed, 20 May 2015 10:07:48 +0200	[thread overview]
Message-ID: <20150520100748.06c2eeed@endymion.delvare> (raw)
In-Reply-To: <1430907377-17147-5-git-send-email-sudipm.mukherjee@gmail.com>

Hi Sudip,

On Wed,  6 May 2015 15:46:17 +0530, Sudip Mukherjee wrote:
> modify paride driver to use the new parallel port device model.

Leading capital please ;-)

> 
> Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
> ---
> 
> in v4 of i2c-parport patch Jean mentioned to use the full name while
> in probe. That has been done in other drivers except this one.
> The higher layer drivers (pcd , pd etc.) are appending the unit number
> to the name before the name is being sent to the lower level (paride).

Mmmpf. If not all drivers can stick to the convention, this kind of
voids my original point.

Anyway... Again not a complete review, just two things which caught my
eye:

> -static int pi_register_parport(PIA * pi, int verbose)
> +static int pi_register_parport(PIA *pi, int verbose, int unit)
>  {
>  	struct parport *port;
> +	struct pardev_cb *par_cb;
>  
>  	port = parport_find_base(pi->port);
>  	if (!port)
>  		return 0;
> -
> -	pi->pardev = parport_register_device(port,
> -					     pi->device, NULL,
> -					     pi_wake_up, NULL, 0, (void *) pi);
> +	par_cb = kzalloc(sizeof(*par_cb), GFP_KERNEL);
> +	if (!par_cb) {
> +		parport_put_port(port);
> +		return 0;
> +	}
> +	par_cb->flags = 0;
> +	par_cb->wakeup = pi_wake_up;
> +	par_cb->private = (void *)pi;
> +	pi->pardev = parport_register_dev_model(port, pi->device, par_cb,
> +						unit);

If pi->device already includes the device number, and you are passing
it again as unit, won't you end up with odd names like pcd0.0, pcd1.1,
pcd2.2 etc?

>  	parport_put_port(port);
> +	kfree(par_cb);

If you don't need par_cb anywhere else then you shouldn't be allocating
it dynamically. It's small enough to fit on the stack really.

-- 
Jean Delvare
SUSE L3 Support

  parent reply	other threads:[~2015-05-20  8:07 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-05-06 10:16 [PATCH v5 WIP 1/5] parport: add device-model to parport subsystem Sudip Mukherjee
2015-05-06 10:16 ` [PATCH v5 WIP 2/5] staging: panel: use new parport device model Sudip Mukherjee
2015-05-19 11:18   ` Dan Carpenter
2015-05-20  8:23   ` Jean Delvare
2015-05-06 10:16 ` [PATCH v5 WIP 3/5] i2c-parport: define ports to connect Sudip Mukherjee
2015-05-19  7:50   ` Jean Delvare
2015-05-19  8:44     ` Sudip Mukherjee
2015-05-19  9:28       ` Jean Delvare
2015-05-19  9:58         ` Sudip Mukherjee
2015-05-19 11:23   ` Dan Carpenter
2015-05-19 12:23     ` Jean Delvare
2015-05-06 10:16 ` [PATCH v5 WIP 4/5] i2c-parport: use new parport device model Sudip Mukherjee
2015-05-20  7:57   ` Jean Delvare
2015-05-20  8:16     ` Sudip Mukherjee
2015-05-06 10:16 ` [PATCH v5 WIP 5/5] paride: " Sudip Mukherjee
2015-05-19 11:32   ` Dan Carpenter
2015-05-19 12:32     ` Sudip Mukherjee
2015-05-20  8:07   ` Jean Delvare [this message]
2015-05-20  8:33     ` Sudip Mukherjee
2015-05-19 11:08 ` [PATCH v5 WIP 1/5] parport: add device-model to parport subsystem Dan Carpenter
2015-05-19 13:18   ` Sudip Mukherjee
2015-05-20  7:54 ` Jean Delvare

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150520100748.06c2eeed@endymion.delvare \
    --to=jdelvare@suse.de \
    --cc=dan.carpenter@oracle.com \
    --cc=gnomes@lxorguk.ukuu.org.uk \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sudipm.mukherjee@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox